Bug Hunting Session
Bug 62299 - Libvisio: Visio document cannot be opend by Draw
Summary: Libvisio: Visio document cannot be opend by Draw
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard: BSA target:4.1.0 target:4.0.2
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-13 14:43 UTC by Reinhard Weber
Modified: 2013-12-15 22:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Visio document (inside a Zip archive) (124.92 KB, application/zip)
2013-03-13 14:43 UTC, Reinhard Weber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Reinhard Weber 2013-03-13 14:43:25 UTC
Created attachment 76477 [details]
Sample Visio document (inside a Zip archive)

Problem description: Draw shows "Allgemeiner Ein-Ausgabefehler" (German Version 4.0.1.2)

Steps to reproduce:
1. Please try to open the attached file in Draw
2. ....
3. ....

Current behavior: Error message

Expected behavior: Display the content

              
Operating System: Windows XP
Version: 4.0.1.2 release
Comment 1 Valek Filippov 2013-03-15 03:27:46 UTC
Fridrich, quick check -- nothing special in the file.
(Preview is a little bit strange -- BMP wrapped into WMF, while in VSDv11 I would expect EMF)
Comment 2 Commit Notification 2013-03-15 12:58:10 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa479a03390e9a779321fae26146cc1493cdf97c

Don't fail if the end of characters is reached after a field fdo#62299



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2013-03-15 13:49:39 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8efcf225f3f8fe57a8a6a46d397c90d04e7073d&h=libreoffice-4-0

Don't fail if the end of characters is reached after a field fdo#62299


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2013-03-18 10:20:28 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e56096755668160dd569aab4be8563450e2d17d&h=libreoffice-4-0-2

Don't fail if the end of characters is reached after a field fdo#62299


It will be available already in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Fridrich Strba 2013-03-22 08:36:55 UTC
Setting to resolved-fixed, please verify in the upcoming 4.0.2 RC2 and the 4.0.2 release
Comment 6 Rainer Bielefeld Retired 2013-04-10 05:45:09 UTC
Modified Assignee due to facts to ease finding of experts via Bugzilla