Download it now!
Bug 62342 - UI: Will Donate $1000 USD for 'Reveal Codes' feature in LibreWriter
Summary: UI: Will Donate $1000 USD for 'Reveal Codes' feature in LibreWriter
Status: RESOLVED DUPLICATE of bug 34002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-14 15:38 UTC by Paul D. Wood
Modified: 2013-08-29 20:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul D. Wood 2013-03-14 15:38:24 UTC
Dear LOS (LibreOffice Support):

This is not a bug, but it is a UI request. I am willing to donate $1,000 USD, half now if active development is being pursued on this item with a deadline by the June 31st, 2013 and the last half once it's published in a release edition/update (if completed sooner it may incur a bonus/tip) -- for the implementation of a 'reveal codes' feature natively within LibreOffice; much like WordPerfect has. This a a truly powerful and simple feature that WordPerfect has a voluntary monopoly on. I believe LibreOffice would garner many converts with inclusion of this feature alone and I myself would rather see our company (and society) use open-source programs in lieu of proprietary applications.

I know for a fact that $1,000 USD is a lot for a single feature in a word processor program, but if the economic utility/value is scaled over the life of myself and the life of my company then I see a donation of $1,000 now as more than worth the investment.

If you think I'm joking of 'pulling your leg,' please feel free to call me or email me. I assure you that I'm not, I'm trying to grow my company and in doing so I plan on using OSS as much as possible. Lastly, see attached screenshot.

US Mobile # (478)335-0504
US Email: paul@sebringengineering.net
-
Paul D. Wood, E.I.T
Operating System: Windows 7
Version: 3.6.5.2 release
Comment 1 Michael Meeks 2013-03-14 16:05:46 UTC
Hi Paul,

This feature is rather commonly requested, but not insignificantly hard to implement :-) $1000 is a great sum to pledge though - perhaps you could head to:

http://www.freedomsponsors.org/core/issue/?s=&project_id=149&project_name=LibreOffice

And make that more formal ? :-)

Of course there are per-se no "codes" in LibreOffice to reveal, so I would make sure you phrase the task in a way that is actually do-able in linear time: things like styles, and table structures may require a different approach to show the whole document model and allow debugging it ( which is what I think you really want - right ? :-)

Thanks for supporting the project.
Comment 2 ign_christian 2013-07-23 08:09:05 UTC
Is it duplicate to Bug 34002?
Comment 3 retired 2013-07-23 09:39:26 UTC
Paul: As Michael said, make that offer formal on Freedom Sponsors.

@ign_christian: Most times your dupe suggestions are very sane to me. I think you can just set state to duplicate yourself. You are very active on here and have great knowledge of LO, so just trust your judgement. I think in almost all cases you are on a very right track. :)

Also maybe you wanna hop on QA IRC? Never saw you there so far...

*** This bug has been marked as a duplicate of bug 34002 ***