Bug Hunting Session
Bug 62349 - Calc crashes when a newly created chart copied to clipboard
Summary: Calc crashes when a newly created chart copied to clipboard
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-14 19:13 UTC by szz
Modified: 2019-02-06 19:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example data table ods and error message png (14.82 KB, application/zip)
2013-03-14 19:13 UTC, szz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description szz 2013-03-14 19:13:32 UTC
Created attachment 76537 [details]
example data table ods and error message png

When a chart is created with hierarchical axis labels (ods attached)
and the ods is not saved yet, CTRL-C cause crash in Calc.

If the ods is already saved with the created chart then copy is working correctly.

steps to reproduce:
1: open a new Calc spreadersheet
2: create a source data table like this:

		collabel1	collabel2	collabel3	collabel4
group1	rowlabel1	2	3	4	5
	rowlabel2	4	5	3	4
group2	rowlabel3	3	5	6	3
	ro1lable4	3	5	4	2

3: select all data cells
4: create a chart with insert/chart menu
5: (single) click to an empty cell to finalize the chart
6: (single) click back inside the chart to select it
7: press CTRL-C

current behaviour:
- runtime error window is appearing and application is exiting


waited behaviour:
- chart should be copied to clipboard
Comment 1 m.a.riosv 2013-03-14 22:45:44 UTC
No reproducible
Win7x64

LibreOffice Version 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)

Sorry szz, It is not right set up the status as NEW without any confirmation from other person than you.
Comment 2 szz 2013-03-15 14:33:44 UTC
(In reply to comment #1)
> No reproducible
> Win7x64
> 
> LibreOffice Version 4.0.2.1 (Build ID:
> 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)
> 
> Sorry szz, It is not right set up the status as NEW without any confirmation
> from other person than you.


Hi,
Thanks, your comment was helpful anyway. I have downloaded now the same pre release version that you have now and it seems that version is not affected by the problem (My OS is: XP 32 bit)


What do you think, the bug report should be set to resolved or not in this case?
Comment 3 szz 2013-03-15 14:46:35 UTC
> Sorry szz, It is not right set up the status as NEW without any confirmation
> from other person than you.

I see only NEW/ASSIGNED/RESOLVED/NEEDINFO statuses now and when I send a new bug its default is NEW.  As I remember some months ago default was UNCONFIRMED but now it is not. Or maybe did I sg wrong? I have sent yesterday 2 bugs and another one is NEW as well and I cannot change to UNCONFIRMED because that option is missing.
Comment 4 Markus Mohrhard 2013-03-18 02:00:38 UTC
Marking as Resolved - Worksforme according to comments.

I did not check it but if it still happens in master/4.0.2.1 please reopen and I'll look into it.
Comment 5 Commit Notification 2019-02-06 19:02:35 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e61a5b34468474bdd359f0aa61561657f601da0f%5E%21

uitest for bug tdf#62349

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.