Bug Hunting Session
Bug 62546 - Standardize menus for (access to) headers and footers
Summary: Standardize menus for (access to) headers and footers
Status: RESOLVED DUPLICATE of bug 86440
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-20 04:05 UTC by bugquestcontri
Modified: 2016-04-14 16:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-03-20 04:05:16 UTC
Problem description: 

Header & Footer can be accessed, inserted, and edited in 
Writer via Inser menu
Calc via  Edit menu
Impress cia View menu
Draw via Master layout
Base and Math not used thus not commented

For each component, as a standalone application, the menus make kind of sense. However, to increase productivity a standard should be introduced to make menus easier to remember and avoid long searching time creating frustration.

I am willing to test to feature in a parallel / portable installation.
Operating System: Windows XP
Version: 3.6.5.2 release
Comment 1 Owen Genat (retired) 2013-12-14 13:08:26 UTC
Confirmed under Ubuntu 10.04 x86_64 using v3.3.0.4 OOO330m19 Build: 6 and v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a so it would appear the indicated options have always been this way. Status set to NEW as I also feel some consistency here would be a good thing. Whether this is done by grouping the existing menu options (e.g., under Edit) or via right-click context menu (e.g., Page > Header/Footer) or via active floating UI object (e.g., like that introduced in v3.5) would seem somewhat arbitrary. Consistency across the various components would seem to be the key aspect.

Component set to UI. Version set to Inherited From OOo. Platform set to All/All. Summary edited for clarity.
Comment 2 Owen Genat (retired) 2014-01-06 10:28:26 UTC
Setting version back from "Inherited From OOo" to what it was prior (for bugs marked enhancement), for QA tracking purposes. My mistake. Apologies.
Comment 3 Yousuf Philips (jay) (retired) 2016-04-14 16:18:12 UTC
This was fixed in 4.4.

*** This bug has been marked as a duplicate of bug 86440 ***