Download it now!
Bug 62555 - UI: Slide names not displayed in navigator
Summary: UI: Slide names not displayed in navigator
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-20 12:23 UTC by bugquestcontri
Modified: 2013-03-29 08:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
file created while writing steps to reproduce - I can be contacted (37.26 KB, application/vnd.oasis.opendocument.presentation)
2013-03-20 12:23 UTC, bugquestcontri
Details
Screenshot shows no problem with reporter's edited sample document (168.07 KB, image/png)
2013-03-24 12:11 UTC, Rainer Bielefeld Retired
Details
this attachement shows slide titles in the navigator. The presentation used is created in ppt and only opened in Impress (3.25 KB, image/gif)
2013-03-24 12:21 UTC, bugquestcontri
Details
2 images with explanations inside (47.01 KB, application/vnd.oasis.opendocument.graphics)
2013-03-26 14:46 UTC, bugquestcontri
Details
a test presentation created in PowerPoint (18.50 KB, application/powerpoint)
2013-03-29 08:27 UTC, bugquestcontri
Details
a screenshot of the navigator and explanations (18.49 KB, application/vnd.oasis.opendocument.graphics)
2013-03-29 08:29 UTC, bugquestcontri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugquestcontri 2013-03-20 12:23:29 UTC
Created attachment 76812 [details]
file created while writing steps to reproduce - I can be contacted

Problem description: 
in the navigator, the slide is not displayed by its title, and shapes are not described by their type. Additionally clicking on the shape name in the navigator does not mark the related shape in the slide

1 Steps to reproduce:
2 open new presentation
3 add presentation title and subtitle
4 add new slide – ctrl+n
5 type slide title – click into title field and type
6 type text
7 add new slide – ctrl+n
8 select layout “title only”
9 add rectangular object
10 click inside shape and add text
11 add oval shaped object
12 click inside shape and add text
13 add new slide – ctrl+n 
14 click an type slide title
15 click and type this text

Current behavior:

In the navigatort slide titles are NOT displayed, shapes are NOT listed by their type, and clicking on the shapes names in navigator DOES NOT mark shapes in the normal view


Expected behavior:

In the navigatort slide titles are displayed, shapes are listed by their type, and clicking on the shapes names in navigator marks shapes in the normal view
Operating System: Windows XP
Version: 3.6.5.2 release
Comment 1 Rainer Bielefeld Retired 2013-03-20 15:24:17 UTC
I reduce this report to the useful part of the Summary line, and that is definitively INVALID, even reporter's sample shows that slide names are shown in Navigator.

@bugquestcontri@online.de
Only one issue per report!
<http://wiki.documentfoundation.org/BugReport#General_information> item 4

Indeed the Navigator is rather useless because Shapes can't be selected (that never worked, also not in DRAW), In you sample when I double click a shape in navigator focus does not change to that slide and and and.
Can you please check whether we already have reports and if not do the reports?
Comment 2 bugquestcontri 2013-03-24 11:17:54 UTC
"...and that is definitively INVALID, even reporter's sample shows that slide names are shown in Navigator."

Above statement is only valid if the navigator is supposed to show only "slide 1", "slide 2", etc as information about the slides. However, this makes the navigator more or less useless because in Normal View at the left side the "Slides" -window provides more information.

Additionally I opened a ppt-file (originally created in PowerPoint) in Impress and the navigator window shows the title of each slide.

Therefore I kindly ask to regards the display of only slide 1", "slide 2", etc as a bug.


As for reporting of two issues, I considered both observations as the same bug, thus reported it as one. Please feel free to split it up according to the best working procedure of the dev team.
Comment 3 Rainer Bielefeld Retired 2013-03-24 11:45:31 UTC
I still have no idea what reporter's problem is. My WIN7 LibO 3.6.6.1 definitively shows default and custom slide names in Navigator 

@bugquestcontri:
Please invest some care to make your problem reproducible. That means: step by step instruction with expected and actual behavior concerning slide names, underpinned with screenshots with comments. Your comments concernint .ppt behavior do not help at all.
Comment 4 Rainer Bielefeld Retired 2013-03-24 12:11:45 UTC
Created attachment 76958 [details]
Screenshot shows no problem with reporter's edited sample document
Comment 5 bugquestcontri 2013-03-24 12:21:50 UTC
Created attachment 76959 [details]
this attachement shows slide titles in the navigator. The presentation used is created in ppt and only opened in Impress
Comment 6 bugquestcontri 2013-03-24 12:49:58 UTC
Looking at Rainer's screenshot the error is to be seen.

But first to my slide titles as they are and as they appear in my navigator (see my screenshots in attached opd-file)

-"presentation title",  apprears in my navigator as "slide 1"
-"title of slide 2", appears in my navigator as "slide 2"
-"title of slide 3", appears in my navigator as "slide 3"
-"steps to reproduce", appears in my navigator as "slide 4"
-"result description & screen shots", appear in my navigator as "slide 5"

Now at Rainer screenshot where the titles of my original slide are good to be seen

-"presentation title",  appears in Rainer's navigator as "Folie 1" (=slide 1)
-"title of slide 2", appears in Rainer's navigator as "Custom Folie 2"
-"title of slide 3", appears in Rainer's navigator as "Folie 3 renamed by Rainer"
-"steps to reproduce", appears in Rainer's navigator as "verydifferentname"
-"result description & screen shots", appear in Rainer's navigator as "Folie 5"

Thus, also Rainer's navigator does not show the real slide titles. I assume now that whenever the slide name in Rainer's navigator is "Folie x" (Folie = slide in German), it is the default slide name in the navigator, but is not the real slide title. I regard the not showing the real slide name in the navigator as the bug.

The attached screenshot 
" this attachement shows slide titles in the navigator. The presentation used is created in ppt and only opened in Impress" 
shows what is displayed in the navigator when I open a file once created in MS Powerpoint and not modified in Impress.

I made an additional test, created a odp file with slide titles entered by myself, saved the files as ppt, closed LibO and opened the file again. In this case the real slide titles do not appear in the navigator but only the generic "Slide 1", "Slided 2"....

To rephrase my issue in simple words: A presentation created in PowerPoint and opened in Impress shows the expected and correct slide titles in the navigator and then the navigator becomes a meaningful tool.


Side question:
Rainer how did you rename the slides in the navigator? I assume you renamed there because the slide title is my original. In my LibO I cannot change the slide name in the navigator.
Comment 7 Rainer Bielefeld Retired 2013-03-24 15:01:29 UTC
(In reply to comment #6)
You can rename the slide after right click on slide in Slides Pane.
Can it be that you expect to see the Title from the Title text box on the slide as slide name? I doubt that we have that function in LibO
Comment 8 bugquestcontri 2013-03-26 14:45:15 UTC
To avoid misunderstanding I attached a file explaining what I mean with "navigator window" and "slides pane".
Comment 9 bugquestcontri 2013-03-26 14:46:28 UTC
Created attachment 77059 [details]
2 images with explanations inside
Comment 10 Rainer Bielefeld Retired 2013-03-26 15:07:40 UTC
(In reply to comment #9) 
We use the same words for 'Navigator' and 'Slides Pane'.

You misunderstand what the Slide name is. 
In your screenshot you see a "Slide 3" in Navigator.

0. Open your Presentation from LibO Start Center
1. In Slides Pane for this "Slide 3" 'Right click -> Rename'
   > You see old name
2. 'Type new Name -> <ok>
   > You see the new name in Navigator

So the Names are shown correctly in Navigator,

What's concerning my suspect in Comment 7?
Comment 11 bugquestcontri 2013-03-27 01:12:44 UTC
OK now we have common understanding on slide pane, navigator, slide name and also slide title.

I also can change slide NAMES in slides pane and see the slide NAME in the navigator.

For me the navigator (in Impress) was always a useless tool because I could not see more than slide 1, slide 2,...  I never used it because the slide pane offered the same numbers plus I could see the slide to a certain and sufficient extend

When I loaded once a presentation, which was created in MS PowerPoint and the Navigator was on, I suddenly saw the slide TITLES in the navigator window. And this made a lot of sense to me. So I tested around with old and new Impress presentations. My conclusion was that we have bug in Impress because I could not see the slide TITLE in the navigator. 

Now, I understand a PowerPoint and Impress difference: PowerPoint assigns the slide TITLE somehow to something which Impress interprets as slide NAME and shows it in the navigator. Impress differentiates between slide TITLE and NAME and shows only the NAME in the navigator.

As I see it now, assigning NAMES to a slide doesn't is of no help for my way of working in presentations. There might be reason for the differentiation between NAME and TITLE, I just don't get it yet.

Leaving the usefulness of the above-mentioned differentiation for the sake of discussion aside, I would now rename my bug report into an enhancement request: Please enable the navigator to read and display the slide TITLE because then one has a long list of slide TITLEs, which help to navigate quickly through a large portion of a presentation. (The navigator window can show about 40 slides.) With such a functionality the navigator would be an alternative to the slide pane with different features. However, I would also include in the enhancement request the functionality that slides can be dragged and dropped in the navigator to change the slide sequence in the presentation. I regard such an enhanced navigator as great tool and would use it, working situation depended, with or without the slide pane. 

What do you think about such an enhancement request?

PS
I think with this comment also your comment 7 is covered.
Comment 12 bugquestcontri 2013-03-29 08:27:13 UTC
Created attachment 77188 [details]
a test presentation created in PowerPoint

this test presentation  was created in PowerPoint, once opened in Impress but never saved using Iimpress
Comment 13 bugquestcontri 2013-03-29 08:29:12 UTC
Created attachment 77189 [details]
a screenshot of the navigator and explanations

the screeshot shows the navigator displaying the PowerPoint slide TITLES and slide NAMES in Impress.