Bug 62559 - import of hebrew docx, parts of it load in squares on Windows version (work on Linux)
Summary: import of hebrew docx, parts of it load in squares on Windows version (work o...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0
Keywords:
: 71982 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-20 15:10 UTC by Nadav
Modified: 2013-12-18 16:06 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the problem documents (17.76 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-03-20 15:10 UTC, Nadav
Details
screenshot in LO (141.60 KB, image/png)
2013-03-20 15:10 UTC, Nadav
Details
Screenshot in Office 2003 (49.14 KB, image/png)
2013-03-20 15:11 UTC, Nadav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav 2013-03-20 15:10:17 UTC
Created attachment 76821 [details]
the problem documents

the attach documents open in office 2003 correctly but badly in lo
Comment 1 Nadav 2013-03-20 15:10:57 UTC
Created attachment 76822 [details]
screenshot in LO
Comment 2 Nadav 2013-03-20 15:11:46 UTC
Created attachment 76823 [details]
Screenshot in Office 2003
Comment 3 Jorendc 2013-03-20 20:07:02 UTC
Hi,

Thanks for reporting!

I can not reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c) and Version 4.1.0.0.alpha0+ (Build ID: b4966ea69ff0ad6944bd16d8a09ecb27a1704c1).

Maybe Windows-only?

Kind regards,
Joren
Comment 4 Jacques Guilleron 2013-03-21 00:30:11 UTC
Hello,

נוהל נסיעות לחול.docx don't work, but .doc version work with 
LO 4.0.2.1  and LOdev 4.0.3.0+ (Build ID: 2a2ada8fcfeb18b91599a8fb09f3c2081e66abe)
on windows 7 Home Premium.

So it's a docx issue.

Have a nice day,

Jacques Guilleron
Comment 5 Nadav 2013-03-21 08:27:25 UTC
It load correctly on Linux so it's windows only bug.

It's still correct for windows version.
Comment 6 Jacques Guilleron 2013-03-21 15:30:03 UTC
Hello Nadav,

The reason why docx don't work is the use of a special font named Arial(body CS). With Arial font (normal), no issue. Perhaps if you install this font on Windows, you will get the correct wieving for this document.

@Jorendc: Which font is used to replace Arial(body CS) for this document on Linux?

Regards,

Jacques Guilleron
Comment 7 Nadav 2013-03-21 18:03:46 UTC
But it test on the same computer on windows so it must include the font since word open it correctly and libre office if I save it in doc.
Comment 8 Jacques Guilleron 2013-03-21 21:23:14 UTC
Hi, 

You are right, Nadav. I found why you have this special setting:
http://www.wordbanter.com/showthread.php?t=113251
Those are your RtL settings.
The only result here is:
With Word, if I change the font Arial(body CS) for Arial and save the document as docx, I read it on LibreOffice without issue.

Regards,

Jacques Guilleron
Comment 9 Maxim Monastirsky 2013-07-31 14:12:45 UTC
@Jacques Guilleron: I think you right about LO doesn't pick the right font, as a similar issue described in bug 64232. I guess that LO tries to use 'Calibri' font instead of 'Arial', and because 'Calibri' doesn't contain Hebrew letters at all, it shows squares instead. It's a known UniScribe behavior, that sometimes it returns the .notdef glyph (It's from where the square comes) when requesting a missing glyph.

But the current issue is about something else, as even if LO for some reason can't display some characters, it still should give the user a readable document, as it does on Linux.
Comment 10 Urmas 2013-08-01 09:00:07 UTC
Arial (Body (CS)) is a UI name for Arial font, because it comes from the document theme.

Obviously is should be imported as Arial by LO.
Comment 11 Maxim Monastirsky 2013-11-25 10:45:29 UTC
*** Bug 71982 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2013-12-18 16:06:10 UTC
Fixed by the patches of Bug 64232. Tested with a master build with Build ID: 4c539fac018dfd44cd8db52161a8cb930c627da7.