Download it now!
Bug 62592 - TDF Site : Fresh channel should include warning about being an early state iteration of LO
Summary: TDF Site : Fresh channel should include warning about being an early state it...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL: http://www.libreoffice.org/internatio...
Whiteboard:
Keywords:
: 85816 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-21 13:35 UTC by Rainer Bielefeld Retired
Modified: 2019-03-15 04:55 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-03-21 13:35:35 UTC
On many localized sites I see a download recommendation for 4.0.1 without any warnings. That is unacceptable lightheaded, 4.0.1 is the first bug correction after 4.0.0. what really only was for hardboiled early testers.

Please add a hint for whom this version can be recommended (still early interested testers) like on <http://de.libreoffice.org/download/>

and add a link direct ink to 3.6.5 for normal users on the same page
[de][sr] link for 3.6.5 not prominent enough
[eo][tr] should not show green checkbox for 4.0.1

[sv] Missing warning, missing prominent link to 3.6.5
[zh-cn] should not show green checkbox for 4.0.1
[vi][zh-tw] Missing warning, should not show green checkbox for 4.0.1, Missing prominent link to 3.6.5

I only added some examples hire, it's too expensive for me to write down all results. More or less all localized websites have at least one of following problems:

a) missing warning (early testers only)
b) missing prominent link to 3.6.5 for normal users
c) checkbox on green circle for 4.0.1 or 4.0.0
Comment 1 Michael Meeks 2013-03-28 09:58:57 UTC
Certainly an issue - IMHO we do need to improve this even for the en_US site - which (AFAICS) doens't make it particularly easy to see the older versions either.
Comment 2 Rainer Bielefeld Retired 2013-03-28 14:15:51 UTC
Not directly related, but worthy of remark: the Auto-Updater recommendations are well-thougt-out May be that mechanism can somehow be used for the website?
Comment 3 retired 2013-03-30 10:56:56 UTC
Related: Similar request for Portable LO version:
https://bugs.freedesktop.org/show_bug.cgi?id=62928
Comment 4 retired 2014-08-11 14:39:41 UTC
http://www.libreoffice.org/download/libreoffice-fresh/

The website now much better differentiates between

* pre-releases
* fresh channel
* still channel

That solves this bug.
Comment 5 retired 2014-08-11 14:40:31 UTC
http://de.libreoffice.org/download/ even has the requested warning about 4.3 being very early.
Comment 6 ign_christian 2014-08-11 15:10:08 UTC
Such warning not exist in main site: http://www.libreoffice.org/download/libreoffice-fresh/
Comment 7 Cor Nouws 2014-08-12 09:26:18 UTC
(In reply to comment #6)
> Such warning not exist in main site:
> http://www.libreoffice.org/download/libreoffice-fresh/

Indeed. There seems to be some room for improvement.
Comment 8 Cor Nouws 2014-08-12 11:57:41 UTC
I would think of something in the following direction:

"LibreOffice Fresh is the version with the most and latest features, but this comes with more glitches that are not yet solved.
For conservative users, the Still version might therefore be a better idea.
In general however, from version X.Y.2, the number of problems with the Fresh version is pretty low for most users."
Comment 9 chs 2014-11-04 16:47:32 UTC
*** Bug 85816 has been marked as a duplicate of this bug. ***
Comment 10 chs 2014-11-04 16:49:34 UTC
All, anything that is not directly related to LibreOffice code is done on RedMine. Check out the tracker issue #793 there.
Comment 11 V Stuart Foote 2014-11-04 17:03:57 UTC
Here is a link, in the Marketing project, https://redmine.documentfoundation.org/issues/793