Bug Hunting Session
Bug 62648 - LanguageTool 2.0 Grammar checker fails to flag lose/loose
Summary: LanguageTool 2.0 Grammar checker fails to flag lose/loose
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-22 17:32 UTC by bugspam
Modified: 2015-11-24 11:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugspam 2013-03-22 17:32:31 UTC
Problem description: 
The Grammar checker fails to flag misuse of the word "lose" rather than "loose". 

Steps to reproduce:
1. Type in a phrase such as "knocked lose"
2. Click "Spelling and Grammar" button
3. Spell Check box opens with no problems detected

Current behavior:
It doesn't see the incorrect grammar.

Expected behavior:
It should flag the bad grammar. 
              
Operating System: openSUSE
Version: 3.6.0.4 release
Comment 1 Brenda Granados 2013-03-28 14:51:57 UTC
Hi, thank you for submitting a report. A grammar checker is an optional extension to LibreOffice, that must be installed separately. Did you install a grammar check extension? Otherwise, the spell checker would only be able to catch a word if it is spelled incorrectly, and "lose" is a word in the dictionary.

Version: 4.0.2.1 (Build ID: 7e5467ff8f30d821f4fbf69cb2769163eb64c2c)
Platform: Ubuntu Linux 12.04 LTS x64


-Brenda
Comment 2 bugspam 2013-03-28 17:40:18 UTC
Yes, I have LanguageTool 2.0 installed. Although now I'm not sure if it's working. It's hard to come up with bad grammar to check it with.
Comment 3 tommy27 2013-09-01 20:01:59 UTC
are you still facing this issue with recent Language Tool 2.2 ( http://extensions.libreoffice.org/extension-center/languagetool ) and recent LibO 4.0.5 or 4.1.1 ?
Comment 4 Daniel Naber 2013-09-07 12:03:23 UTC
I have copied this bug to LanguageTool (https://sourceforge.net/p/languagetool/bugs/192/) and I'm closing this report.