Download it now!
Bug 62655 - FORMATTING: Formatting Text Boxes with PPT File Error
Summary: FORMATTING: Formatting Text Boxes with PPT File Error
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-23 01:31 UTC by ljelly
Modified: 2015-03-01 09:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ppt file with a close passage format slide. this occurs with multiple ppt files not just this one. (1.59 MB, application/vnd.ms-powerpoint)
2013-03-23 01:31 UTC, ljelly
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ljelly 2013-03-23 01:31:56 UTC
Created attachment 76924 [details]
ppt file with a close passage format slide. this occurs with multiple ppt files not just this one.

Problem description: 

Steps to reproduce:
1. .... Open PPT File Text Boxes are resized and not in order, or on the same line as they are on Microsoft Office 2010 or 2007 Windows.
2. .... Text Boxes need to be resized and converted.
3. ....

Current behavior:
1. .... Open PPT File Text Boxes are resized and not in order, or on the same line as they are on Microsoft Office 2010 or 2007 Windows.
2. .... Text Boxes need to be resized and converted.
3. .... Only occurs on slides that are in a close passage format.

Expected behavior: Text Boxes should fit on the close passage line without any formatting errors.
Operating System: All
Version: 4.1.0.0.alpha0+ Master
Comment 1 Joel Madero 2013-03-25 17:08:30 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Normal - prevents high quality work
High - formatting is quite terrible, if you were to open a PPT sent from someone else the file is almost unusable as it is. Nothing very special about the file so this could potentially affect a lot of users

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 QA Administrators 2015-02-19 15:44:45 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 3 Jean-Baptiste Faure 2015-03-01 09:23:14 UTC
This PPT slideshow works perfectly in my LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64.

The only small problem is in slide 20 in which the text area has the option "Autofit text" checked in its contextual menu. That has the effect to change the font size (32 --> 30,3) that breaks the alignment with other text boxes. Unchecking this option solves the problem.

Closing as WorksForMe. Please feel free to reopen if you disagree.

Best regards. JBF
Comment 4 ljelly 2015-03-01 09:52:49 UTC
It looks to me testing this is nearly solved on libreoffice 4.4.0.3 on windows. I reported this bug a while ago. The bug has been resolved except for the slide that you mentioned where the text does to fit or align probably due to the font size issue. Is there a way to disable the autofit text option if it is moving the text in the incorrect position automatically when opening files, or an automated way to resize the text so that it can fit in the spaces, without having to disable options manually and change font size? 

I would like to receive some feedback on this issue before I can close this bug.