Download it now!
Bug 62674 - Paste Special -> Formatted Text[RTF] doesn't handle table data correctly
Summary: Paste Special -> Formatted Text[RTF] doesn't handle table data correctly
Status: RESOLVED DUPLICATE of bug 37223
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-23 15:27 UTC by Sebastian
Modified: 2013-10-10 13:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian 2013-03-23 15:27:18 UTC
When copying and pasting special from Calc into Writer - if one chooses "Formatted text[RTF]" as Paste Special option - a table is created in the Writer document. That is good.

However, if one copies a number of cells from Calc, then selects the same number of cells in an existing Writer table, and does a Paste Special -> Formatted Text[RTF] - the data is not pasted correctly across all selected cells - but rather a new table is created in the first cell of the selection. When copying from the spreadsheet program to the text processing program of Another Office Suite, if the same number of cells is selected at both ends (provided they are lined up in the same configuration rows/columns wise) - the paste process is smart enough and it fills them up correctly in the table of the text processing document.

This feature is used and relied on quite heavily in certain work environments - and its absence creates a lot of additional effort in the workflow. It would save a lot of users significant amounts of time if it can be implemented.
Comment 1 Sebastian 2013-03-24 22:06:55 UTC
Just an additional note. I can't decide if this is a bug or an enhancement request. I think the correct (or at least desirable) behaviour should be to paste across the selected cells - but I'm not sure the current behaviour can really be classed as a bug either.
Comment 2 Joel Madero 2013-03-25 16:13:37 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Normal - can prevent high quality work or make it almost impossible to work around, adds substantial time to workflow time

Low - while this is indeed an issue, RTF is not used by the majority of our users, furthermore, unless there is a specific reason why RTF is necessary, we recommend using native file formats as much as possible. Lastly, there is a workaround, even if it's quite tedious (ie. formatting the box again)


+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 ign_christian 2013-10-10 13:24:42 UTC

*** This bug has been marked as a duplicate of bug 37223 ***