Download it now!
Bug 62720 - Cannot "Select All" in some circumstances
Summary: Cannot "Select All" in some circumstances
Status: RESOLVED DUPLICATE of bug 37606
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-25 11:47 UTC by Matthew Francis
Modified: 2013-03-25 14:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2013-03-25 11:47:02 UTC
When a document starts with a table, "Select All" is ineffective for selecting all the text in the document, no matter how many times it is repeated.

To reproduce, create a document like the following:
1. Single cell table containing text (at the very start of the document, no preceding text or newline)
2. Following text outside table

Whether the cursor is initially placed inside or outside the table, repeating "Select All" cycles between selecting the content of the table cell and the table cell itself; the following text outside the table is never selected.



Compare with the following case with correct behaviour:
1. Single newline
2. Single cell table containing text
3. Following text outside table

In this case, when "Select All" is performed outside the table, all text both inside and outside the table is immediately selected. When performed repeatedly from inside the table, the progression

   All text in cell selected -> Whole cell selected -> All text in document selected

results, as expected.



Reproduced on both OSX and Linux
Comment 1 manj_k 2013-03-25 14:44:37 UTC
Thanks, already reported as 'Bug 37606 - EDITING, TABLES: Edit > Select All doesn't work on a document beginning with a table'.

*** This bug has been marked as a duplicate of bug 37606 ***