Download it now!
Bug 62750 - Asian text is displayed twice if Western font is chosen as Asian
Summary: Asian text is displayed twice if Western font is chosen as Asian
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2013-03-26 09:32 UTC by Zild
Modified: 2015-04-07 12:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Japanese Punctuation Bug Screenshot (93.75 KB, image/png)
2013-03-26 09:32 UTC, Zild
Details
Sample document showing error (12.28 KB, application/vnd.oasis.opendocument.text)
2013-03-31 09:52 UTC, Zild
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zild 2013-03-26 09:32:20 UTC
Created attachment 77035 [details]
Japanese Punctuation Bug Screenshot

Under V4.0.1 (and also V3.6) when working in Japanese, entering Japanese punctuation can cause the subsequent Japanese text to be displayed incorrectly. It appears as thought the subsequent text is displayed twice, once on top of the other, in different fonts.

This has been seen with Japanese quotation marks (『』) and the Japanese iteration mark (々).

This occurs under some fonts (e.g. Arial) but in others renders correctly (e.g. MS UI Gothic). My suspicion is it is trying to display the text in both the specified font and the "backup" Asian font.
Comment 1 Urmas 2013-03-27 23:15:45 UTC
Please attach the document itself.
Comment 2 Zild 2013-03-31 09:52:02 UTC
Created attachment 77243 [details]
Sample document showing error

Added sample document to attachments.
Comment 3 Urmas 2013-03-31 18:51:55 UTC
Does the problem goes away if you select MS Gothic or Mincho as the asian font for the second and the third example?
Comment 4 Zild 2013-04-01 18:15:09 UTC
Yes, it goes away then.

From: bugzilla-daemon@freedesktop.org
To: zild_remo@hotmail.com
Subject: [Bug 62750] Asian text is displayed twice if Western font is chosen as Asian
Date: Sun, 31 Mar 2013 18:51:55 +0000


    
      
    
     Urmas
 changed
              bug 62750
        

             
          
            What
            Removed
            Added
          

         
           Summary
           Japanese punctuation causes subsequent text to be displayed incorrectly (text written twice, overlapping)
           
           Asian text is displayed twice if Western font is chosen as Asian
           
         
      
        
            Comment # 3
              on bug 62750
              from  Urmas

        Does the problem goes away if you select MS Gothic or Mincho as the asian font
for the second and the third example?
        
      
      
      You are receiving this mail because:
      
      
          You reported the bug.
Comment 5 Buovjaga 2015-04-07 12:01:49 UTC
The problem is gone now. Setting to WFM.

Win 7 Pro 64-bit, Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fi_FI