Bug Hunting Session
Bug 62837 - Importing docx files with images in text frame gives incorrect layout
Summary: Importing docx files with images in text frame gives incorrect layout
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-27 21:28 UTC by brian.bj.parker99
Modified: 2014-03-19 22:11 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
example Word docx file showing incorrect placement of images in frames (217.48 KB, application/zip)
2013-03-27 21:28 UTC, brian.bj.parker99
Details
Example of images saved as object in Word docx incorrectly placed at start of file (913.73 KB, application/zip)
2013-03-27 22:17 UTC, brian.bj.parker99
Details

Note You need to log in before you can comment on or make changes to this bug.
Description brian.bj.parker99 2013-03-27 21:28:38 UTC
Created attachment 77124 [details]
example Word docx file showing incorrect placement of images in frames

Attached is an example docx file and pdf files from Word and LO.

Figures 1 and 2 are simply inserted images. Figure 3 is an image inserted in a text frame. In LO Figure 3 is incorrectly placed over figure 2.

Ob-OB microarray_test_image_bug_frame3.docx is example docx file
Ob-OB microarray_test_image_bug_frame3_word.pdf is output of Word
Ob-OB microarray_test_image_bug_frame3_lo.pdf is output of LO

The Word version the file was open on was:
Word 2008 for Mac
Version 12.3.1

and the LbreOffice version was:
Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-02-27_17:15:43
Comment 1 brian.bj.parker99 2013-03-27 22:17:53 UTC
Created attachment 77127 [details]
Example of images saved as object in Word docx incorrectly placed at start of file

Attached is an additional example probably related to the previous example. 
This example is a docx file with figures 1 and 2 simple inserted figures and figure 3 inserted as an object (this is based on a file emailed to me- I am not sure exactly how the object was created). In LO figure 3 is incorrectly located at the start of the file. (note: an additional bug that is not directly relevant to this issue is that the object had several properties set in Word i.e. black and white with red background which were not maintained when opened in LO- a separate bug report may be useful for that issue).

lo_test_image_bug1_image_as_object2_lo.pdf is output of LO
lo_test_image_bug1_image_as_object2_word.pdf is output of Word
Comment 2 brian.bj.parker99 2013-03-28 19:21:09 UTC
Some additional information- I noticed that first saving both these examples as a doc file then opening with LO gave the correct layout, so it appears to be a specific problem with docx format.
Comment 3 Jorendc 2013-04-08 21:09:16 UTC
Thanks for reporting.

I can reproduce this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.2 as well as LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 7b515a57eb6a644860715018656ac0b843b62ba . Therefore I mark this as NEW.

I don't know there is a duplicate somewhere around, but because there is a particular file attached, I'm not going to mark this as duplicate without the opinion of a developer who can look at the code.

I mark this as: Normal High
Normal: does prevent you to make high quality work
High: text frames are broadly used in older and newer documents

Kind regards,
Joren
Comment 4 Jorendc 2014-03-19 22:11:52 UTC
Looks fixed to me, tested using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 90dd4320de6ace24e464979630a2c9fbab35f64b
TinderBox: Win-x86@39, Branch:master, Time: 2014-03-19_00:22:53

(In reply to comment #1)
> (note: an additional bug that is not
> directly relevant to this issue is that the object had several properties
> set in Word i.e. black and white with red background which were not
> maintained when opened in LO- a separate bug report may be useful for that
> issue).

Indeed, this is a different issue, please report this in a seperate bug report.

Kind regards,
Joren