Bug Hunting Session
Bug 62873 - Conditional formatting formulas move TWICE the number of rows/columns inserted or deleted
Summary: Conditional formatting formulas move TWICE the number of rows/columns inserte...
Status: RESOLVED DUPLICATE of bug 62206
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: (target:4.1.0)
Keywords: regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-03-28 16:35 UTC by Mark Brown
Modified: 2013-03-30 11:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Try inserting or deleting rows in demo, then check formulas (9.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-28 16:35 UTC, Mark Brown
Details
Simple Sample for Bibisect (7.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-03-29 10:59 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Brown 2013-03-28 16:35:41 UTC
Created attachment 77165 [details]
Try inserting or deleting rows in demo, then check formulas

Conditional formatting formulas move TWICE the number of rows inserted or deleted.
for example:
insert 3 rows moves formula 6 references 6 rows.
See attached
Comment 1 Rainer Bielefeld Retired 2013-03-28 17:47:32 UTC
I believe this one is a variant or "Bug 60311 - EDITING: Copy cells with CONDITIONAL FORMATTING formula with wrong references after paste", what has been fixed for 4.0.2

@Mark Brown
Can you do a test with the 4.0.2RC  available at
<http://www.libreoffice.org/download/pre-releases/>
Comment 2 Mark Brown 2013-03-28 22:10:23 UTC
Still not working.
I installed version 4.0.2.2 without a problem and rebooted.
Problem remains.

Condition 1:
Cell C12 contains conditional format "Cell value is" "greater than" "C13".
Cell D12 contains conditional format "Formula is" "D12>D13".
If you insert three rows above row 12:
Cell C15 now contains conditional format "Cell value is" "greater than" "C19".
Cell D15 now contains conditional format "Formula is" "D18>D19".
It appears to have done the formula adjustments twice.
Comment 3 Rainer Bielefeld Retired 2013-03-29 10:05:03 UTC
[Reproducible] with reporter's sample document and server installation of "LibO  4.0.2.2 rc   -  German UI / German Locale  [Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)]"  {tinderbox: @6, pull time  2013-03-26 12:00(?)} on German WIN7 Home Premium (64bit) with newly created own user profile:

1. open document from LibO start center
2. type an "x into cell A23 to find row easily 
3. Check condition in Cell C23: Refers to C24
4. select rows 1 ... 3 Marking them with mouse at row headers
5. Menu 'Insert -> Rows'
   > 3 rows inserted
6. Check condition in Cell C26 (former C23): 
   Expected: Refers to C27
   Actual: refers to C30

I will do some more research concerning possible relations later
Comment 4 Rainer Bielefeld Retired 2013-03-29 10:52:27 UTC
This bug destroys users' documents.

Already [Reproducible] with 
* Server Installation of "LibO  4.0.0.3   -  GERMAN UI / German Locale  [Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89)]"  {tinderbox: @6, pull time 2013-01-31 11:30(?)} on German WIN7 Home Premium (64bit) with separate  new User Profile 
* server  installation of  "LOdev  4.0.0.1+   -  ENGLISH UI / German Locale  [Build ID:  072fc07107e9849ed7050d18575b42049db9657)]"  {tinderbox: Win-x86@6, pull time 2013-01-16 09:31:57} on German WIN7 Home Premium (64bit) with own separate User Profile 

Was still ok with 
* server-installation of Master "3.7.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: b255de8]" (tinderbox: Win-x86@6-fast, pull time 2012-06-05 23:16:58)
Comment 5 Rainer Bielefeld Retired 2013-03-29 10:59:10 UTC
Created attachment 77203 [details]
Simple Sample for Bibisect

For quick tests concerning affected Versions this document might be more appropriate. Simply insert a row in row 5 and watch the "1" in column F. If it changes from big - bold to standard - small the vest version is affected.

Attention, many older 4.0 versions open the document with broken CF (showing all numbers in standard formatting). For bibisect there you will have to compare the reference in cell with number n column F before and after having inserted row.
Comment 6 Rainer Bielefeld Retired 2013-03-29 11:00:34 UTC
@SMarkus
Please add Witeboard tag “bibisectrequest” if you think that a bibisect result can ease your work.
Please change  Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 7 Rainer Bielefeld Retired 2013-03-29 11:56:59 UTC
Already [Reproducible] with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: 76c921de48ee41716b5a500b892945c704da73c)]"  {tinderbox: Win-x86@6, pull time 2012-12-10 09:43:47} on German WIN7 Home Premium (64bit) with own separate User Profile 

Was still ok with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile
Comment 8 Markus Mohrhard 2013-03-29 12:08:23 UTC
Should be fixed in master and 4.0.3.1. Sorry that this fix did not make it into 4.0.2.2 but it was a bit high risk and I was unable to finish the unit test for it in time.

Testing with a master/daily build highly appreciated.
Comment 9 Rainer Bielefeld Retired 2013-03-30 11:02:22 UTC
Indeed, works fine with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 049ce78144650d92eb6bd73292868f73d37c901) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-03-29_23:59:42" ENGLISH UI / German Locale on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile
Comment 10 Markus Mohrhard 2013-03-30 11:31:46 UTC
Then let us mark it as duplicate of the other bug.

*** This bug has been marked as a duplicate of bug 62206 ***