Bug Hunting Session
Bug 62887 - EDITING: LO Impress Crash When editing notes with bulleted list
Summary: EDITING: LO Impress Crash When editing notes with bulleted list
Status: RESOLVED DUPLICATE of bug 47018
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: high major
Assignee: Cao Cuong Ngo
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-29 01:19 UTC by cranstonide
Modified: 2013-04-09 10:50 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of notes view where I saw crash. (252.04 KB, image/png)
2013-03-29 01:19 UTC, cranstonide
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cranstonide 2013-03-29 01:19:41 UTC
Created attachment 77178 [details]
Screenshot of notes view where I saw crash.

Problem description: Program Crashes when copy/pasting bulleted list items in impress

Steps to reproduce:
1. Start new impress presentation
2. make a new slide
3. Edit notes, use bulleted list. (3+ entries)
4. Copy one item and move it elsewhere in the list
-- Item will appear to be non-bulleted.
5. Click the button to make bulleted
-- Program will crash (I could reproduce 100% of time)

Current behavior:
crash

Expected behavior:
to modify formatting
              
Operating System: Linux (Other)
Version: 4.0.1.2 release
Comment 1 A (Andy) 2013-03-29 08:31:30 UTC
Thank you very much for your bug report.

This bug is reproducible with LO 4.0.1.2 (Win7 Home, 64bit).

-> increased the importance
Comment 2 Jorendc 2013-04-05 18:50:38 UTC
I can not reproduce this behavior using Linux Mint 14 x64 with LibreOffice Version 4.0.2.2 .2.2 (Build id: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3) and Master Version: 4.1.0.0.alpha0+ Build ID: 7e7302730454aa417f2711024e3a5d9d953add6

@Cao: I can not provide a backtrace. I hope Thorsten can provide some pointers. (see mailinglist)

Kind regards,
Joren
Comment 3 Cao Cuong Ngo 2013-04-08 08:21:30 UTC
@Jorendc: I can reproduce it using Ubuntu 12.04 x64 100% of the time in master. Does the newly created, blank bullet will *disappear* when you copy? Because If I add a space before copying the bullet will not disappear and there will be no crash.
Comment 4 Cao Cuong Ngo 2013-04-08 09:07:43 UTC
I think it's related to the bug https://bugs.freedesktop.org/show_bug.cgi?id=60551 and https://bugs.freedesktop.org/show_bug.cgi?id=50260 since the root cause is the bullet disappear which lead to a null pointer when modifying the bullet format.
Comment 5 Jorendc 2013-04-08 11:09:17 UTC
(In reply to comment #3)
> @Jorendc: I can reproduce it using Ubuntu 12.04 x64 100% of the time in
> master. Does the newly created, blank bullet will *disappear* when you copy?
> Because If I add a space before copying the bullet will not disappear and
> there will be no crash.

I really can not reproduce this behavior using the mentioned steps. Maybe it's worth to provide more detailed steps. I tried both drag&drop as well as copy/paste ... no crash over here.

Kind regards,
Joren
Comment 6 Cao Cuong Ngo 2013-04-08 11:12:25 UTC
Does your bullet disappear as mentioned in https://bugs.freedesktop.org/show_bug.cgi?id=60551 ?
Comment 7 Jorendc 2013-04-08 11:16:45 UTC
Yes, I can confirm that behavior in Bug 60551. Maybe Bug 59932 is also related or a duplicate of one you mentioned? It's currently on our HardHack list (https://wiki.documentfoundation.org/HardHacks#Current_Hard_Hacks) but I didn't saw any activity last 3 weeks.
Comment 8 Cao Cuong Ngo 2013-04-08 11:22:45 UTC
Can you modify the bullet format when it's disappeared following the mentioned steps in this bug? I guess not, this behavior exist from 3.5 and it must be a bug too.
Comment 9 Jorendc 2013-04-08 11:31:44 UTC
No, I can't modify/add a bullet list after it dissapears.
Comment 10 Cao Cuong Ngo 2013-04-09 10:41:52 UTC

*** This bug has been marked as a duplicate of bug 47018 ***
Comment 11 Cao Cuong Ngo 2013-04-09 10:50:31 UTC
I make a patch here you can test it
https://gerrit.libreoffice.org/#/c/3285/