Bug 62900 - FILEOPEN: [libreoffice-calc] .xlsx crash
Summary: FILEOPEN: [libreoffice-calc] .xlsx crash
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-29 10:22 UTC by mattia.b89
Modified: 2013-05-31 18:47 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
an example spreadsheet (11.36 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-03-29 10:22 UTC, mattia.b89
Details
profile directory (474.23 KB, application/gzip)
2013-05-11 10:48 UTC, mattia.b89
Details
gdbtrace log (12.04 KB, text/x-log)
2013-05-11 12:17 UTC, mattia.b89
Details
strace compressed log (769.21 KB, application/gzip)
2013-05-11 12:18 UTC, mattia.b89
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mattia.b89 2013-03-29 10:22:41 UTC
Created attachment 77202 [details]
an example spreadsheet

Problem description:

bug initially reported in the ArchLinux bugtracker:
https://bugs.archlinux.org/task/34498

if I try to expand a cell with "Err:520", calc crashes
I'm on Arch Linux x86_64 with libreoffice-4.0.1.2
BUT with libreoffice-4.0.1.2 in Windows XP (32bit) everything work: cells not showing me "Err:520" but the right result since the cells contain the right formula.

Steps to reproduce:
1. open the attached file
2. try to expand a cell showing "Err:520" e.g.: F15
3. calc crashes with the above output
Operating System: Linux (Other)
Version: 4.0.1.2 release
Comment 1 mattia.b89 2013-03-29 12:26:50 UTC
I found that if I try to expand  any cell calc crashes with the same error!
Comment 2 mattia.b89 2013-03-29 13:36:45 UTC
libreoffice is becoming a fiend:

1. open calc
2. start to write a formula (namely type '=') in any cell and calc crashes
Comment 3 Julien Nabet 2013-03-30 13:17:33 UTC
On pc Debian x86-64 with master sources updated today, I opened the attached Calc file, there were no Err:520 cell.
Then I increased row height and column witdh, no crash.

mattia.b89: Could you rename your LO directory profile and give it a new try? (https://wiki.documentfoundation.org/UserProfile)
Do you reproduce this on a brand new file?
Comment 4 mattia.b89 2013-03-30 14:48:27 UTC
Due to hardware failure i can't test it.
When my PC will be ok, I'll test it.
Comment 5 mattia.b89 2013-04-20 14:39:23 UTC
with 4.0.2 I have the issue;
removing my $HOME/.config/libreoffice I have the issue;
Comment 6 mattia.b89 2013-05-11 09:14:41 UTC
with latest release 4.0.3.3 there is a little enhancement:

now cells show me correctly the values of formulas, that is it doesn't show me "Err:520"
but if I try to expand it I get the same crash
Comment 7 mattia.b89 2013-05-11 09:22:30 UTC
with latest release 4.0.3.3 there is a little improvement:

now cells show me correctly the values of formulas, that is it doesn't show me "Err:520"
but if I try to expand it I get the same crash
Comment 8 Julien Nabet 2013-05-11 09:48:45 UTC
Joren: would you have some time to give it a try? I hadn't been able to reproduce, perhaps you'll be more lucky :-)
Comment 9 mattia.b89 2013-05-11 10:08:53 UTC
(In reply to comment #8)
> Joren: would you have some time to give it a try? I hadn't been able to
> reproduce, perhaps you'll be more lucky :-)

tell me what I can do
Comment 10 Julien Nabet 2013-05-11 10:13:22 UTC
mattia.b89: since I don't reproduce this, I wanted to know if I miss something obvious or not ; so I asked to Joren (who's doing a lot of QA)
BTW, when you say "expand", you mean increase row height or column width or something else?
Comment 11 mattia.b89 2013-05-11 10:22:03 UTC
(In reply to comment #10)
> mattia.b89: since I don't reproduce this, I wanted to know if I miss
> something obvious or not ; so I asked to Joren (who's doing a lot of QA)
> BTW, when you say "expand", you mean increase row height or column width or
> something else?

no, with "expand" I mean double click on the cell for editing the formula

to be more precise:
-PREVIOUSLY expanding a cell do LO to crash
-NOW first time I expand a cell LO make me edit the formula (LO works).
the second time I try to expand a cell (the previous expanded OR any other cell in the sheet) LO crashes
Comment 12 Jorendc 2013-05-11 10:28:07 UTC
Hi,

(In reply to comment #2)
> libreoffice is becoming a fiend:
> 
> 1. open calc
> 2. start to write a formula (namely type '=') in any cell and calc crashes

Mmh, looks very familiar too me. There are recently a lot of errors with that. Not due LibreOffice itself, but due extensions attached to LibreOffice
You have some extensions installed? If yes, can you please disable them? If still reproducible, please reset (rename) your user profile (guide: https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile).

If the user rename resolved the problem (or didn't), is it possible to zip your user profile and send it to me? In that case 1) I'll try to determine which thing crashes LibreOffice.

I fail to reproduce this behavior by myself (tested using Linux Mint 14 x64 with LibreOffice 4.0.3.3 and master version (5441e509f87c96ca36913bd443152adbb8ad2c9))

kind regards,
Joren
Comment 13 mattia.b89 2013-05-11 10:31:38 UTC
(In reply to comment #12)
> Hi,
> 
> (In reply to comment #2)
> > libreoffice is becoming a fiend:
> > 
> > 1. open calc
> > 2. start to write a formula (namely type '=') in any cell and calc crashes
> 
> Mmh, looks very familiar too me. There are recently a lot of errors with
> that. Not due LibreOffice itself, but due extensions attached to LibreOffice
> You have some extensions installed? If yes, can you please disable them? If
> still reproducible, please reset (rename) your user profile (guide:
> https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile).
> 
> If the user rename resolved the problem (or didn't), is it possible to zip
> your user profile and send it to me? In that case 1) I'll try to determine
> which thing crashes LibreOffice.
> 
> I fail to reproduce this behavior by myself (tested using Linux Mint 14 x64
> with LibreOffice 4.0.3.3 and master version
> (5441e509f87c96ca36913bd443152adbb8ad2c9))
> 
> kind regards,
> Joren

how can I disable the extensions???
Comment 14 Jorendc 2013-05-11 10:35:49 UTC
(In reply to comment #13)
> how can I disable the extensions???

Please do not quote my whole answer. That creates a lot of unnecessary noise and makes your reply really long.

I'm sorry I didn't provide steps. My bad.
* Open LibreOffice
* Tools > Extension Manager ...

But I think you only can delete non-default extensions there (so the default extensions can't be deleted in that way).

But I recommend to reset your user profile right away. It isn't likely that you installed an extension if you don't know where you can manage them (don't understand me wrong :-) ).

So, can you please reset your user profile (https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile)?

Thanks,
Joren
Comment 15 mattia.b89 2013-05-11 10:46:59 UTC
removed these extensions:

libreoffice-extension-presentation-minimizer
libreoffice-extension-nlpsolver

with no luck!

renamed profile directory no luck, too!

I attach the compressed folders
Comment 16 mattia.b89 2013-05-11 10:48:12 UTC
Created attachment 79139 [details]
profile directory
Comment 17 Jorendc 2013-05-11 10:59:44 UTC
Thanks for your extra information.

I still fail to reproduce your behavior, even with your user profile. Therefore it's 99% sure this is LibreOffice related (in combination with your OS).

Is it possible for you to upgrade to the latest 4.0.3.3 which you can download here: http://www.libreoffice.org/download and a guide to install it: http://www.libreoffice.org/get-help/installation/linux/ ?

Kind regards,
Joren
Comment 18 mattia.b89 2013-05-11 11:11:48 UTC
I have already the latest stable version (4.0.3.3)
installed through archlinux package manager (pacman)

how to see what do LO to crash ???
Comment 19 Julien Nabet 2013-05-11 11:13:56 UTC
Mattia: just follow https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux
Comment 20 mattia.b89 2013-05-11 12:16:27 UTC
ok, I do:

soffice --backtrace

gdbtrace.log attached

and

soffice --strace

strace.log compressed and attached
Comment 21 mattia.b89 2013-05-11 12:17:02 UTC
Created attachment 79163 [details]
gdbtrace log
Comment 22 mattia.b89 2013-05-11 12:18:12 UTC
Created attachment 79164 [details]
strace compressed log
Comment 23 mattia.b89 2013-05-11 12:26:37 UTC
ok, I do:

gdbtrace.log attached
and
strace.log compressed and attached

both with the following actions:
soffice --backtrace
click on down arrow beside "open..." button
click on the first item of the list (the attached .xlsx file)
click on E14 cell
double click on E14 cell
press enter
double click on E14 cell
LO crashes

the same with soffice --strace
Comment 24 Julien Nabet 2013-05-11 13:36:31 UTC
mattia: What's the version of the extension NumberText? You'll find 0.9.5 here http://extensions.libreoffice.org/extension-center/numbertext-1
Comment 25 mattia.b89 2013-05-11 13:45:10 UTC
I have 0.9.4 version;
I'll report to archlinux bugtracker and when they update the package I'll test again the issue
Comment 26 Julien Nabet 2013-05-11 14:14:47 UTC
mattia: for the test, you can uninstall NumberText 0.9.4 and install 0.9.5. Whatever the result, you'll have extra information to provide for your Arch bugtracker.
Comment 27 mattia.b89 2013-05-31 18:32:30 UTC
with latest official release 4.0.3.3
(which provides the latest numbertext version, too)

THE BUG WAS SOLVED

I'm not sure if it was definitively a numbertext problem or other...

thank you for the support!
Comment 28 Jorendc 2013-05-31 18:47:59 UTC
(In reply to comment #27)
> I'm not sure if it was definitively a numbertext problem or other...
> 
> thank you for the support!

You're welcome :). Thank you for your feedback. Let's mark this bug as RESOLVED WORKSFORME then :)