Bug 62903 - PDF with strange character in maths object
Summary: PDF with strange character in maths object
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-29 11:24 UTC by makeminemadmyron
Modified: 2018-07-12 10:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PDF export with changed character in maths object (199.73 KB, application/pdf)
2013-03-29 11:24 UTC, makeminemadmyron
Details
Printed page with equation and table lines missing (540.64 KB, application/pdf)
2013-03-29 11:25 UTC, makeminemadmyron
Details
Printed page with equation and table lines missing - page 2 (577.93 KB, application/pdf)
2013-03-29 11:27 UTC, makeminemadmyron
Details
Original document with table and equations (526.93 KB, application/vnd.oasis.opendocument.text)
2013-03-29 11:28 UTC, makeminemadmyron
Details
Screenshot (7.97 KB, image/png)
2013-04-08 20:49 UTC, Jorendc
Details
PDF file created from LO 4.0.2.2 in Ubuntu 13.04 (534.93 KB, application/pdf)
2013-04-29 13:15 UTC, makeminemadmyron
Details
The .odt file from LO 4.0.2.2 in Ubuntu 13.04 (445.02 KB, application/vnd.oasis.opendocument.text)
2013-04-29 13:17 UTC, makeminemadmyron
Details
PDF Physics11 Ch01 Th decay from LO 6.1.0.1 (426.29 KB, application/pdf)
2018-07-12 10:53 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description makeminemadmyron 2013-03-29 11:24:15 UTC
Created attachment 77204 [details]
PDF export with changed character in maths object

Printout is missing borders on the tables and horizontal lines in the fractions included in the maths objects. PDF export has borders on the tables and complete fractions in the maths objects but has a division character in the maths equation. Printing was tried on a laser printer and inkjet with identical results (lines missing).

Printing the same file from OpenOffice portable (v3.2.0) and LO 3.6.5 are fine and PDF exports also work.

LO v4.0.0.3 and 4.0.1.2 have both had problems with documents that have table borders or horizontal lines in the header or elsewhere in the document, so I've gone back to another computer at work that has LO 3.6.5 installed or used a portable version of OpenOffice 3.2.0.
Comment 1 makeminemadmyron 2013-03-29 11:25:49 UTC
Created attachment 77205 [details]
Printed page with equation and table lines missing
Comment 2 makeminemadmyron 2013-03-29 11:27:22 UTC
Created attachment 77206 [details]
Printed page with equation and table lines missing - page 2
Comment 3 makeminemadmyron 2013-03-29 11:28:59 UTC
Created attachment 77207 [details]
Original document with table and equations
Comment 4 Jorendc 2013-04-08 20:44:52 UTC
(In reply to comment #0)
> Printing the same file from OpenOffice portable (v3.2.0) and LO 3.6.5 are
> fine and PDF exports also work.

Therefore I mark this as a regression bug.

I can not reproduce this behavior using Linux Mint 14 x64 with LibreOffice Versie 4.0.2.2 .2.2 (Bouw-id: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3); Dutch UI.

@Bug reporter: could you please retest using 4.0.2.2, which you can download here http://www.libreoffice.org/download

It also could be a windows-only issue.

Kind regards,
Joren
Comment 5 Jorendc 2013-04-08 20:49:16 UTC
Created attachment 77634 [details]
Screenshot

The only "stranger" behavior I see is a strange fraction bar.
Comment 6 Rainer Bielefeld Retired 2013-04-16 15:49:56 UTC
@Jorendc
Tha table border printing problem is a DUP of "Bug 62667 - CALC OLE object PRINTING with missing cell borders" and related ones; can be excluded here.

Can you please follow up the Math problems?
Comment 7 Joel Madero 2013-04-16 19:02:12 UTC
same as comment 5, strange behavior for fraction bar. Bibisectrequest
Comment 8 Joel Madero 2013-04-16 19:03:06 UTC
Prioritized:

New (confirmed)
Normal - can prevent high quality work with PDF's
Medium - default seems appropriate
Comment 9 Joel Madero 2013-04-16 19:28:59 UTC
Not a regression, reproduced with earliest bibisect, removing regression & bibisectrequested
Comment 10 makeminemadmyron 2013-04-17 23:15:17 UTC
Error in PDF file also appeared in LO version 4.0.2.2 from same computer as before.
Comment 11 makeminemadmyron 2013-04-17 23:18:56 UTC
Joren,
I just retested with 4.0.2.2 on the same Windows 7 (64-bit) machine
and have the same result with the strange division character near the
end of the horizontal line in the fraction in the pdf file.
Myron 

----- Original Message -----
From: bugzilla-daemon@freedesktop.org
To:
Cc:
Sent:Mon, 08 Apr 2013 20:44:52 +0000
Subject:[Bug 62903] PRINTING missing table borders and PDF with
strange character in maths object

 Jorendc [1]  changed bug 62903 [2] 

		WHAT
 		REMOVED
 		ADDED

		CC
 		   
 		joren.libreoffice@telenet.be 

		Keywords
 		   
 		regression 

	   COMMENT # 4 [3] ON BUG 62903 [4] FROM  JORENDC [5]  

	(In reply to comment #0 [6]) > Printing the same file from OpenOffice
portable (v3.2.0) and LO 3.6.5 are > fine and PDF exports also work.
Therefore I mark this as a regression bug. I can not reproduce this
behavior using Linux Mint 14 x64 with LibreOffice Versie 4.0.2.2 .2.2
(Bouw-id: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3); Dutch UI. @Bug
reporter: could you please retest using 4.0.2.2, which you can
download here http://www.libreoffice.org/download [7] It also could be
a windows-only issue. Kind regards, Joren  
-------------------------
You are receiving this mail because: 

	* You reported the bug.



Links:
------
[1] mailto:joren.libreoffice@telenet.be
[2] https://bugs.freedesktop.org/show_bug.cgi?id=62903
[3]
http://webmail.iinet.net.au/HTTPS://BUGS.FREEDESKTOP.ORG/SHOW_BUG.CGI?ID=62903#C4
[4]
http://webmail.iinet.net.au/HTTPS://BUGSFREEDESKTOP.ORG/SHOW_BUG.CGI?ID=62903
[5] http://webmail.iinet.net.au/MAILTO:JOREN.LIBREOFFICE@TELENET.BE
[6] http://webmail.iinet.net.au/show_bug.cgi?id=62903#c0
[7] http://www.libreoffice.org/download
Comment 12 Joel Madero 2013-04-17 23:20:43 UTC
Please respond directly on FDO not through email as we get a bunch of extra text this way :)

As for the bug, I think we are seeing the same issue and it's been around forever but the bug is marked as "NEW" (confirmed) so it's made it through triaging :)


Thanks for helping us!
Comment 13 makeminemadmyron 2013-04-29 13:10:29 UTC
My apologies, but I may have provided misleading information.

I recently tried the same file in LO v4.0.2.2 on Ubuntu 13.04 and discovered that I couldn't edit the math equation, which seemed strange. So I duplicated the math object and created a PDF file. The file shows the strange division symbol in the first equation (original) but the second is correct.

When I went back to Windows I discovered that the original equation that creates the strange division symbol when converted to a PDF is a MathType or Microsoft equation object. I must have started with a .doc file and converted it to an .odt file at some point.

Interestingly, the mathematical expression in question 8 is also a fraction created originally in MathType or Microsoft office, but it does not create an error when converted to a PDF file, so it's not consistent.

I still find it annoying that the table borders sometimes work and sometimes don't in the PDF (good in all parts of the PDF except missing in the answer section for question 8.c, but I know this is a different issue.

Myron
Comment 14 makeminemadmyron 2013-04-29 13:15:11 UTC
Created attachment 78600 [details]
PDF file created from LO 4.0.2.2 in Ubuntu 13.04

A second math object was created after the original in LO v4.0.2.2 running in Ubuntu 13.04 and a PDF was created. The math equation object is correct in the PDF.
Comment 15 makeminemadmyron 2013-04-29 13:17:54 UTC
Created attachment 78601 [details]
The .odt file from LO 4.0.2.2 in Ubuntu 13.04

The original file with a MathType or Microsoft Office math object followed by a LO Math object.
Comment 16 ign_christian 2013-07-24 08:36:30 UTC
Hi makeminemadmyron@iinet.net.au, could you please see Bug 31241 whether this bug is a duplicate? 

Maybe I'm wrong, but I saw same problem with PDF export -> middle right parenthesis replaced by division sign
Comment 17 QA Administrators 2015-04-01 14:39:58 UTC Comment hidden (obsolete)
Comment 18 Buovjaga 2015-04-19 13:56:28 UTC
The division character is still haunting the maths equation, when exporting as PDF.

Ubuntu 14.10 64-bit 
Version: 4.5.0.0.alpha0+
Build ID: afb82d3729bda2754d0add08cc6c4dce1dc76d59
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-14_00:05:04
Locale: en_US
Comment 19 QA Administrators 2016-09-20 10:13:57 UTC Comment hidden (obsolete)
Comment 20 Roman Kuznetsov 2018-07-12 10:53:36 UTC
Created attachment 143512 [details]
PDF Physics11 Ch01 Th decay from LO 6.1.0.1
Comment 21 Roman Kuznetsov 2018-07-12 10:54:43 UTC
Export to PDF from LibreOffice 6.1.0.1 looks good

Status -> WFM