Bug Hunting Session
Bug 62667 - CALC OLE object PRINTING with missing cell borders
Summary: CALC OLE object PRINTING with missing cell borders
Status: RESOLVED DUPLICATE of bug 60280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.1 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 63585 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-03-23 12:40 UTC by koenig.ralph
Modified: 2013-04-24 19:37 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Printed document aspect (317.93 KB, image/jpeg)
2013-03-23 12:40 UTC, koenig.ralph
Details
Writer Document with embedded Calc OLE with cell borders (15.19 KB, application/vnd.oasis.opendocument.text)
2013-04-03 07:59 UTC, Jeff Evans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description koenig.ralph 2013-03-23 12:40:07 UTC
Created attachment 76938 [details]
Printed document aspect

Until version 3.6.x I just created my tables in Calc to save some work or to take advantage of some kind of calculation results and used to copy and paste them into a Writer document, and the result was fine: I printed my documents and what I saw in the screen was what I got in my printer.
Since version 4.0 (and the problem persists in version 4.2.0.1) when I use these documents both created in this version or saved with the previous (3.6.x) version, on the screen all seems to be correct but when I print cell or table borders disappear and from the page where the Calc table is inserted a black stripe appears at the middle of every printed page.
Comment 1 koenig.ralph 2013-03-23 12:42:14 UTC
Comment on attachment 76938 [details]
Printed document aspect

I apologize, the attachment did not work as I expected. Please ignore it.
Comment 2 Rainer Bielefeld Retired 2013-03-23 18:33:39 UTC
(In reply to comment #0)
Please attach a sampledocument.odt!
Comment 3 Jeff Evans 2013-04-03 07:59:42 UTC
Created attachment 77360 [details]
Writer Document with embedded Calc OLE with cell borders

I'm getting a similar problem with 4.0.1.2 live Windows version.

Cell Borders of embedded Calc Object do not print. Cell content printing correctly.  The missing borders do appear on the Print Preview, and PDF is created and prints correctly.

Printer is 10-year-old Minolta-QMS Magicolor 3100. System is Windows XP SP3.

Worked OK in 3.6. Is 4.0 using print features not available in earlier OS / Drivers?
Comment 4 Rainer Bielefeld Retired 2013-04-03 08:45:18 UTC
[Reproducible] with sample document "2013-04-03 07:59 UTC, Jeff Evans " and server installation of "LibO  4.0.2.2 rc   -  German UI / German Locale  [Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)]"  {tinderbox: @6, pull time  2013-03-26 12:00(?)} on German WIN7 Home Premium (64bit) with newly created own user profile: Print to FreePDF with missing cell borders, PDF Export is ok.

Already [Reproducible] with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile 

Was still ok with Server-installation of Master " 3.7.0.0.alpha0+  – ENGLISH UI [Build ID: f2e622]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3

Related to or DUP of?
"Bug 60280 - PRINTING of TABLE borders, borders around paragraphs and footer, some graphic elements suppressed by OLE objects in document"
"Bug 61913 - particular OLE objects suppress PRINTING of .wmf"
or even
"Bug 62898 - PRINTING: missing graphic contents of chart like looking object"?
Comment 5 Jeff Evans 2013-04-03 10:44:57 UTC
Regarding related bugs: both of the real documents in which I first spotted this problem contain .wmf vector-graphics logos in the page header. No problems with these, except that one of them doesn't appear correctly in the new Template Manager.

In one case I cut and pasted part of an .xls spreadsheet loaded into Calc, and some of the borders did print, but thinner lines than intended.
Comment 6 Rainer Bielefeld Retired 2013-04-10 07:56:49 UTC
Regresson due to Comment 4 and others
Comment 7 Rainer Bielefeld Retired 2013-04-16 09:35:09 UTC
*** Bug 63585 has been marked as a duplicate of this bug. ***
Comment 8 Andrés Gómez García 2013-04-22 20:15:17 UTC
Tested with 4.0.1.2 and in Linux (Ubuntu Quantal 12.10).

Printing to PDF with the virtual printer provided by cups-pdf works correctly.

The same when exporting to PDF.
Comment 9 Timon 2013-04-23 04:39:25 UTC
(In reply to comment #8)
> Tested with 4.0.1.2 and in Linux (Ubuntu Quantal 12.10).
> 
> Printing to PDF with the virtual printer provided by cups-pdf works
> correctly.
> 
> The same when exporting to PDF.

Export to pdf worked fine and in earlier versions. But phisical printing (not virtual printing) is bad even in 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) in Windows XP
Comment 10 Michael Stahl (CIB) 2013-04-24 19:37:39 UTC
was fixed by 954d695827431a5badd1a993d8f364c669ca9c9c
-> duplicate

*** This bug has been marked as a duplicate of bug 60280 ***