Bug 61913 - particular OLE objects suppress PRINTING of .wmf
Summary: particular OLE objects suppress PRINTING of .wmf
Status: RESOLVED DUPLICATE of bug 60280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard:
Keywords: regression
: 63156 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-03-06 17:27 UTC by jürgen roland
Modified: 2013-04-24 19:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
template used many times for years without any problems (38.78 KB, application/vnd.oasis.opendocument.text-template)
2013-03-06 17:27 UTC, jürgen roland
Details
printing result with Adobe PDF printer with OLE object (1.34 MB, application/pdf)
2013-03-06 17:50 UTC, jürgen roland
Details
printing result with Adobe PDF printer without OLE object (1.35 MB, application/pdf)
2013-03-06 17:52 UTC, jürgen roland
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jürgen roland 2013-03-06 17:27:10 UTC
Created attachment 76032 [details]
template used many times for years without any problems

Problem description: 

Steps to reproduce:
Documents and templates which have graphics like WMF files (logos)or lines etc. involved are not shown in prints anymore (no matter whether it's a laser printer - OKI 5900 - or the Adobe PDF printer X) after changing from LO 3.6 to 4.0.1. 

I can see those things in the printing menue but not in the prints. 

Current behavior:
Many tests have shown that the reason is an OLE object from Calc (these documents are accounts where the invoice is calculated by Calc in those Writer documents).

I designed these documents some years ago with an OpenOffice version (don't know really which - could be 2 or so...) and had many updates since then (OO and LO from the start). Every version made it alright... until version 4!

The documents can be printed with every graphic in it without the OLE object of Calc but every time i put this OLE object back into these documents the printing fails again! No matter if it's the old OLE object i'm using for years or a new one edited in Calc or in Writer directly.
Comment 1 jürgen roland 2013-03-06 17:50:32 UTC
Created attachment 76033 [details]
printing result with Adobe PDF printer with OLE object
Comment 2 jürgen roland 2013-03-06 17:52:52 UTC
Created attachment 76035 [details]
printing result with Adobe PDF printer without OLE object
Comment 3 Rainer Bielefeld Retired 2013-03-12 10:28:25 UTC
Due to comment in "Bug 60280 - PRINTING: TABLE borders, borders around paragraphs and footer, some graphic elements missing"
Comment 4 Rainer Bielefeld Retired 2013-03-19 14:19:19 UTC
Missing logo.wmf is [Reproducible] with server installation of "LibO  4.0.1.2 release   -  German UI / German Locale  [Build ID: 84102822e3d61eb989ddd325abf1ac077904985)]"  {tinderbox: @6, pull time  2013-02-28 08:53(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LibreOffice\4012\.


@jürgen roland 
Please be more specific and precise in your descriptions. 
In "Unbenannt1b.pdf" I see Calc-Object Missing, in Unbenannt1.pdf I see logo.wmf missing. That should tell us what?

May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? 
Please add all information requested in following:
- Write a meaningful Summary describing exactly what the problem is
  (99% of all reports here are about problems, that's not a distinctive
  feature)
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
  -- How can I reproduce missing wmf?
  -- how can O reproduce missing Calc OLE obbject?
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
  (attachment 68877 [details], attachment 68490 [details])
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
     (NOT "some elements missing" but "in text row ..."
Comment 5 jürgen roland 2013-03-19 19:05:14 UTC
@ Rainer Bielefeld,

i think i explained the problem already.

you have to open my template. there you can see all the graphics and lines that should be in the document.
then just print this template (with a laser printer or PDF printer - doesn't matter!).

the first PDF file "Unbenannt1.pdf" is showing the result of the printing directly from my template - as you can see all the graphics (wmf logo) and the lines are missing!

you should get the same results after printing my template.

the second PDF file "Unbenannt1b.pdf" is showing the result of the printing after i deleted the calc OLE object from the template - as you can see here all the graphics (wmf logo) and the blue lines on the left are now as they should be.

my tests came to the result that there has to be the problem within the calc OLE object - no matter if you make a new one in a new document or if you use my template! every time you use such an OLE object the printing problem are shown as seen in my PDF file "Unbenannt1.pdf". i've tested both ways, too.

you also can build a new calc OLE object in different ways:
by building a calc table in calc and then put it into a writer document or directly from within writer. if you use some lines in that table (as i did in my template for example) the lines won't be printed! i've tested that, too.

is that enough explaination?
Comment 6 Rainer Bielefeld Retired 2013-03-19 21:33:16 UTC
(In reply to comment #5)
1. Open Unbenannt 1.ott
2. Print to PDF (FreePDF)
   > Calc OLE object shown              :-)
   > logo.wmf missing                   :-(
3. delete  Calc OLE object
4.  Print to PDF (FreePDF)
    > logo.wmf shown                    :-)
5. Menu 'Insert -> Object -> OLE -> New - Libreoffice 4.0 Calc' <ok>
   > Calc table appears
6. Insert some few characters and numbers into Range A1:D5
7. Print to PDF (FreePDF)
   > Calc OLE object shown              :-)
   > logo.wmf missing   again           :-(
 
Suppression also reproducible with 
- Draw objects (Draw objects mostly visible, sometimes not)
- Math Formula OLE object

No suppression with Chart

I will do some additional research tomorrow (where did that start, relation to Bug 60280, general reproducible with own documents, other pictures, ...)

@jürgen roland 
Thx for clarification.
Comment 7 Rainer Bielefeld Retired 2013-03-20 06:27:24 UTC
Some tests with reporter's sample:
---------------------------------
Still [Reproducible] with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 094bab7f9097fba62800d3dd578bd42640d8c6e2) TinderBox: Win-x86@6, Branch:master, Pull Time: 2013-03-18_01:35:56" ENGLISH UI / German Locale on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile 

Already [Reproducible] with unzipped  installation of  "LOdev  4.0.0.0.alpha1+   -  ENGLISH UI / German Locale  [Build ID: af60316514f3ae3d4c475819bf86f2af837171e)]"  {tinderbox: Win-x86@6, pull time 2012-11-23 22:10:31} on German WIN7 Home Premium (64bit) with own separate User Profile 

Was still ok with Server-installation of Master " 3.7.0.0.alpha0+  – ENGLISH UI [Build ID: f2e622]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3

I think this one shows some additional aspects of Bug 60280, dev. should decide.

@Michael:
Please add Witeboard tag “bibisectrequest” if you think that a bibisect result can ease your work.
Please change  Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 8 Timur 2013-03-21 12:13:56 UTC
While maybe not the same bug, please take a look at Bug 38619 - Picture of type WMF is not printed correctly. 
Like that one, Export as PDF exports correctly for this document, while Print doesn't work. (But, for some other documents, even Export as PDF doesn't work)
Comment 9 Panos Stokas 2013-04-10 06:29:12 UTC
*** Bug 63156 has been marked as a duplicate of this bug. ***
Comment 10 Panos Stokas 2013-04-10 06:34:58 UTC
Not only a WMF issue. It also affects documents containing SmartDraw objects and even LibreOffice Drawing objects!

I lost an entire ream of paper because of this. I am raising the importance because printing is a core function of those actually working with LibreOffice.
Comment 11 Andrés Gómez García 2013-04-22 20:08:01 UTC
Tested with 4.0.1.2 and in Linux (Ubuntu Quantal 12.10).

Printing to PDF with the virtual printer provided by cups-pdf works correctly.

The same when exporting to PDF.
Comment 12 Cédric Bosdonnat 2013-04-24 07:52:13 UTC
Started to locate the bug: works with a build at commit a9b7cee.
Comment 13 Michael Stahl (CIB) 2013-04-24 19:23:44 UTC
was fixed by 954d695827431a5badd1a993d8f364c669ca9c9c
-> duplicate

*** This bug has been marked as a duplicate of bug 60280 ***