Download it now!
Bug 62898 - PRINTING: missing graphic contents of chart like looking object.
Summary: PRINTING: missing graphic contents of chart like looking object.
Status: RESOLVED DUPLICATE of bug 60280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-03-29 08:50 UTC by Domingo Sacristan
Modified: 2013-04-24 20:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (31.73 KB, application/vnd.oasis.opendocument.text)
2013-03-29 08:50 UTC, Domingo Sacristan
Details
print sample print ole object enable (59.48 KB, application/pdf)
2013-03-29 08:51 UTC, Domingo Sacristan
Details
print sample print ole object disable (51.51 KB, application/pdf)
2013-03-29 08:52 UTC, Domingo Sacristan
Details
again test file odt (31.73 KB, application/vnd.oasis.opendocument.text)
2013-03-29 08:53 UTC, Domingo Sacristan
Details
another sample now direct created with Libreoffice 4.0.2.2 (11.80 KB, application/vnd.oasis.opendocument.text)
2013-03-29 09:14 UTC, Domingo Sacristan
Details
the document test file odt print with Libreoffice 3.6.2 under Ubuntu (102.74 KB, application/pdf)
2013-03-29 09:31 UTC, Domingo Sacristan
Details
image as OLE originally from ms word document (56.62 KB, application/vnd.oasis.opendocument.text)
2013-03-29 10:09 UTC, Domingo Sacristan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Domingo Sacristan 2013-03-29 08:50:23 UTC
Created attachment 77192 [details]
test file

Test:

Platform: Win XP
Libreoffice Version: 4.0.2.2

- Open attachment: printproblems.odt
- print document:
- Result: Diagram of chart will not print, only metadaten(Legende,Axys Values), Table borders will not print

- select OLE Object
- go to Format - Frame/Object - Options
- turn under properties option "print" off
- print document again
- Table borders will print

If document contains OLE Object they many Problems to print the document correctly
Please this is a heavy print problem
Comment 1 Domingo Sacristan 2013-03-29 08:51:42 UTC
Created attachment 77193 [details]
print sample print ole object enable
Comment 2 Domingo Sacristan 2013-03-29 08:52:18 UTC
Created attachment 77194 [details]
print sample print ole object disable
Comment 3 Domingo Sacristan 2013-03-29 08:53:36 UTC
Created attachment 77195 [details]
again test file odt
Comment 4 Domingo Sacristan 2013-03-29 09:14:50 UTC
Created attachment 77196 [details]
another sample now direct created with Libreoffice 4.0.2.2
Comment 5 Domingo Sacristan 2013-03-29 09:31:05 UTC
Created attachment 77197 [details]
the document test file odt print with Libreoffice 3.6.2 under Ubuntu
Comment 6 Rainer Bielefeld Retired 2013-03-29 09:37:09 UTC
This one might be related to or DUP of "Bug 60280 - PRINTING of TABLE borders, borders around paragraphs and footer, some graphic elements suppressed by OLE objects in document"
"Bug 61913 - particular OLE objects suppress PRINTING of .wmf"

I will o additional tests, soon.

@Domingo Sacristan:
Please do not attach lots of sample documents without explication. we need 1 sample document with related step by step instruction, may be together with screenshots or print results. No more test documents required!
Mostly is more eay to reproduce a bug if reporter collects all related documents for a test to a testkit.zip
Comment 7 Rainer Bielefeld Retired 2013-03-29 09:45:53 UTC
Effect is [Reproducible] with sample document "2013-03-29 08:50 UTC, Domingo Sacristan " and server installation of "LibO  4.0.2.2 rc   -  German UI / German Locale  [Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)]"  {tinderbox: @6, pull time  2013-03-26 12:00(?)} on German WIN7 Home Premium (64bit) with newly created own user profile
Comment 8 Rainer Bielefeld Retired 2013-03-29 09:53:55 UTC
I will do some further tests, what are difficult with first sample, because all 4.x versions before 4.0.2.2 I tested only show placeholder instead of chart.

@Domingo Sacristan:
Please contribute detailed information concerning the chart object in your first sample document
Comment 9 Rainer Bielefeld Retired 2013-03-29 09:56:55 UTC
Comment on attachment 77196 [details]
another sample now direct created with Libreoffice 4.0.2.2

Broken document, missing linked object.

@reporter:
please do not attach any more sample documents here
Comment 10 Domingo Sacristan 2013-03-29 10:09:02 UTC
Created attachment 77201 [details]
image as OLE originally from ms word document
Comment 11 Domingo Sacristan 2013-03-29 10:15:17 UTC
Sorry the comment will not save. The chart object in my first sample document is originally created with ms excel, add to odt document per copy an paste. Please see my another sample. This is a simple graphic embedded as OLE object originally in one ms word document. This document was convert to odt document. The resut is the same as by my first sample, the table borders will not print
Comment 12 Rainer Bielefeld Retired 2013-04-03 09:00:07 UTC
Here we only talk about that strange chart like object, and we have to find out whether this bug is related to mentioned bugs or independent. 

Because the Ole Object is missing in several versions it's difficult to find out when this problem started. 

May be we should wait for a fix in the "See Also" bugs and then check whether shis one persists.

Domingo Sacristan:
Please do not add samples for bugs with similar symptoms, but possibly completely unrelated. I will obsolete your latest sample.
Comment 13 Rainer Bielefeld Retired 2013-04-03 09:00:45 UTC
Comment on attachment 77201 [details]
image as OLE originally from ms word document

Obsoleted, see comment above!
Comment 14 Rainer Bielefeld Retired 2013-04-10 07:56:15 UTC
Worked fine with  "LibreOffice 3.6.6.2 release " German UI/ German Locale [Build-ID: f969faf] {pull date 2013-04-03} on German WIN7 Home Premium (64bit), so Regression.

Most other similar bugs appeared between 2012-10-06 and 2012-11-23, I did not test yet for this one.
Comment 15 Michael Stahl (CIB) 2013-04-24 19:54:20 UTC
Comment on attachment 77195 [details]
again test file odt

duplicate attachment
Comment 16 Michael Stahl (CIB) 2013-04-24 20:00:26 UTC
was fixed by 954d695827431a5badd1a993d8f364c669ca9c9c
-> duplicate

*** This bug has been marked as a duplicate of bug 60280 ***