Bug Hunting Session
Bug 62955 - UI When opening a Macro (Alt-F11) allow searching a module/ function name with typing the first letter
Summary: UI When opening a Macro (Alt-F11) allow searching a module/ function name wit...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Andreas Heinisch
URL:
Whiteboard: target:6.4.0
Keywords:
: 62949 (view as bug list)
Depends on:
Blocks: Macro-UI
  Show dependency treegraph
 
Reported: 2013-03-30 23:49 UTC by Cor Nouws
Modified: 2019-10-16 08:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2013-03-30 23:49:11 UTC

    
Comment 1 Robinson Tryon (qubit) 2013-10-29 04:30:56 UTC
Whiteboard: proposedEasyHack -> ProposedEasyHack
Comment 2 Joel Madero 2014-02-27 22:55:06 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 3 Robinson Tryon (qubit) 2015-12-10 07:20:07 UTC
Migrating Whiteboard tags to Keywords:(needDevEval -> needsDevEval)
(Harmonize spelling of term)
Comment 4 tagezi 2017-05-28 09:31:21 UTC
*** Bug 62949 has been marked as a duplicate of this bug. ***
Comment 5 tagezi 2017-05-28 09:37:44 UTC
I do not understand that you want. It can be supposed many things. Could you open your thought and explain how it need to work if there is several modules with one name  and in different libraries?
Comment 6 QA Administrators 2017-12-04 12:44:46 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2017-12-05 22:17:06 UTC
(In reply to tagezi from comment #5)
> I do not understand that you want. It can be supposed many things. Could you
> open your thought and explain how it need to work if there is several
> modules with one name  and in different libraries?

The dialog Basic Macro has the list Macro From (on the left)
Imagine Libraries AA, BB, CC, DD, ... XX
Now when the cursor is on top, type X and the focus jumps there.

(sorry, the correct technical English description escapes me)
Comment 8 Commit Notification 2019-10-16 08:24:46 UTC
Andreas Heinisch committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a15459316bcf18000a74c3779a60689c828c5870

tdf#62955 - Allow searching a name with typing the first letter

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.