Download it now!
Bug 62971 - 3d scene displays 90deg right turned
Summary: 3d scene displays 90deg right turned
Status: CLOSED DUPLICATE of bug 62402
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-03-31 21:45 UTC by Regina Henschel
Modified: 2016-06-18 19:03 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2013-03-31 21:45:11 UTC
Create a 3D scene, for example the Pyramid from the set of predefined shapes. Its top goes to the right side, but should be up.

Version 4.1.0.0.alpha0+ (Build ID: 74f74aa5470fe631c7827897742c0ccbddcf6ad)
TinderBox: Win-x86@6, Branch:master, Time: 2013-02-23_23:21:01
is OK.

Version 4.1.0.0.alpha0+ (Build ID: 2c9d3817429b1537ea31521cb263a52ce9c7968)
TinderBox: Win-x86@6, Branch:master, Time: 2013-03-04_01:18:29
is broken.

The file format is OK. When you open the file in AOO or in LO4.0, the scene is shown with the correct orientation.
Comment 1 Jorendc 2013-04-08 15:42:06 UTC
Thanks for reporting Regina :)!

I can reproduce this behaviour using Linux Mint 14 x64 with LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 7b515a57eb6a644860715018656ac0b843b62ba (build today). Therefore I mark this as NEW.

What I did:
* Open Draw
* Insert basic triangle shape
* Click on Extrusion On/off in the toolbar

Behavior: 3D triangle/piramid rotates 90° clockwise.

* Save file
* Open with LibreOffice Version 4.0.2.2

Behavior: 3D triangle/piramid is oriented well.

* Open file back on master

Behavior: still rotated incorrectly.

Seems indeed like a Display bug.

Kind regards,
Joren
Comment 2 Markus Mohrhard 2013-04-08 18:58:56 UTC

*** This bug has been marked as a duplicate of bug 62402 ***
Comment 3 Regina Henschel 2016-06-18 19:03:18 UTC
Fix from bug 62402 solves this too. Verified in Version: 5.3.0.0.alpha0+
Build ID: 3ab13873ebb6dc4738be2e2184ee4433a2447c1d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-06-16_01:48:01
Locale: de-DE (de_DE)