Bug 63017 - Copying XY chart to Writer/Impress change Error Bars
Summary: Copying XY chart to Writer/Impress change Error Bars
Status: RESOLVED DUPLICATE of bug 56730
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-02 08:57 UTC by Henning
Modified: 2013-07-26 03:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of wrong errorbar scaling in impress (left side) and correct scaling in calc (right side). (155.50 KB, image/png)
2013-04-02 08:57 UTC, Henning
Details
Example with minimum chart data (12.95 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-06-12 19:40 UTC, Henning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henning 2013-04-02 08:57:33 UTC
Created attachment 77306 [details]
Example of wrong errorbar scaling in impress (left side) and correct scaling in calc (right side).

Hello!

When copying a chart with y-errorbars from calc to writer or impress the errorbars have a wrong scaling (see example image).
Using individual errorvalues for each data point the errorbars increase linear, using a constant error for all data points the errorbars in the copy have a size of zero. I have not checked on the other two errorbar "types" (percentage value and one item of the drop-down box like standard deviation and so on).

Nanority

Steps to Reproduce:
1) Create chart with y-errorbars in calc.
2) Copy chart to writer or impress.

Actual Results:
Errorbars have wrong scaling in copy.

Expected Results:
Correct errorbar scaling as in calc.

Build Date & Platform:
Fedora 18: 3.6.5.2-8.fc18.x86_64
Comment 1 rjhenwood 2013-04-22 18:28:18 UTC
I too am experiencing this bug.
Comment 2 rjhenwood 2013-04-22 18:29:57 UTC
More info:

I see this bug copying to Writer.

I'm using: Version 3.6.5.2 (Build ID: 3.6.5.2-6.fc18)
Comment 3 ign_christian 2013-06-11 04:22:45 UTC
I can't reproduce on LO 4.0.4.1 (Win7 32bit)

But I see incorrect result with X Error Bars, line/bars color reformatted to default.

Could you retest using latest stable release (3.6.6 or 4.0.3) & attach your spreadsheet if possible?
Comment 4 ign_christian 2013-06-11 04:24:05 UTC
Copying to Writer or Impress produces same result
Comment 5 Henning 2013-06-12 19:39:40 UTC
(In reply to comment #3)
> I can't reproduce on LO 4.0.4.1 (Win7 32bit)
> 
> But I see incorrect result with X Error Bars, line/bars color reformatted to
> default.
> 
> Could you retest using latest stable release (3.6.6 or 4.0.3) & attach your
> spreadsheet if possible?

I can still reproduce the error with Fedora 3.6.6.2-8.fc18.
I did not check on reformatting and so on.

To reproduce just
1) open the attached file
2) highlight the cart
3) crtl+c 
4) open writer (or Impress, or ...)
5) crtl+v
6) compare error bars
Comment 6 Henning 2013-06-12 19:40:37 UTC
Created attachment 80741 [details]
Example with minimum chart data
Comment 7 ign_christian 2013-06-13 02:19:35 UTC
I still can't reproduce on LO 4.0.4.1 (Win7 32bit), perhaps it's been fixed on LO 4.x
Comment 8 ign_christian 2013-06-13 02:55:07 UTC
Hi Henning

I confirm that it's reproducible on LO 3.6.6.2 (Ubuntu 12.04 32bit). Though I must modify that file first because Y error bars range is missing (not happen on 4.0.4.1).

So I left the status UNCONFIRMED -> waiting confirmation from QA whether that will be fixed on 3.6.7 (because it's fixed on 4.0.4.1)
Comment 9 ign_christian 2013-07-26 03:08:02 UTC

*** This bug has been marked as a duplicate of bug 56730 ***