Bug 63077 - EDITING: Paste by Enter Key unexpectedly removes / erases Calc contents from clipboard
Summary: EDITING: Paste by Enter Key unexpectedly removes / erases Calc contents from ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 71505 90949 (view as bug list)
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2013-04-03 12:53 UTC by gzernmplatz
Modified: 2016-12-26 09:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gzernmplatz 2013-04-03 12:53:25 UTC
Problem description: When I select cells and press Ctrl+c for copy (or Ctrl+x for cut), a moving frame appears around the selected cells (this hurts my eyes). When I press Enter anywhere inside this frame, Enter has the effect of Ctrl+v, the content of the clipboard is pasted where the selection mark is. In addition, the frame vanishes and the clipboard is empty.

Steps to reproduce, example:
1. Make a spreadsheet with the letters a,b,c in the cells (1,A), (2,A), (3,A) respectively (for an example; any other spreadsheet does the same).
2. Select the cells (1,A), (2,A), (3,A) and press Ctrl+c or choose "copy" in the edit menu. A moving, blinking frame appears (and the cells are in the clipboard).
3. Press Enter: The frame disappears. 
4. Go to cell (1,B) and paste (with edit menu or Ctrl+v): Nothing happens although the copied cells should still be in the clipboard.
5. Repeat step 2.
6. Move the selection mark to cell (2,A).
7. Press Enter. Now the spreadsheet looks like this: 
a
a
b
c
The frame has disappeared, but so has the clipboard.
8. Move the selection mark anywhere and paste: Nothing happens although the letters should still be in the clipboard.

If you have OpenOffice, you can also do the following: 
9. Repeat step 2 again.
10. Make an OpenOffice spreadsheet and paste there: The result looks weird but shows that there is something in the clipboard.
11. Go back to LibreOffice and press Enter inside the frame.
12. Try to paste anywhere in the OpenOffice spreadsheet: Nothing happens, showing that LibreOffice has really emptied the clipboard instead of just being too stupid to paste.

Current behavior: After copying, a moving frame appears, pressing Enter inside it causes LibreOffice to paste and to empty clipboard.

Expected behavior: No moving or blinking stuff, Enter works as Enter everywhere, not as paste, copied stuff stays in the clipboard until I replace it by copying other stuff or until I shut down the computer.


Operating System: Windows 7
Version: 4.0.1.2 release
Comment 1 Rainer Bielefeld Retired 2013-04-03 14:10:37 UTC
User Error! In Calc <Enter> pastes CALC (!) clipboard contents to cell cursor position and afterwards removes contents from clipboard. Please also see "Bug 34686 - Option to turn off Paste mode for Return".

But I can't find a hint in Help or documentation.

@gzernmplatz:
Please avoid meaningless "not properly" summaries!
It would be great if you could do some additional research and submit a new Bug concerning missing Help for this if you can confirm my suspect that that behavior is not mentioned in Help.
Comment 2 gzernmplatz 2013-04-04 15:35:05 UTC
Sorry for the bad summary. 

I think this behavior IS a bug or rather a whole bunch of bugs: 
1. Enter works as Paste which disrupts the work flow.
2. Pasting with Enter deletes the clipboard.

This is (together with those annoying moving frames) a copy of the misbehavior of Microsoft Excel that is the reason why I do not use Microsoft Excel.

This new behavior of LibreOffice makes some strategies simply impossible, for example, pressing Shift+Enter to get to the end of a selected area that is several pages long (in a spreadsheet that is even more pages long) and then pasting a copy of it one line under it.

The Help, at least the German Help, does not mention anything about pasting with Enter. On the contrary, what the German Help says is the following:

There is a special "selection clipboard" that contains the last selection and can be pasted using the mouse wheel. Copying with Ctrl+c puts content into the normal clipboard and clipboard content can be pasted with Ctrl+v. 

The Help does neither mention a special CALC clipboard nor pasting with Enter.
Comment 3 Rainer Bielefeld Retired 2013-04-13 06:34:23 UTC
Back to NOTABUG.

I sent some hints to reporter how contribute promising enhancement requests.

@gzernmplatz@mixedstuff.de:
the original bug was concerning lost Clipboard contents, your comment 2 (of course is related to this LibO behavior) is concerning not working of undocumented shortcut. Please submit a separate report for this issue.

Please also see "Bug 63175 - LOCALHELP for "Navigating in Spreadsheets" with errors" for incomplete Help
Comment 4 Aron Budea 2016-12-26 07:55:21 UTC
*** Bug 90949 has been marked as a duplicate of this bug. ***
Comment 5 Aron Budea 2016-12-26 08:57:38 UTC
*** Bug 71505 has been marked as a duplicate of this bug. ***
Comment 6 steve -_- 2016-12-26 09:40:57 UTC
platform → all since two macOS reports were set to dupe.