Download it now!
Bug 63228 - Printers list does not increase height with Print Dialog
Summary: Printers list does not increase height with Print Dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0 target:4.2.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-07 10:30 UTC by Rainer Bielefeld Retired
Modified: 2014-04-02 09:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshots (250.92 KB, application/pdf)
2013-04-07 10:30 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-04-07 10:30:45 UTC
Created attachment 77554 [details]
screenshots

Observations of users on German Mailing lists 
<http://listarchives.libreoffice.org/de/users/msg08610.html>
are already  [Reproducible] with parallel installation of  "LOdev  4.0.0.0.beta1   -  French UI / German Locale  [Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)]"  {tinderbox: @6, pull time 2012-12-06} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch

and still visible in current Master.

When I increase height of print dialog with 4.0, a big white unused area appears under the selections instead of using the room for more hight of the printers list, see screenshots.
Comment 1 Rainer Bielefeld Retired 2013-04-07 10:34:44 UTC
It should not be too difficult to restore the old behavior, so EasyHack Proposal. 
New due to comments on mailing list. 
I doubt that that problem is limited to WIN

Already  [Reproducible] with Server-installation of Master " 3.7.0.0.alpha0+  – ENGLISH UI [Build ID: f2e622]" {tinderbox: Win-x86@16, pull time 2012-10-06 09:31:39} on German WIN7 Home Premium (64bit) UserInstallation=$SYSUSERCONFIG/LOdev/3
Comment 2 Commit Notification 2014-03-31 15:06:43 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e764b46eea2aab37b7f62d6bf495d2b80080e3b2

Resolves: fdo#63228 Printers list does not increase height with Print Dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2014-04-02 09:07:07 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f85db6b7999d8d4f9f54a0699b73641934d7e441&h=libreoffice-4-2

Resolves: fdo#63228 Printers list does not increase height with Print Dialog


It will be available in LibreOffice 4.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.