Bug Hunting Session
Bug 63276 - FORMCONTROLS: huge sort dialog due big cell content
Summary: FORMCONTROLS: huge sort dialog due big cell content
Status: RESOLVED DUPLICATE of bug 60764
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard: BSA (target:4.1.0)
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-08 17:46 UTC by Markov
Modified: 2013-04-10 14:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
print screen (293.83 KB, image/png)
2013-04-08 17:46 UTC, Markov
Details
options tab print screen (57.51 KB, image/png)
2013-04-08 20:27 UTC, Markov
Details
sort options png (66.28 KB, image/png)
2013-04-08 20:50 UTC, Markov
Details
attach with sort error (111.07 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-08 21:16 UTC, Markov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markov 2013-04-08 17:46:20 UTC
Created attachment 77622 [details]
print screen

Problem description: 

Steps to reproduce:
1. Spreadsheet with a large number of columns ( up to AF )...
2. select sort on menu....
3. ....

Current behavior:
The width of the sort form is long as the number of columns,
far beside screen dimension

Expected behavior:
small form of fixed size 

              
Operating System: Fedora
Version: 4.0.2.2 release
Comment 1 Jorendc 2013-04-08 18:14:47 UTC
Hi,

Thanks for reporting.

I think this is caused by a Combo Box in the 'option' tab (monday, Tuesday, ...) in your UI language.
@Markov: can you please attach a screenshot of the 'option' tab

Seems like a duplicate of Bug 60764, but it should be fixed for that case in LibreOffice 4.0.2.2 (the version you are using).

Is this behavior still reproducible after an user profile reset (guide: https://wiki.documentfoundation.org/UserProfile#Resetting_the_user_profile). If this problem isn't reproducible anymore after that, please zip your user profile and attach it to the bug report so we can examine.

Kind regards,
Joren
Comment 2 Markov 2013-04-08 20:27:00 UTC
Created attachment 77629 [details]
options tab print screen

Hi Joren
I did a reset of libreoffice profile, but the problem is still.
I attach a print screen with tab options ( i hope itìs the right tab ).
I didn't install Italan version but days and months are in italian ( Coming from past installation ? ) 
On Restart I have now two Error Popup

Error loading BASIC of document file:///home/markov/.config/libreoffice/4/user/basic/Standard/script.xlb/
Comment 3 Jorendc 2013-04-08 20:36:28 UTC
Thanks for your fast reply.

I didn't mean that option tab, sorry about that. I mean the option tab in the sort-dialog (see your first screenshot).

You still have a '3' user profile? Is it possible to reset both at once (cut and paste them into another map for example, or rename them both the 3old and 4old).

Kind regards,
Joren
Comment 4 Jorendc 2013-04-08 20:37:01 UTC
Comment on attachment 77629 [details]
options tab print screen

marking this one as obsolete due my bad instructions.
Comment 5 Markov 2013-04-08 20:50:08 UTC
Created attachment 77635 [details]
sort options png

Hi Joren,

Sorry, I didn't understand.
I send sort options ( I hope it's the right one )
I have only  version-4  profile .
If it can help  I devel Qt4 Software ( my be some setting on
the Environment / UI libraries ? ) 

Kind regards
Marco
Comment 6 Markov 2013-04-08 20:58:05 UTC
Hi Joren,

some news.
One column ( P column ) has very long contents ( it's a text description ).
If I cancel the column sort form shows regular size.
If needed I can attach the ods file

Marco
Comment 7 Jorendc 2013-04-08 21:00:47 UTC
(In reply to comment #6)
> If needed I can attach the ods file

Thanks for you additional information. Please attach the document indeed :-).

Kind regards,
Joren

PS: the screenshot is the good one now :-). Thanks
Comment 8 Markov 2013-04-08 21:15:28 UTC
Hi Joren

 I did som more testing,
I think the problem is due to label's cell length.
It was , unnecessary , very long, squeezing spaces I solved the problem.
Probably you can reproduce the bug if you input very long labels with spaces
in the first row.
If so it's a minor bug.

Thank you
Marco
Comment 9 Markov 2013-04-08 21:16:35 UTC
Created attachment 77641 [details]
attach with sort error

I send you  the attachment anyway.

Best Regards
Marco
Comment 10 Jorendc 2013-04-08 21:27:17 UTC
I can confirm this behavior using Linux Mint 14 x64 with LibreOffice 4.0.2.2. I can't anymore using LibreOffice Version: 4.1.0.0.alpha0+ Build ID: 7b515a57eb6a644860715018656ac0b843b62ba (build today).

Steps to reproduce:
* Open attached file
* Select Column E
* Data > Sort ... 
* Extend Selection

Behavior: huge dialog

As you mentioned, I mark this bug as Minor Low and will be fixed in 4.1.0 release.

@Caolon: you know without blinking which patch fixed this issue :-) so we can backport it to LibreOffice 4.0 branch?

Kind regards,
Joren
Comment 11 Caolán McNamara 2013-04-09 16:27:50 UTC
Is this a duplicate of bug #60764 fixed for 4-0 by http://cgit.freedesktop.org/libreoffice/core/commit/?id=e43b2fa55e244db36111a7cb0548f2ff5d2ae66a&h=libreoffice-4-0 ?

IIRC it got committed too late to make it into 4.0.2, so you'd need to test the daily 4-0 builds to see if it's really fixed for 4.0.3
Comment 12 Markov 2013-04-09 17:56:26 UTC
Hi Caaolan,

The bug seems the same. I use Fedora15 with KDE, .
I think the reason, in my case, was the dimension of the header cell
in the table.

Marco
Comment 13 Caolán McNamara 2013-04-10 14:07:18 UTC

*** This bug has been marked as a duplicate of bug 60764 ***