Download it now!
Bug 63289 - FORMATTING: Incorrect representation of WordArt text in docx
Summary: FORMATTING: Incorrect representation of WordArt text in docx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-09 05:12 UTC by bazilio
Modified: 2014-11-16 15:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (405.50 KB, application/x-zip-compressed)
2013-04-10 14:22 UTC, bazilio
Details
A screenshot with LO 4.2.0 (236.09 KB, image/png)
2014-02-08 17:46 UTC, Alexandr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bazilio 2013-04-09 05:12:51 UTC
Problem description: 
I have a document prepared in ms office. When I open it in libre a see an error.

Steps to reproduce:
1. Open 1.docx
2. You will see two angled lines libre.png
3. ....

Current behavior:

Expected behavior:
As in ms.png

              
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Jorendc 2013-04-09 08:56:13 UTC
Hi,

Thanks for reporting.

Is it possible to attach mentioned documents (the document itself, how it should look like and how it now looks like in LibreOffice).

Can you also explain how you created that document (step-by-step), so we can reproduce this behavior from scratch too?

Thanks in advance for your time,
Joren

PS: if you attached/added requested information, please feel free to mark this bug back to UNCONFIRMED
Comment 2 bazilio 2013-04-09 13:14:22 UTC
I'm sorry but in original report a have attached document 1.docx in error.zip.

libre.png - what i'va seen in libre office
ms.png - what i've seen in ms office and should it.


That documents i just recieved via email from my maprtner, I just guess it was created in ms office 2007/2010.
Comment 3 bazilio 2013-04-10 14:22:25 UTC
Created attachment 77746 [details]
test case

I'm sorry but yours attach service for bugs is not very clear.
I'va already attached that file in original report.
Comment 4 Jorendc 2013-04-10 21:53:51 UTC
Thanks for reporting.

Seems like this is the exact behavior of Bug 33072. In that document there is also only a border line/curve visible where the text *should* be in between. Therefore I mark it as such. If bug 33072 is fixed, but you can still reproduce bad behavior in attached document, please feel free to reopen.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 33072 ***
Comment 5 Alexandr 2014-02-08 17:46:15 UTC
Created attachment 93668 [details]
A screenshot with LO 4.2.0

I think this bug is not a duplicate of bug 33072. WordArts in that bug example are visible in LibreOffice 4.1.4, but in an example for this bug WordArt “ОБРАЗЕЦ” is not visible at all. 

The situation has changed in LibreOffice 4.2.0: the WordArt is visible but is situated in front of the text (see attachment).
Comment 6 Joel Madero 2014-11-06 00:42:55 UTC
Never confirmed by QA team - moving to UNCONFIRMED. Thanks for your patience and understanding.
Comment 7 Buovjaga 2014-11-16 15:22:35 UTC
The word art is ok in 4.4 alpha2, but I had to change the table to have no fill - it had white so it blocked a part of the word at. Arrange - Bring to front did not help.

Reporter can check this in MS Office and create a separate bug report, if they wish.

In 4.3.4.1 the word art is completely invisible.

Win 7 64-bit 4.3.4.1 and Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08