Bug 33072 - .docx import - graphics missing (JPEG), wordart messed up
Summary: .docx import - graphics missing (JPEG), wordart messed up
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: All All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-13 11:45 UTC by zaphodfj
Modified: 2014-02-08 15:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing WordArt and JPEGs (145.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-01-13 11:45 UTC, zaphodfj
Details
PDF showing what the DOCX file should look like. (139.19 KB, application/pdf)
2011-01-13 11:47 UTC, zaphodfj
Details
A screenshot with LO 3.5 which shows the bug (200.25 KB, image/png)
2014-02-08 15:15 UTC, Alexandr
Details
A screenshot with LO 4.2.0 : Much better (259.08 KB, image/png)
2014-02-08 15:17 UTC, Alexandr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zaphodfj 2011-01-13 11:45:31 UTC
Created attachment 41983 [details]
DOCX containing WordArt and JPEGs

Using .docx import, graphics and wordart are messed.  

WordArt displays as a black line in the shape of the original text.  Graphics (originally JPEG) are missing.

Tested on: Libo 3.3 beta 2, on Win XP and Ubuntu 10.04.

Attached file - .docx produced by Word 07 SP2.  Front page should show a title (at the top - "The Space Race" and at the bottom, "Student's Name Removed".

Images are missing from all pages, except contents.
Comment 1 zaphodfj 2011-01-13 11:47:00 UTC
Created attachment 41984 [details]
PDF showing what the DOCX file should look like.

PDF to show what the DOCX should look like. I was not able to add 2 attachments to original bug report.
Comment 2 Rainer Bielefeld Retired 2011-05-09 01:21:44 UTC
Bight be related to or DUP of
Bug 32170 - FILEOPEN Opened DOCX-file is empty
Bug 36862 - Docx file displays nothing

I do a cleanup and assign all "DOCX missing contents" bugs to Cédirc

@Cédirc
Please feel free to reassign if it's not your area!
Comment 3 Lior Kaplan 2012-05-07 12:29:50 UTC
This issue is still relevant in 3.5.2...
Comment 4 Jorendc 2013-04-10 21:53:51 UTC
*** Bug 63289 has been marked as a duplicate of this bug. ***
Comment 5 bazilio 2013-04-12 04:45:39 UTC
This issue is still relevant in 4.0.2...
Comment 6 Alexandr 2014-02-08 15:15:28 UTC
Created attachment 93659 [details]
A screenshot with LO 3.5 which shows the bug

I reproduce this bug in LibreOffice 3.5.4 and attach a screenshot to demonstrate how it was. But In LibreOffice 4.1.4 and 4.2.0 WordArt is visible and pictures are on correct places. That's why I  believe this complex bugreport should be resolved worksforme. Please, reopen it if you can reproduce it in LibreOffice 4.2.0 or later.

Unfortunately, opening of the document is not perfect: contents starts on the first page and the bottom WordArt is between the title “Contents” and the contents list. I think it should be another issue.

I do not think that bug 63289 is a duplicate of this one because it is reproducible in  LibreOffice 4.1.4
Comment 7 Alexandr 2014-02-08 15:17:01 UTC
Created attachment 93660 [details]
A screenshot with LO 4.2.0 : Much better