Download it now!
Bug 36862 - Docx file displays nothing (w:txbxContent)
Summary: Docx file displays nothing (w:txbxContent)
Status: RESOLVED DUPLICATE of bug 34617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium normal
Assignee: Luboš Luňák
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-05 00:26 UTC by Dotan Cohen
Modified: 2012-02-27 10:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
docx file which does not open (688.30 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-05-05 00:26 UTC, Dotan Cohen
Details
png image showing how the document should look (548.59 KB, image/png)
2011-05-05 00:27 UTC, Dotan Cohen
Details
Screenshot showing sample document in LO Master 2011-12-01 (26.17 KB, image/png)
2011-12-02 05:52 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2011-05-05 00:26:12 UTC
Created attachment 46348 [details]
docx file which does not open

Attached is a valid Docx file. I do not know which version of MSO created it.
The file displays nothing in LibreOffice. Thanks.
Comment 1 Dotan Cohen 2011-05-05 00:27:32 UTC
Created attachment 46349 [details]
png image showing how the document should look
Comment 2 Muthu 2011-05-05 01:06:47 UTC
One for cedric?
Comment 3 Rainer Bielefeld Retired 2011-05-09 01:09:18 UTC
I modified Status due to facts.

All observations in tests similar to 
"Bug 35983 - No content shown in particular .docx"
but sample for for this one not shown correctly in OOo 3.1.1.

So I can't tell whether it's a simple DUP or also shows additional effects.
Comment 4 Dotan Cohen 2011-05-09 07:01:17 UTC
From the mailing list it appears that this document consists of a single image placed in a textbox. The problem is that LO does not show images in textboxes.

Furthermore, in the same thread it became apparent that this is a common issue: for some reason MSO users often place images in textboxes.
Comment 5 Roman Eisele 2011-12-02 05:51:55 UTC
There is some progress about this bug:

LibO-dev 3.5.0 
Build ID: 549f928-b211287-090bcba-45cf606
Build date: 2011-12-01
running on MacOS X 10.6.8 German

opens the DOCX document and shows a part of the document’s contents -- the textbox just has the wrong size now, it is very narrow. I will attach a screenshot showing the new behaviour. It is possible to double-click on the box and to change its size via entering useful width and height values in the dialog.

So, some progress, but still not correct ...
Comment 6 Roman Eisele 2011-12-02 05:52:41 UTC
Created attachment 54074 [details]
Screenshot showing sample document in LO Master 2011-12-01
Comment 7 Luboš Luňák 2011-12-16 09:59:06 UTC
This is the same like bnc#693388 , so I'll take it.
Comment 8 Tobias Burnus 2012-02-27 09:42:35 UTC
I wonder whether the fix for bug 34617 has helped.
Comment 9 Luboš Luňák 2012-02-27 10:19:51 UTC
Yes.

*** This bug has been marked as a duplicate of bug 34617 ***