Download it now!
Bug 34617 - DOCX import: Textbox comes up empty
Summary: DOCX import: Textbox comes up empty
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium normal
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords:
: 36862 38701 43536 44343 45556 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-23 07:16 UTC by Tobias Burnus
Modified: 2012-02-27 10:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of .DOCX file with Wordviewer (©2004, + Compatibility Pack) under Wine; same result w/ Word 2003+compat pack on XP (35.73 KB, image/png)
2011-02-23 07:16 UTC, Tobias Burnus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2011-02-23 07:16:57 UTC
Created attachment 43703 [details]
Screenshot of .DOCX file with Wordviewer (©2004, + Compatibility Pack) under Wine; same result w/ Word 2003+compat pack on XP

Follow up to bug 34305. Tested with libreoffice-3.3.1 of openSUSE Factory.

The text box in the DOCX file, available at
  https://bugzilla.novell.com/attachment.cgi?id=394228
  (cf. https://bugzilla.novell.com/show_bug.cgi?id=645557 )
comes up empty.

I do not know how it comes up in Microsoft Word 2010, but in Word(viewer) 2003 + compatibility package, it shows up as shown in the attachment. With LibreOffice 3.3.1 it is completely empty.

(One needs the patch for bug 34305, committed after 3.3.1, to see the images in LibreOffice.)
Comment 1 Rainer Bielefeld Retired 2011-05-09 02:10:29 UTC
[Reproducible] with "LibreOffice 3.4Beta4  – WIN7  Home Premium  (64bit)
English UI [DEV300m103 (Build:4)]".

Uner "LOWES" textframes and text is missing in LibO

Contents shown with OOo 3.1.1 (but looks disorted)

Might be related to or DUP of
Bug 32170 - FILEOPEN Opened DOCX-file is empty
Bug 36862 - Docx file displays nothing
Bug 33072 - .docx import - graphics missing (JPEG), wordart messed up
Bug 36791 - Text and images are not displayed from a docx document
Bug 34620 - docx import: Hidden text not shown

I do a cleanup and assign all "DOCX missing contents" bugs to Cédirc

@Cédirc
Please feel free to reassign if it's not your area!
Comment 2 Cédric Bosdonnat 2011-12-16 08:25:20 UTC
The textbox is now imported with master build... though badly formatted
Comment 3 Cédric Bosdonnat 2011-12-16 08:33:30 UTC
*** Bug 38701 has been marked as a duplicate of this bug. ***
Comment 4 Cédric Bosdonnat 2011-12-16 08:34:49 UTC
*** Bug 43536 has been marked as a duplicate of this bug. ***
Comment 5 Rainer Bielefeld Retired 2012-01-10 10:38:40 UTC
*** Bug 44343 has been marked as a duplicate of this bug. ***
Comment 6 Rainer Bielefeld Retired 2012-02-04 09:55:53 UTC
*** Bug 45556 has been marked as a duplicate of this bug. ***
Comment 7 Cédric Bosdonnat 2012-02-27 08:16:45 UTC
Fixed in master and libreoffice-3-5 branch.
Comment 8 Luboš Luňák 2012-02-27 10:19:51 UTC
*** Bug 36862 has been marked as a duplicate of this bug. ***