Bug 63290 - UI: Goal Seek - incorrect term "current cell"
Summary: UI: Goal Seek - incorrect term "current cell"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: low trivial
Assignee: Jorendc
URL:
Whiteboard: target:4.1.0
Keywords: needsDevEval, skillCpp
Depends on:
Blocks:
 
Reported: 2013-04-09 06:00 UTC by grofaty
Modified: 2015-12-15 22:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2013-04-09 06:00:51 UTC
LibreOffice 4.0.2.2 on Windows XP:
1. In cell A1 type in: 100
2. In cell A2 type in: =A1*10
3. Click on cell A2 (there is a formula and will make it easier for next steps).
4. Tools | Goal Seek.
5. Formula cell contains $A$2 (because of step 3). Leave this field as default.
6. Target value type in: 2000
7. Variable cell type in: A1
8. Click on OK button.
9. Dialog appears with text: "Goal Seek successful. Insert result (200) into current cell?"
Now the problem: Dialog reports that it would like to insert result in "current cell" witch in my case is A2. The problem is the term "current cell". I understand term "current cell" the cell that is bordered (marked) and the name is displayed in Name Box (drop-down selection above cell A1). In my case "current cell" is A2 (from step 3). This message "current cell" is wrong. Because value is ALWAYS inserted in "Variable cell", not "current cell". 

Expected: I think dialog instead of:
Goal Seek successful. Insert result (200) into current cell?
should display something like:
Goal Seek successful. Insert result (200) into Variable cell?
Comment 1 Jorendc 2013-04-09 08:40:46 UTC
Hi,

Thanks for reporting.

I totally agree with your comments about the "Current cell" label. Therefore I mark this as NEW.

I mark this bug as trivial low following our prioritizing flowchart https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

Kind regards,
Joren
Comment 2 grofaty 2013-04-09 09:18:03 UTC
Maybe we should even remove any reference to "type" of cell where data will be inserted.
Probably better instead of:
Goal Seek successful. Insert result (200) into current cell?
use:
Goal Seek successful. Result (200). Apply setting to spreadsheet?
Comment 3 Jorendc 2013-04-09 15:25:52 UTC
Patch is under review: https://gerrit.libreoffice.org/#/c/3291/
Comment 4 Cor Nouws 2013-04-09 21:53:17 UTC
(In reply to comment #2)

> Goal Seek successful. Result (200). Apply setting to spreadsheet?

I don't like the word 'setting'

What about
  " Apply entry to spreadsheet? " or
  "Apply value to spreadsheet? " or simply
  "Apply to spreadsheet? "
Comment 5 grofaty 2013-04-10 06:20:21 UTC
@Cor Nouws, I understand you point and I agree with you.
"Apply to spreadsheet?" --> I love this one, it is simple and tells user what will happen. I vote for this.

Other two:
- "entry": it is actually not an entry it is calculated value,
- "value": no need for additional word
Comment 6 grofaty 2013-04-10 06:26:51 UTC
One more detail we should probably talk about. When current dialog "Goal Seek successful..." appears it offers two buttons Yes/No. I don't like Yes/No questions. It forces user to read all of the dialog text and it misunderstood it can lead to undesired results.

My suggestion is:
1. change Yes button label to: Apply
2. change No button label to: Cancel
Comment 7 Commit Notification 2013-04-11 04:26:02 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d06180200195d4c20a58d989f9d2c16cb1989688

fdo#63290 UI: Goal Seek - incorrect term "current cell"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Adolfo Jayme 2013-04-11 05:38:37 UTC
The commit does not take comment 4 into account at all.
Comment 9 Jorendc 2013-04-11 09:45:35 UTC
(In reply to comment #8)
> The commit does not take comment 4 into account at all.

Yes, I see that. I didn't had the time to push another change for review. I only pushed my change to gerrit to ping the UX advice list. After that I saw Cor proposed a better change.

Until now next version of 4.0.x version will not be affected (only 4.1 master version), so no worries about that :-).

I'm sorry for the noise and I'll push the right string changes to gerrit soon.

Kind regards,
Joren
Comment 10 Jorendc 2013-04-11 14:37:55 UTC
Reaction of Stefan Knor at the patch currently under review (https://gerrit.libreoffice.org/#/c/3338/):

Hm, that message sounds a bit odd. How about
Goal seek successful. Insert result ($result) into spreadsheet?


Any ideas/agreements/improvements/...?
Comment 11 Stefan Knorr (astron) 2013-04-11 22:09:54 UTC
Thanks for adding that in there :)

grofaty, can you explain why we should change the verb from "insert" to "apply"? I admit, "insert" is maybe not the most fitting verb, but "apply" seems worse.
Maybe an alternative: "replace value"?


Looking at this more closely, why should we use the term "spreadsheet"? The obvious term seems to be to use "variable cell", no? This is the term that is already used in this dialogue for this particular cell.

I don't think we need emphasise when we're successful – it can be implied.

So, new proposal:
  _____________________________________________________________________
  LibO Calc

  Result of goal seek: $result [line break]
  [line break.]
  Do you want to insert the result into the variable cell?

                                                 [ Insert ] [ Cancel ]
  _____________________________________________________________________


Joren, as you are at it: could you also look into updating the dialogue of a failed goal seek? It's pretty easy to get that, e.g. by using =(A1*RAND()) as the formula.

Proposal for that:
  _____________________________________________________________________
  LibO Calc

  Goal seek unsuccessful. [line break]
  [line break.]
  Do you want to insert the closest result ($result) into the variable
  cell anyway?

                                                 [ Insert ] [ Cancel ]
  _____________________________________________________________________
Comment 12 grofaty 2013-04-12 07:11:02 UTC
@Astron, I understand your point. My main complain was "current cell", so using "variable cell" is more appropriate. Lets use your "Insert" suggestion instead of my suggestion "Apply", it sounds to me as a better solution.

I love the solution you have provided (line brakes etc). Maybe just one additional suggestion, instead of "Do you want to insert..." just use "Insert..." so without "Do you want to". The logic would be the same as for example closing document without saving, it is displayed message "Save changes to..." and not "Do you want to save changes...". Less words to read the better and also to have whole product the same question logic.

One additional suggestion. When Goal Seek dialog opens there is no icon. If you look at close without saving dialog there is question icon. I think we should add the "question" icon to the left of the dialog. It looks more professional.
Comment 13 Jorendc 2013-04-12 20:33:38 UTC
(In reply to comment #11)
> Thanks for adding that in there :)
> 
> grofaty, can you explain why we should change the verb from "insert" to
> "apply"? I admit, "insert" is maybe not the most fitting verb, but "apply"
> seems worse.
> Maybe an alternative: "replace value"?

It isn't that easy to convert the action buttons of the dialog. I pushed a reworked patch to gerrit for review which doesn't change anything to the buttons. They are "hard coded" and depends on the MessBox. There are no RET_INSERT buttons, so this wouldn't be an easy conversion. I'll have a look at it later.
 
> So, new proposal:
>   _____________________________________________________________________
>   LibO Calc
> 
>   Result of goal seek: $result [line break]
>   [line break.]
>   Do you want to insert the result into the variable cell?
> 
>                                                  [ Insert ] [ Cancel ]
>   _____________________________________________________________________
> 

What about the "Goal Seek successful" line? I didn't delete it on my current patch.


(In reply to comment #12)
> I love the solution you have provided (line brakes etc). Maybe just one
> additional suggestion, instead of "Do you want to insert..." just use
> "Insert..." so without "Do you want to". 

Done
 
> One additional suggestion. When Goal Seek dialog opens there is no icon.

I'll also have a look at this. But this may also be a property of the MessBox, so mabye this isn't altered easy too.
Comment 14 Stefan Knorr (astron) 2013-04-12 21:26:03 UTC
(In reply to comment #13)
> What about the "Goal Seek successful" line? I didn't delete it on my current
> patch.

I don't think we absolutely need this – there's a result, so we're successful. (But maybe I am assuming too much – we can keep this in.)

One thing I'd change from yesterday night is that I'd actually replace the "unsuccessful" with "failed." But it should be alright anyway.

Ugh ... I notice, something else went wrong with my failure message: "insert the closest result" is of course bogus if we don't have a result, that should remain value, as it was before.
Comment 15 Stefan Knorr (astron) 2013-04-12 21:49:36 UTC
Joren, I uploaded it my changes from the previous comment (hope that's ok), so we don't have to do too many roundtrips – if you're happy with this, let's just push it.
Comment 16 Jorendc 2013-04-12 22:55:48 UTC
(In reply to comment #15)
> Joren, I uploaded it my changes from the previous comment (hope that's ok),
> so we don't have to do too many roundtrips – if you're happy with this,
> let's just push it.

+1
Comment 17 Commit Notification 2013-04-16 19:33:39 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af4a947174aafe669c129c54c304caa43d90eac7

fdo#63290 - UI: Goal Seek - incorrect term "current cell"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Jorendc 2013-04-16 19:54:23 UTC
I think we can close this one. I'll still have a look at the buttons; but that wasn't the initial problem for this bug report. Therefore I mark this as RESOLVED FIXED, and will have a look at the buttons later.

Kind regards,
Joren
Comment 19 Commit Notification 2013-04-18 15:29:55 UTC
Lior Kaplan committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dbc3b2544acffcf9d8f1f14c3b6fce5c80e0493e

fdo#63290 related: cleanup stings defines due to removal



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Robinson Tryon (qubit) 2015-12-15 22:40:52 UTC
Migrating Whiteboard tags to Keywords: (ProposedEasyHack -> needsDevEval, SkillCpp )
[NinjaEdit]