Bug 63321 - SVG: Exported to SVG image missing a shape
Summary: SVG: Exported to SVG image missing a shape
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-09 15:40 UTC by Dmitry Chestnykh
Modified: 2014-08-11 09:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Source LibreOffice document. (16.60 KB, application/vnd.oasis.opendocument.graphics)
2013-04-09 15:40 UTC, Dmitry Chestnykh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Chestnykh 2013-04-09 15:40:10 UTC
Created attachment 77674 [details]
Source LibreOffice document.

Problem description: 

When exporting the attached document to SVG and viewing it
in different programs, the bottom orange shape is
missing.

Screenshots (original in LibreOffice Draw and exported SVG in WebKit, Firefox, and Inkscape) can be viewed here:
http://imgur.com/a/LVJLO

The source document is attached.
Operating System: Mac OS X
Version: 4.0.2.2 release
Comment 1 Thomas van der Meulen 2013-04-09 18:10:10 UTC
Thank you for your bug report, I can reporduce this bug running LibreOffice 4.0.2.2 on Mac osx 10.8.3.
Comment 2 Julien Nabet 2013-04-09 19:24:53 UTC
On pc Debian x86-64 with master sources updated today, I reproduced this problem

I noticed this type of logs on console:
warn:legacy.osl:15196:1:filter/source/svg/svgwriter.cxx:3672: SVGActionWriter::ImplWriteActions: unsupported MetaAction #

Thorsten/Radek: one for you?
Comment 3 Julien Nabet 2013-04-09 19:47:35 UTC
Just for information, when adding trace about unsupported MetaAction, it's the "150" each time (META_TEXTLANGUAGE_ACTION, see http://opengrok.libreoffice.org/xref/core/vcl/inc/vcl/metaact.hxx#91)
Comment 4 Dmitry Chestnykh 2013-04-09 20:59:17 UTC
Also, notice that when displayed in WebKit and Inkscape, the text "Depth" is not rotated. It is correctly rotated in Firefox and in the source in Draw.

The shape is:

<g xmlns="http://www.w3.org/2000/svg" class="com.sun.star.drawing.TextShape">
      <g id="id13">
       <text class="TextShape"><tspan class="TextParagraph" font-family="Arial, sans-serif" font-size="494px" font-weight="400"><tspan class="TextPosition" x="1574" y="5330" transform="translate(1574,5330) rotate(-90) translate(-1574,-5330)"><tspan fill="rgb(148,0,107)" stroke="none">Depth</tspan></tspan></tspan></text>
      </g>
     </g>


Notice that `transform` is on the <tspan> element. When I move it to text:

<g xmlns="http://www.w3.org/2000/svg" id="id13">
       <text class="TextShape" transform="translate(1574,5330) rotate(-90) translate(-1574,-5330)"><tspan class="TextParagraph" font-family="Arial, sans-serif" font-size="494px" font-weight="400"><tspan class="TextPosition" x="1574" y="5330"><tspan fill="rgb(148,0,107)" stroke="none">Depth</tspan></tspan></tspan></text>
      </g>


it becomes correct in WebKit: http://i.imgur.com/PuuP4jp.png
Comment 5 Gerry 2013-04-30 15:10:32 UTC
I can reproduce the bug on 4.0.0.3 and 3.6.2.2 on Ubuntu 12.10. Pattern is missing on export.

Importing (File->Open) the SVG file again does not work nicely. It imports as a black box in both versions. The import is unusable.

When inserting the SVG-file in 4.0.0.3 (Insert->Picture->From File), it looks like in the other web browsers. It actually looks better in 4.0.0.3 than in 3.6.2.2 where the background is completely missing.
Comment 6 Christina Rossmanith 2013-06-11 12:01:09 UTC
If the style of the blue hatching is copied via "Format Paintbrush" the shape is exported correctly. Just changing the hatching isn't enough.

Version: 4.2.0.0.alpha0+
Build ID: 6e4637db213e7570d3920902288ca15b5e61b19
Linux
Comment 7 retired 2014-08-11 09:36:44 UTC
Looking good to my eyes with

OSX 10.9.4.
LO Version: 4.4.0.0.alpha0+
Build ID: aa0e3701aad1a8a955773e869d9a6b59eac51e72
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2014-08-10_06:59:50

Open test file, then File > Export > svg
Open exported svg with chromium

Looking good. Hatching orange lines are there.

WORKSFORME.