Bug 63322 - FILEOPEN: Crash when opening exported SVG
Summary: FILEOPEN: Crash when opening exported SVG
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-09 15:43 UTC by Dmitry Chestnykh
Modified: 2013-08-24 11:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash log (77.99 KB, text/plain)
2013-04-09 15:43 UTC, Dmitry Chestnykh
Details
SVG exported from LibreOffice (33.21 KB, image/svg+xml)
2013-08-06 13:45 UTC, Dmitry Chestnykh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Chestnykh 2013-04-09 15:43:55 UTC
Created attachment 77675 [details]
Crash log

Problem description: 

LibreOffice Draw crashes when opening the exported SVG drawing.

Steps to reproduce:
1. Open the document attached to bug 63321.
2. Export it to SVG by clicking File > Export.
3. Open the exported SVG with LibreOffice by clicking File > Open.

Current behavior:

Crash!

Expected behavior:

Opened document.

--
Crash log attached.
Operating System: Mac OS X
Version: 4.0.2.2 release
Comment 1 Thomas van der Meulen 2013-04-09 16:12:13 UTC
Hello Dmitry, Thank you for your bug report. I can reprorduce this bug running LibreOffice 4.0.2.2 on mac osx 10.8.3.
Comment 2 Julien Nabet 2013-04-09 19:32:47 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce the crash but the svg is quite broken.
I noticed these logs:
warn:legacy.tools:15282:1:xmloff/source/core/xmlimp.cxx:748: SvXMLImport::endElement: popped context has wrong prefix
warn:legacy.tools:15282:1:xmloff/source/core/xmlimp.cxx:748: SvXMLImport::endElement: popped context has wrong prefix
warn:legacy.osl:15282:1:xmloff/source/core/xmlerror.cxx:184: An error or a warning has occurred during XML import/export!
Error-Id: 0x10020002
    Flags: 1 WARNING
    Class: 2 FORMAT
    Number: 2
Parameters:
    0: fo:font-family
    1: 
Exception-Message: 

warn:legacy.osl:15282:1:svx/source/sdr/contact/viewcontactofsdrpathobj.cxx:66: PolyPolygon object without geometry detected, this should not be created (!)
warn:legacy.osl:15282:1:xmloff/source/core/xmlerror.cxx:184: An error or a warning has occurred during XML import/export!
Error-Id: 0x10040001
    Flags: 1 WARNING
    Class: 4 API
    Number: 1
Parameters:
    0: svggradient0
Exception-Message: 

Thorsten/Radek: one for you?
Comment 3 Don't use this account, use tml@iki.fi 2013-08-06 12:49:49 UTC
I could not reproduce this with LibreOffice 4.1.0.4. (But the SVG I had exported rendered quite brokenly in LO, more sanely in Safari.)

Dmitry, if you still have the *SVG* file that crashes/crashed LibreOffice, please attach it.
Comment 4 Dmitry Chestnykh 2013-08-06 13:44:22 UTC
(In reply to comment #3)
> I could not reproduce this with LibreOffice 4.1.0.4. (But the SVG I had
> exported rendered quite brokenly in LO, more sanely in Safari.)

Indeed, no longer crashes in 4.1.0.4. I guess this bug can be marked as fixed.
I'm still attaching the SVG which I verified crashed 4.0.3.3 on OS X (but not 4.0.2.2 on Ubuntu 13.04).
Comment 5 Dmitry Chestnykh 2013-08-06 13:45:49 UTC
Created attachment 83720 [details]
SVG exported from LibreOffice

Opening this SVG crashed 4.0.3.3 on OS X, but no longer crashes 4.1.0.4.
Comment 6 Julien Nabet 2013-08-24 11:42:20 UTC
Dmitry: thank you for your feedback, since it works for your in 4.1.0.4, I'll put it as WFM.