Bug 63503 - delete button in special character dialog shouldn't delete all
Summary: delete button in special character dialog shouldn't delete all
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-13 18:10 UTC by almos
Modified: 2013-05-07 01:55 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description almos 2013-04-13 18:10:08 UTC
Clicking on a character in the table appends it to the string to be inserted, so it is easy to add an unwanted character. However, the 'delete' button deletes the whole string, which is not only unintuitive, but also frustrating, because most of the time one just wants to undo the last addition, and not to restart from the beginning.
Comment 1 Joel Madero 2013-04-18 02:38:22 UTC
Please provide numerated detailed steps on how to reproduce, even if it seems simple to you, for triaging purposes we need the steps in order to see exactly what you see.

Marking as NEEDINFO, once you provide the steps mark as UNCONFIRMED and we will triage the bug :)



Thanks for your understanding and help
Comment 2 almos 2013-04-18 09:29:07 UTC
Steps to reproduce:
1. Insert/Special character...
2. Click on any character in the table on the left: this will print the clicked character below the table, right after the label 'Characters:'
3. Repeat step 2 a few times: the clicked characters are printed below the table, each after the previously clicked character
(Now if you click on the button labeled as 'OK', all of the characters gathered in steps 2 and 3 are inserted at the cursor position in the document)
4. Click on the button labeled as 'Delete' in the bottom right corner: it deletes all the characters gathered so far
5. You realize you cannot undo step 4, and perform something like this:
http://www.youtube.com/watch?feature=player_detailpage&v=wFnCYgoYvBA#t=22s

Why is the current behavior wrong? Because gathering characters from the semi-ordered table can be very time-consuming and/or frustrating. When you are looking for 4 special characters, found 3 of them, then accidentally clicked on something you don't want, and you try to remove it, you can start the whole process again from the beginning. This kills the whole feature of inserting more than one special character at once.

I see two possible solutions:
1. The 'Delete' button is renamed to 'Delete all'
2. The 'Delete' button only removes the last character of the string (preferred)

Is this detailed enough?
Comment 3 Joel Madero 2013-04-18 13:56:42 UTC
Will attempt to reproduce :)
Comment 4 Commit Notification 2013-04-18 19:49:44 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab7776e1bc0687b6e42ffa6e837435800b4a58af

fdo#63503 add 'Delete Last' button to Special Characters dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Adolfo Jayme 2013-05-06 04:07:54 UTC
To make things simpler, why not remove both “Delete” and the newly added “Delete All” and make the “Character” label a text box? That way, UI is simplified and the user can delete characters one by one with the Backspace key or the Delete key.
Comment 6 almos 2013-05-06 08:07:42 UTC
(In reply to comment #5)
> To make things simpler, why not remove both “Delete” and the newly added
> “Delete All” and make the “Character” label a text box? That way, UI is
> simplified and the user can delete characters one by one with the Backspace
> key or the Delete key.

Yes, please.
Comment 7 Andras Timar 2013-05-06 08:36:16 UTC
UI font not necessarily contains the required glyph, simple Edit box is not good for that purpose. We would need a rich text edit box. Feel free to open a new bug and/or hack on this, it is an easy hack.
Comment 8 Adolfo Jayme 2013-05-07 01:55:05 UTC
Thanks a bunch András for replying, I’ve now submitted my suggestion as bug #64302 and will attempt to hack on it :-)