Bug Hunting Session
Bug 63538 - Zero Width Space (U+200B) always visible, even when not viewing Nonprinting Characters
Summary: Zero Width Space (U+200B) always visible, even when not viewing Nonprinting C...
Status: RESOLVED DUPLICATE of bug 58434
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-15 05:29 UTC by Brian Wilson
Modified: 2014-06-13 16:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Wilson 2013-04-15 05:29:08 UTC
[Update before posting: Also tested today Libreoffice 3.4.4 on Linux Ubuntu 11.10 and Libreoffice 3.5.4.2 on Windows XP and newly installed Liberoffice 4.0.2.2 on Macbook running Mountain Lion all with the same results]

Request: That the visibility of the Zero Width Space is turned on and off with the other Nonprinting Characters.

Since the Lao written language does not word wrap properly, scripts have been developed for windows and MS word to automatically insert a Zero Width Space (U+200B) between each word. These are indivisible in MS Word, but show up as small  forward slashes with a dark grey background in Libreoffice. (I have observed this over several years on Mac, Windows and Linux. Currently I am on a Mac with Libreoffice 4.0.1.2 (wish there were automatic updates).

The issue is that the visible Zero Width Space is not turned off when disabling "view Nonprinting Characters". 

Here is a Zero Width Space between the reversed angle brackets.  >​<

And here is some Lao text to observe (happens to be Jude 1:9 three times as that was what I had handy).

ແຕ່​ມີຄາເອນ ຜູ້​ເປັນ​ນາຍ​ທູດສະຫວັນ ເມື່ອ​ໂຕ້​ແຍ່ງ​ກັບ​ມານ​ເລື່ອງ​ສົບ​ຂອງ​ໂມເຊ ກໍ​ບໍ່​ບັງອາດ​ກ່າວ​ໂທດ​ມານ​ດ້ວຍ​ຖ້ອຍ​ຄຳ​ທີ່​ເປັນ​ການ​ສົບ​ປະໝາດ​ເລີຍ ແຕ່​ກ່າວ​ພຽງ​ວ່າ “ຂໍ​ໃຫ້​ອົງ​ພຣະ​ຜູ້​ເປັນ​ເຈົ້າ​ຊົງ​ຕິ​ຕຽນ​ເຈົ້າ​ເທີ້ນ”. ແຕ່​ມີຄາເອນ ຜູ້​ເປັນ​ນາຍ​ທູດສະຫວັນ ເມື່ອ​ໂຕ້​ແຍ່ງ​ກັບ​ມານ​ເລື່ອງ​ສົບ​ຂອງ​ໂມເຊ ກໍ​ບໍ່​ບັງອາດ​ກ່າວ​ໂທດ​ມານ​ດ້ວຍ​ຖ້ອຍ​ຄຳ​ທີ່​ເປັນ​ການ​ສົບ​ປະໝາດ​ເລີຍ ແຕ່​ກ່າວ​ພຽງ​ວ່າ “ຂໍ​ໃຫ້​ອົງ​ພຣະ​ຜູ້​ເປັນ​ເຈົ້າ​ຊົງ​ຕິ​ຕຽນ​ເຈົ້າ​ເທີ້ນ”. ແຕ່​ມີຄາເອນ ຜູ້​ເປັນ​ນາຍ​ທູດສະຫວັນ ເມື່ອ​ໂຕ້​ແຍ່ງ​ກັບ​ມານ​ເລື່ອງ​ສົບ​ຂອງ​ໂມເຊ ກໍ​ບໍ່​ບັງອາດ​ກ່າວ​ໂທດ​ມານ​ດ້ວຍ​ຖ້ອຍ​ຄຳ​ທີ່​ເປັນ​ການ​ສົບ​ປະໝາດ​ເລີຍ ແຕ່​ກ່າວ​ພຽງ​ວ່າ “ຂໍ​ໃຫ້​ອົງ​ພຣະ​ຜູ້​ເປັນ​ເຈົ້າ​ຊົງ​ຕິ​ຕຽນ​ເຈົ້າ​ເທີ້ນ”.

Here it is without the Zero Width Space

ແຕ່ມີຄາເອນ ຜູ້ເປັນນາຍທູດສະຫວັນ ເມື່ອໂຕ້ແຍ່ງກັບມານເລື່ອງສົບຂອງໂມເຊ ກໍບໍ່ບັງອາດກ່າວໂທດມານດ້ວຍຖ້ອຍຄຳທີ່ເປັນການສົບປະໝາດເລີຍ ແຕ່ກ່າວພຽງວ່າ “ຂໍໃຫ້ອົງພຣະຜູ້ເປັນເຈົ້າຊົງຕິຕຽນເຈົ້າເທີ້ນ”. ແຕ່ມີຄາເອນ ຜູ້ເປັນນາຍທູດສະຫວັນ ເມື່ອໂຕ້ແຍ່ງກັບມານເລື່ອງສົບຂອງໂມເຊ ກໍບໍ່ບັງອາດກ່າວໂທດມານດ້ວຍຖ້ອຍຄຳທີ່ເປັນການສົບປະໝາດເລີຍ ແຕ່ກ່າວພຽງວ່າ “ຂໍໃຫ້ອົງພຣະຜູ້ເປັນເຈົ້າຊົງຕິຕຽນເຈົ້າເທີ້ນ”. ແຕ່ມີຄາເອນ ຜູ້ເປັນນາຍທູດສະຫວັນ ເມື່ອໂຕ້ແຍ່ງກັບມານເລື່ອງສົບຂອງໂມເຊ ກໍບໍ່ບັງອາດກ່າວໂທດມານດ້ວຍຖ້ອຍຄຳທີ່ເປັນການສົບປະໝາດເລີຍ ແຕ່ກ່າວພຽງວ່າ “ຂໍໃຫ້ອົງພຣະຜູ້ເປັນເຈົ້າຊົງຕິຕຽນເຈົ້າເທີ້ນ”.

Copying the above paragraphs and pasting them into Libreoffice will show the difference in behaviour of these two paragraphs.

Request: That the visibility of the Zero Width Space is turned on and off with the other Nonprinting Characters.
Comment 1 Urmas 2013-04-15 06:25:57 UTC
Confirming.
Comment 2 Andras Timar 2013-04-20 08:08:53 UTC
You can turn off field shading. View - Field Shading (Ctrl+F8)

It is an interesting question, why these formatting marks (zero with space, optional hyphen, etc.) have field shading.
Comment 3 Simo Kaupinmäki 2014-06-12 11:57:27 UTC
Indeed. It's nice to have the option to make special spaces, hyphens etc. stand out, but it would be more intuitive if this was linked to the visibility of non-printing characters.

It seems that no-break space (U+00A0), word joiner (U+2060), and non-breaking hyphen (U+2011) also have field shading, but narrow no-break space (U+202F) and figure space (U+2007) do not, although these are all non-breaking characters.
Comment 4 Simo Kaupinmäki 2014-06-13 16:05:10 UTC

*** This bug has been marked as a duplicate of bug 58434 ***