Bug 63568 - Inserting rectangle with hatching instead of colour => crash of writer
Summary: Inserting rectangle with hatching instead of colour => crash of writer
Status: RESOLVED DUPLICATE of bug 62287
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: low critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-15 19:37 UTC by Bernd Kloss
Modified: 2013-05-04 12:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
crash log mac osx 10.8.3 (62.15 KB, text/plain)
2013-04-17 14:19 UTC, Jorendc
Details
crash-report (98.30 KB, text/plain)
2013-04-17 15:01 UTC, Bernd Kloss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Kloss 2013-04-15 19:37:28 UTC
Drawing-function within writer
inserting rectangle
right-click the rectangle for changing the pattern of the tile to hatching
writer crashes
Comment 1 Jorendc 2013-04-15 21:50:05 UTC
Thanks for reporting!

I can reproduce a crash using Mac OSX 10.8.3 with LibreOffice 4.0.2.2

Also reproducible using master build (also Mac OSX 10.8.3) Version: 4.1.0.0.alpha0+ Build ID: afb3af7ce5fef803d42a549095863e6bb8210ef

Not reproducible using LibreOffice 3.6.4.2. Therefore -> regression.

* open Draw
* draw a rectange
* right click > Edit Style ...
* tab 'Area'
* Change the selector to 'Hatching'
* Select a hatch (I used 'black 45 degrees')
* Ok

-> Crash

Kind regards,
Joren
Comment 2 Julien Nabet 2013-04-17 13:44:53 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this by following step by step process of Joren.

Bernd: could you retrieve traces by using this link? (https://wiki.documentfoundation.org/BugReport#How_to_get_debug_information_on_Mac_OS_X)
Comment 3 Jorendc 2013-04-17 14:19:56 UTC
Created attachment 78135 [details]
crash log mac osx 10.8.3
Comment 4 Bernd Kloss 2013-04-17 15:01:28 UTC
Created attachment 78138 [details]
crash-report

Thanks for taking care!
Regards
Bernd
Comment 5 Julien Nabet 2013-05-04 06:43:06 UTC
seeing this http://cgit.freedesktop.org/libreoffice/core/commit/?id=43a23fb3f8f1ffa4937658dd9393d23533b84d18, I wonder if it the bug could be solved.
dup of fdo#62287?

Joren/Bernd: could one of you give a try to a 4.0.3 prerelease?
Comment 6 retired 2013-05-04 06:51:16 UTC
Interesting. I tried re-producing this on 10.8.3 and LO 4.0.3.1 and couldn't get LO to crash. Working fine for me.

Jorendc, Bernd: Could you confirm this is fixed in 4.0.3.1?
http://www.libreoffice.org/download/pre-releases/
Comment 7 retired 2013-05-04 06:52:11 UTC
Setting to Resolved, Fixed.

Should this problem be persisting for any of you with the 4.0.3.1 release, please re-open this bug. Thanks :)
Comment 8 Julien Nabet 2013-05-04 06:56:12 UTC
Thank you James for the test, I put this as dup.

*** This bug has been marked as a duplicate of bug 62287 ***
Comment 9 Bernd Kloss 2013-05-04 09:05:13 UTC
I tried 4.0.3.1 and it has been working.

Thank you for fixing it.
Comment 10 Jorendc 2013-05-04 12:54:46 UTC
Yes, I can triple-verify this is fixed :-)!

Thanks for that, and thanks for retesting!