Bug Hunting Session
Bug 63592 - change text direction while editing take you out from the edit mode
Summary: change text direction while editing take you out from the edit mode
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium normal
Assignee: abdulmajeed
URL:
Whiteboard: target:4.1.0
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2013-04-16 09:08 UTC by abdulmajeed
Modified: 2013-05-22 16:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abdulmajeed 2013-04-16 09:08:15 UTC
step to reproduce:
1-open clac 
2- type any thing inside cell
3- change text direction LTR <-> RTL

current behavior:
gets you out from the edit mode

correct behavior:
keep you in the edit mode
Comment 1 abdulmajeed 2013-04-16 11:51:05 UTC
also if you continue typing it will overwrites the previous content inside the cell
and this is annoying
Comment 2 Urmas 2013-04-16 13:32:21 UTC
Confirmed in master. The direction toolbar buttons are confirming cell entry, unlike alignment buttons &co.
Comment 3 Lior Kaplan 2013-04-17 05:46:32 UTC
Bug confirmed on 4.0.2.2, updating bug's version.
Comment 4 Caolán McNamara 2013-04-18 10:14:37 UTC
Looks like the code at the top of ScFormatShell::ExecuteTextDirection kicks out of edit mode

if ( GetViewData()->HasEditView( GetViewData()->GetActivePart() ) )           
{                                                                             
    SC_MOD()->InputEnterHandler();                                            
    pTabViewShell->UpdateInputHandler();                                      
} 


ScFormatShell::ExecuteAlignment on the other hand doesn't kick out of edit mode.
Comment 5 Caolán McNamara 2013-04-18 10:32:00 UTC
I have a proposal at https://gerrit.libreoffice.org/#/c/3450/ as an alternative to that of https://gerrit.libreoffice.org/#/c/3406/
Comment 6 Commit Notification 2013-04-18 15:22:10 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c3db8a660fbbcfca277e5cf22a3987c35e656d0

Resolves: fdo#63592 changing text direction exits edit mode



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2013-04-18 15:57:03 UTC
seems to be fixed
Comment 8 Lior Kaplan 2013-04-18 17:17:18 UTC
Fix verified on a build from master.
Comment 9 abdulmajeed 2013-04-27 09:08:33 UTC
Reopening 
this bug patch cause another problem
problem is:
change your numerical type to context (tools>option>language setting>complex text layout)

1-type  123 in LTR mode 
2-change to RTL mode 
3-problem is calc doesn't update the view so you have to get out from edit and enter again then it will be updated.

i will upload a new patch after minutes.
Comment 10 abdulmajeed 2013-04-27 09:17:21 UTC
you can check the proposal patch here
https://gerrit.libreoffice.org/#/c/3629/
Comment 11 Commit Notification 2013-04-29 09:35:00 UTC
abdulmajeed ahmed committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5a8a57703cad29ec2865390f3ced34af0e82b33f

fdo#63592 Solve context numerical problem when changing text direction



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Lior Kaplan 2013-05-22 16:37:22 UTC
Fixed verified on a build from master (4.1 branching point).