Bug 63619 - Arabic: when use Arabic letters currency the number are disappear
Summary: Arabic: when use Arabic letters currency the number are disappear
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RTL-Arabic
  Show dependency treegraph
 
Reported: 2013-04-17 05:22 UTC by Faisal Menawer
Modified: 2017-10-19 23:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test-Screenshot (16.06 KB, image/png)
2013-04-17 05:24 UTC, Faisal Menawer
Details
Example document (7.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-05-02 19:19 UTC, Urmas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Faisal Menawer 2013-04-17 05:22:29 UTC
the number disappear after use Arabic currency 

steps to reproduce:
1-open calc.
2-change the currency to one of arabic currency(for example: SAR- Arabic)
3-enter any number and use number format currency.

Current behavior:
the number disappear

Expected behavior:
the number still there and had the wanted currency.

workaround:
it works fine if the cell are merged.
Comment 1 Faisal Menawer 2013-04-17 05:24:07 UTC
Created attachment 78120 [details]
Test-Screenshot
Comment 2 Faisal Menawer 2013-04-20 12:19:10 UTC
The number disappear when we use an Arabic currency
and the alignment are default.

workaround:
change the alignment
Comment 3 Eike Rathke 2013-04-22 17:26:10 UTC
Already didn't work in 3.5.7.2, it did work in earlier OOo though.
Comment 4 Lior Kaplan 2013-04-24 06:17:13 UTC
The weird thing is that it works fine for Frasi (IRR), while it doesn't work for any of the other Arabic languages.
Comment 5 Faisal Menawer 2013-04-24 11:51:43 UTC
it is work fine for Frasi (IRR) because it is print the number before
the currency.

if you change the format to print the currency first the problem appear too.

And i notice something the Farsi currency are moving if you change the
text direction.
is this a correct behavior?
Comment 6 Eike Rathke 2013-04-24 16:09:03 UTC
I suspect the cause to be deep inside vcl and the layout algorithms. If anyone could dig into that?
Comment 7 Khaled Hosny 2013-05-02 05:37:10 UTC
I don’t use spreadsheet applications, so I’m not really sure how to follow the listed steps, is there a dummies version of this or, even better, a test file that I can just open to see the effect of this bug?
Comment 8 Urmas 2013-05-02 19:19:41 UTC
Created attachment 78796 [details]
Example document
Comment 9 Faisal Menawer 2013-11-19 05:26:40 UTC
the bug are fix on
Version: 4.2.0.0.alpha1+
Build ID: 6fd82243e26af3cace74beeb2193c40f39b84bc2