Download it now!
Bug 63638 - RTL: target value
Summary: RTL: target value
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-17 11:32 UTC by mjpric
Modified: 2014-01-25 17:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
you can convert this spreadsheet to .xlsx format and verify that MSExcel success to solve it (147.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-04-17 11:32 UTC, mjpric
Details
attachment-21046-0.html (4.19 KB, text/html)
2014-01-25 16:30 UTC, mjpric
Details
attachment-21046-1.dat (1 bytes, multipart/alternative)
2014-01-25 16:30 UTC, mjpric
Details
IMSTP12.gif (46.83 KB, image/gif)
2014-01-25 16:30 UTC, mjpric
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mjpric 2013-04-17 11:32:15 UTC
Created attachment 78131 [details]
you can convert this spreadsheet to .xlsx format and verify that MSExcel success to solve it

Problem description: 
the aim of the spread sheet is to calculate or verify rate interest of a loan (long term) with differents financials flows.
 
Calc hangs : it doesnot answer when trying to solve with :
menu/tools/target value search 

the parameters of the search are written on line 8 :
read explanations in cells A7:A9
line 9 give the results obtained with MSExcel 

(with shorter loans, results are correct - no change to calc standard options : path 100 minimal change 0.001)

Current behavior: "deadlock"

Expected behavior: MS Excel success to solve see line 9 :
variable values obtained (interest rate) E9, H9, K9, N9 respectively  when trying to obtain 0 in F9  I9  L9  P9 
- I suggest that the function halts after 100 unsucessfull path and give choice of "continue" or " cancel"
              
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 tommy27 2014-01-25 10:14:32 UTC
hi, did you try current 4.1.4.2 release? is bug still there?
Comment 2 mjpric 2014-01-25 16:30:59 UTC
Created attachment 92773 [details]
attachment-21046-0.html

Hello,

Thanks a lot. 

Yes, obviously the sample that I send works well now.
I've tested some others : again Calc find the right solution...
the improvement seems to be general.....

I'll give again a new donation to your organisation.

Greetings for this good job again.

Michel RICARD - (ex-IBM system engineer -70yrs old - Delphi XE5 Dvlpt today)
 
 
 
 
-------Message original-------
 
De : bugzilla-daemon@freedesktop.org
Date : 25/01/2014 11:14:34
A : mjpric@gmail.com
Sujet : [Bug 63638] RTL: target value
 
tommy27 changed bug 63638 
WhatRemovedAdded
CC  barta@quipo.it 
SummaryRTL: target valu RTL: target value 

Comment # 1 on bug 63638 from tommy27 
hi, did you try current 4.1.4.2 release? is bug still there?


You are receiving this mail because: 
You reported the bug.
Comment 3 mjpric 2014-01-25 16:30:59 UTC
Created attachment 92774 [details]
attachment-21046-1.dat
Comment 4 mjpric 2014-01-25 16:30:59 UTC
Created attachment 92775 [details]
IMSTP12.gif
Comment 5 tommy27 2014-01-25 17:25:35 UTC
ok Michel, I set status to RESOLVED.