Download it now!
Bug 63667 - CRASH when FILESAVE document with complex nested TABLES as .doc/.docx
Summary: CRASH when FILESAVE document with complex nested TABLES as .doc/.docx
Status: RESOLVED DUPLICATE of bug 64872
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-18 05:03 UTC by Matthew Francis
Modified: 2013-11-20 18:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (69.45 KB, text/plain)
2013-04-18 05:04 UTC, Matthew Francis
Details
Crashing file (8.87 KB, application/vnd.oasis.opendocument.text)
2013-04-18 05:04 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2013-04-18 05:03:34 UTC
Saving a certain file as .doc / .docx (2007/2010) / .docx (Office Open XML) causes Writer to hang (for .doc) or crash (for the other two filetypes)

Backtrace and minimised ODT of the crashing file attached
Comment 1 Matthew Francis 2013-04-18 05:04:07 UTC
Created attachment 78164 [details]
Backtrace
Comment 2 Matthew Francis 2013-04-18 05:04:44 UTC
Created attachment 78165 [details]
Crashing file
Comment 3 Rainer Bielefeld Retired 2013-04-19 14:49:54 UTC
[Reproducible] with server installation of "LibO  4.0.2.2 rc   -  German UI / German Locale  [Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)]"  {tinderbox: @6, pull time  2013-03-26 12:00(?)} on German WIN7 Home Premium (64bit) with newly created own user profile 

@Matthew Francis
General problem with those file types or limited to your sample document?
Comment 4 Rainer Bielefeld Retired 2013-04-19 14:56:14 UTC
Worked fine with 3.4.5, so REGRESSION

Still required: tests with what version the problem appeared
Comment 5 Matthew Francis 2013-04-19 16:40:56 UTC
(In reply to comment #3)

> @Matthew Francis
> General problem with those file types or limited to your sample document?

All I can tell you is I wasn't specifically trying to torture-test anything. The attached sample is a redacted version of an actual business document I was working with.

After I saw the bug occur, I spent a few minutes paring the problematic file down to the minimum file I could construct that would trigger it, then briefly and inexhaustively explored the set of available output formats to find which others might have the same problem. That's all I have.
Comment 6 Matthew Francis 2013-04-19 16:50:55 UTC
(In reply to comment #3)

I haven't seen anything else like this problem occur except on this one file with the interestingly nested tables - if that was your question

I don't have a bug reference handy but there was a long standing bug fixed a couple of versions back where tables would be corrupted on export to MS formats (and a big thankyou to whoever finally killed that one). Long shot but maybe related?
Comment 7 Michael Stahl (CIB) 2013-05-28 21:25:49 UTC
fixed by e94c8521041259d36aaadcadb9e42ca729a3812b

*** This bug has been marked as a duplicate of bug 64872 ***