Bug 63708 - FILTER: need filter view like ms excel 2007 in libreoffice calc
Summary: FILTER: need filter view like ms excel 2007 in libreoffice calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:5.4.0 target:5.3.3
Keywords:
Depends on:
Blocks: Data-Filter
  Show dependency treegraph
 
Reported: 2013-04-19 06:51 UTC by Radhey
Modified: 2018-04-30 18:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
i am using filter(date format) in excel 2007. In this, first years is selected then monthly will automatically come then days. (1.15 MB, image/bmp)
2013-04-19 06:51 UTC, Radhey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Radhey 2013-04-19 06:51:07 UTC
Created attachment 78209 [details]
i am using filter(date format) in excel 2007. In this, first years is selected then monthly will automatically come then days.

i want to apply filter on the basis of years then months name then days like in Microsoft office excel 2007. I need same as excel 2007 in libreoffice calc.
Operating System: Ubuntu
Version: 4.0.0.3 release
Comment 1 Jorendc 2013-05-13 10:55:43 UTC
hi,

Thanks for reporting.

As far I can understand from your bug report you would like to sort a date, first sort by year, then sort by month, then by date... but can't you sort a data using the Calc feature: Data > Sort...?

If not, please attach a sample document and a more precise description of what you can't do with calc.

Kind regards,
Joren
Comment 2 Alexander Schneider 2013-07-23 13:45:55 UTC
I have just arrived here looking for / requesting the same feature Radhey is looking for.

When Excel 2007 creates a filter on a date field, it creates a hierarchy in the filter dialog box: first it displays the years, after you check a year, it displays the corresponding months, after you check the month, it displays the corresponding dates.

This feature enables users to be much faster when selecting larger date intervals than what is possible in LibreOffice Calc right now - selecting individual dates in a plethora of rows in the dialog box in LibreOffice is just tedious.

I would like request this feature to be implemented.
Comment 3 QA Administrators 2014-02-02 02:07:08 UTC Comment hidden (obsolete)
Comment 4 GerardF 2014-02-02 11:02:40 UTC
Not a bug, but a valid enhancement request.
Mark as New and Enhancement.
Comment 5 V Stuart Foote 2018-04-30 18:23:21 UTC
The requested GUI filter is already implemented as an Calc "Auto Filter" applied against Date formatted columns. 

Fully correct at 5.3.3 and 5.4.0 builds onward.

=-ref-=
https://gerrit.libreoffice.org/gitweb?p=core.git;a=commitdiff;h=e5755f4022c1e99514a236a97a9a62552dd8e9fe

bug 106214
https://gerrit.libreoffice.org/#/c/35730