Download it now!
Bug 63752 - Cannot "Save As" to Samba Share
Summary: Cannot "Save As" to Samba Share
Status: RESOLVED DUPLICATE of bug 64311
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-20 14:13 UTC by cab_77573
Modified: 2013-05-07 09:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot of the error dialog (12.09 KB, image/png)
2013-04-20 14:13 UTC, cab_77573
Details
screen shot of the 4.0.3.1 error dialog (10.22 KB, image/png)
2013-05-02 01:12 UTC, cab_77573
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cab_77573 2013-04-20 14:13:40 UTC
Created attachment 78271 [details]
screen shot of the error dialog

When attempting to perform "Save As" to a Linux-based Samba share from my Mint LMDE (Update Pack 6) Dell D620 laptop, the attempt fails with the following error:
"Error saving the document <my doc name> Nonexistent object. Path to the file does not exist."
All other applications on this laptop are able to read and write to the Samba server.
LibreOffice is able to navigate the directory tree on the Samba server but does not successfully read or write documents on the Samba server.
 
Operating System: Linux (Other)
Version: 4.0.2.2 release
Last worked in: (See in Summary)
Comment 1 Joel Madero 2013-04-20 18:46:39 UTC
haven't confirmed yet but upping to critical, if it's confirmed this is a very problematic regression.

What is the other system you are saving to ? Linux Mint saving to Windows...?
Comment 2 Joel Madero 2013-04-20 18:57:29 UTC
So I just did a test on my samba setup.

My setup:

Windows 7 with LibreOffice 4.0.2.2 release
Bodhi Linux with samba share full rights given to any other system on my network


Opened writer on Windows 7, saved to samba share on Bodhi Linux machine, no problems at all.


Can you also try resetting your profile - https://wiki.documentfoundation.org/UserProfile

Is this essentially exactly what you're doing or are you saving FROM Linux TO Windows? Or Linux - Linux (in which case, I highly recommend leaving Samba and going with NAS)
Comment 3 cab_77573 2013-04-20 23:32:46 UTC
I have no problem with LibreOffice accessing Samba shares from Windows 7 PC.  The problem seems to be related to the Linux Mint LMDE (Debian Testing) based version of LibreOffice.  Other applications on the Linux Mint laptop have no problem accessing the Samba shares.  Even LibreOffice is capable of traversing the directory trees on the Samba shares.  The problem occurs when trying to actually open or save a document.  Will reset profile and try again.
Comment 4 cab_77573 2013-04-21 00:22:31 UTC
I have a Linux-based Samba Server that is used by both Windows and Linux PCs.  The Windows PCs have no problem accessing the Samba shares via LO.  It is only a problem with my Debian-based Linux Mint PCs accessing Samba shares via LO.  LO has no problem navigating the Samba shares from the Linux Mint PCs but fails when attempting to actually read or write files.  Note: none of the other (non-LO) applications on the Linux Mint PCs are having this problem -- they can access the Samba shares without problem.
Comment 5 Joel Madero 2013-04-21 04:32:42 UTC
Okay what I can confirm:

4.0.2.2 release is broken

4.1 master is fixed

so I need to test against 4.0 master, if it works you can expect that in 4.0.3 release the problem will be fixed. I am building now so will have to test tomorrow.
Comment 6 Joel Madero 2013-05-01 04:34:59 UTC
indeed seems fixed - when 4.0.3 release is released, please confirm that it's indeed fixed for you.

Thanks for reporting
Comment 7 cab_77573 2013-05-02 01:12:17 UTC
Created attachment 78745 [details]
screen shot of the 4.0.3.1 error dialog

It would seem to still be broken in 4.0.3 RC1.  See the newly attached error dialog. I still cannot "save as" to samba shares.
Comment 8 cab_77573 2013-05-02 11:17:45 UTC
Not sure if this helps but the Samba Server runs on Debian Squeeze AMD64, and the PC Client runs on Linux Mint Debian Edition (LMDE)
Comment 9 Michael Meeks 2013-05-02 16:22:28 UTC
Works also for me; using gvfs/gio to save with a custom build at least.
Comment 10 Michael Meeks 2013-05-02 16:23:44 UTC
Ah ! now I can reproduce this with the downloaded builds - annoying indeed.
Comment 11 Joel Madero 2013-05-02 16:28:35 UTC
Michael - Mark as NEW or is it NOTOURBUG?
Comment 12 Michael Meeks 2013-05-07 08:38:32 UTC
So - re-opening; this clearly needs a fix :-)
Comment 13 Michael Meeks 2013-05-07 09:59:23 UTC
I couldn't reproduce this - except with the official builds which are missing the gnome-vfs piece that enables this ! ;-)

Thanks so much for the report ...

*** This bug has been marked as a duplicate of bug 64311 ***