Bug Hunting Session
Bug 64311 - no SMB . gnome-vfs support
Summary: no SMB . gnome-vfs support
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.3.1 rc
Hardware: Other Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: target:4.1.0 target:4.0.4
Keywords:
: 54275 59514 63752 (view as bug list)
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-05-07 09:52 UTC by Michael Meeks
Modified: 2015-03-07 07:53 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace output (13.57 KB, text/plain)
2013-06-13 14:00 UTC, David
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2013-05-07 09:52:05 UTC
It seems that several duplicates of the "SMB doesn't work" variety appear to come from a missing GNOME-VFS UCP in our vanilla builds. Of course, ideally we'd have a gio/gvfs backend - but apparently we can't easily do that.

In my:

rpm -qlp libobasis4.0-gnome-integration-4.0.3.3-3.i586.rpm 
/opt/libreoffice4.0
/opt/libreoffice4.0/program
/opt/libreoffice4.0/program/gconfbe1.uno.so
/opt/libreoffice4.0/program/gnome-open-url
/opt/libreoffice4.0/program/gnome-open-url.bin
/opt/libreoffice4.0/program/libevoablo.so
/opt/libreoffice4.0/program/libqstart_gtklo.so
/opt/libreoffice4.0/program/libvclplug_gtklo.so

I would expect to see a UCP for gvfs; and I see none - it seems that

commit 7389260dbf73aa88f8db18d04547c72a51f7d0e7
Author: Fridrich Štrba <fridrich.strba@bluewin.ch>
Date:   Tue Jan 8 14:13:05 2013 +0100

    Disable gnome-vfs for now
    
    Change-Id: Id02270bad13ba575e7818c714d4920be604f2c1c

Disabled it on the -4-0 branch.

What is the thinking there ?
Comment 1 Michael Meeks 2013-05-07 09:53:01 UTC
Fridrich - thoughts ? I forget the details here :-)
Comment 2 Michael Meeks 2013-05-07 09:53:46 UTC
*** Bug 54275 has been marked as a duplicate of this bug. ***
Comment 3 Michael Meeks 2013-05-07 09:59:23 UTC
*** Bug 63752 has been marked as a duplicate of this bug. ***
Comment 4 Michael Meeks 2013-05-07 10:12:46 UTC
*** Bug 59514 has been marked as a duplicate of this bug. ***
Comment 5 Michael Meeks 2013-05-09 16:15:14 UTC
The recollection is that this is a deliberate approach: to ensure that GNOME will pass us a FUSE / file-path rather then an smb:// style URI. *but* it seems we have a couple of issues here:

1. our .desktop files tell the system to send us URIs not fils
2. our file-selector code does the same, I guess this guy:

SalGtkFilePicker.cxx:    gtk_file_chooser_set_local_only( GTK_FILE_CHOOSER( m_pDialog ), sal_False );

Is one enemy here :-)
Comment 6 Stephan Bergmann 2013-05-10 15:16:39 UTC
(In reply to comment #5)
> The recollection is that this is a deliberate approach: to ensure that GNOME
> will pass us a FUSE / file-path rather then an smb:// style URI.

"this" being the "Disable gnome-vfs for now" commit mentioned in comment 0?
Comment 7 Michael Meeks 2013-05-10 15:52:19 UTC
> "this" being the "Disable gnome-vfs for now" commit

Sure - that's the proximate cause of the issue for sure. I think the fixes in comment #5 will nail it - but needs to be conditional on having neither gio nor gvfs compiled in I guess :-)
Comment 8 Michael Meeks 2013-05-11 16:39:39 UTC
I've pushed these fixes to master; we should use file URLs now instead. Thanks for the reports.

Fridrich - can you cherry-pick to -4-0 ? Testing much appreciated of the -4-0 tinderbox snapshots as/when its picked - it's possible we missed some URL handling somewhere :-)
Comment 9 Commit Notification 2013-05-11 16:47:21 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=363b82fdb4016bc42877fea2ebde9227b27579fe

fdo#64311 - .desktop files: use %U for URLs only if we have gvfs or gio.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-05-11 16:47:40 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8659ca5c350b9b08fb5f343c68955cdd6d361c96

fdo#64311 - don't encourage the fpicker to give us URLs we can't handle.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2013-05-11 17:00:23 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fbc486a449808d1d9261f67ffaa4f0213e80787e

fdo#64311 - fix pre-processor conditionals & don't bail-out without gnome-vfs.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Michael Meeks 2013-05-11 20:02:21 UTC
With the third fix I pushed I think we can re-enable gnome-vfs for the -4-0 branch which will provide the real fix.

I noticed we were aborting startup [!] if the gnome-vfs ucp was not installed - which seems ultra-lame from a packaging perspective, and perhaps underlies Bjoern's problems in this area around dependencies; there is no need for that workaround to succeed if we have no gnome-vfs :-)

I'd love to have that in -4-0 and to re-enable gnome-vfs there;
Comment 13 Commit Notification 2013-05-11 20:04:20 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8627bf17d565e085bb204b91dfe596c4a0430d1d

fdo#64311 - fix namespace issue / compile failure.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2013-05-13 08:34:54 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=71f77792ed000e30a5cb090b0a21b8d1c577c23f&h=libreoffice-4-0

fdo#64311 - .desktop files: use %U for URLs only if we have gvfs or gio.


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2013-05-13 08:35:12 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bfdab9aeb1290f970d11c3704cbb11992c0d6304&h=libreoffice-4-0

fdo#64311 - don't encourage the fpicker to give us URLs we can't handle.


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2013-05-13 08:42:56 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0179aca82573724072b19fc1e8e669f133105dd4&h=libreoffice-4-0

fdo#64311 - fix pre-processor conditionals & don't bail-out without gnome-vfs.


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2013-05-13 08:55:42 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9bd1022011bd9a46715134151ddde303d68e04c2&h=libreoffice-4-0

fdo#64311 - re-enable gnome-vfs for linux.


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 David 2013-06-12 16:34:43 UTC
User testing report: my context = Lubuntu 12.10, to a Windows network drive. 

Using LibO Version: 4.1.0.0.beta2 [Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6] - installed beside 4.0.3.3 according to these instructions:
https://wiki.documentfoundation.org/Installing_in_parallel

Attempted to save test odt to share drive, and got the familiar red error popup:

"Error saving the document Untitled1:
Nonexistent object.
Path to the file does not exist."

From terminal (ran application from command line), note this warning that could be relevant:

"WARNING: gnome-keyring:: couldn't connect to: /run/user/reimer/keyring-viGdJN/pkcs11: No such file or directory"

Had hoped this would work seamlessly. :( Not fixed for me. Sadly (if you see what I mean), AbiWord has no problem at all saving a file to that location.
Comment 19 Michael Meeks 2013-06-12 19:44:37 UTC
> Had hoped this would work seamlessly. :(

Me too :-)

> Not fixed for me. Sadly (if you see what I mean), AbiWord has
> no problem at all saving a file to that location.

Do you have a file libucpvfs1.so or somesuch in your install's program/ directory ? (what does ls *vfs* in there say ?).

Do you have gnome-vfs installed ?

Thanks.
Comment 20 Joel Madero 2013-06-13 03:05:19 UTC
Just tested myself with beta2, worked like a charm.

I do have libgnomevfs installed


Bodhi Linux (built on Ubuntu 12.04)
Comment 21 David 2013-06-13 07:42:35 UTC
@Michael_Meeks (comment #19):

> Do you have a file libucpvfs1.so or somesuch in your install's program/
> directory ? (what does ls *vfs* in there say ?).

It says:

  -rwxr-xr-x 1 reimer reimer 255628 Jun  5 22:35 libucpgvfs1lo.so

> Do you have gnome-vfs installed ?

I have libgnomevfs2-0 installed (v. 1:2.24.4-1ubuntu3).

Any ideas? I would dearly love to have this working (as, I'm sure, you would too!)

And thanks for the help. :)
Comment 22 David 2013-06-13 07:47:49 UTC
P.S. (to comment #21): I just tried again, in case a new day, fresh boot, would bring new hope. Still the "Error saving..." message, but I also got this in my terminal:

    (soffice:2715): Gtk-WARNING **: Operation not supported by backend

But I did *not* get yesterday's gnome-keyring warning. FWIW.
Comment 23 Michael Meeks 2013-06-13 08:12:30 UTC
Presumably there is some 12.04 -> 12.10 change in Ubuntu that horks this.

chasing this down should be easy:

    (soffice:2715): Gtk-WARNING **: Operation not supported by backend

Ensure you have gtk+ debuginfo / symbols installed and do:

gdb ./soffice.bin
break g_logv
run
... do your operation ...
backtrace

and paste the output here - that should show us what operation gtk+ thinks is not supported / missing :-)

Thanks.
Comment 24 David 2013-06-13 08:33:47 UTC
Feedback for comment #23 - Bascially, LibO wouldn't run : The Office welcome window came up, but when I tried to create a "Text Document", I got the "frame" of the chrome (?) but the window didn't "fill" - it just froze. Here's the output:

[code]
> gdb ./soffice.bin
GNU gdb (GDB) 7.5-ubuntu
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/soffice.bin...(no debugging symbols found)...done.
(gdb) break g_logv
Function "g_logv" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y

Breakpoint 1 (g_logv) pending.
(gdb) run
Starting program: /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/soffice.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[New Thread 0xb3c61b40 (LWP 4604)]
[New Thread 0xb2193b40 (LWP 4605)]
[New Thread 0xb17ffb40 (LWP 4606)]
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
[Thread 0xb2193b40 (LWP 4605) exited]
[New Thread 0xb2193b40 (LWP 4607)]
warning: File "/home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libpython3.3m.so-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
[New Thread 0xaebc2b40 (LWP 4608)]
[Thread 0xaebc2b40 (LWP 4608) exited]
[New Thread 0xaebc2b40 (LWP 4609)]
[Thread 0xaebc2b40 (LWP 4609) exited]
[New Thread 0xaebc2b40 (LWP 4610)]
[Thread 0xaebc2b40 (LWP 4610) exited]
[New Thread 0xaebc2b40 (LWP 4611)]
[New Thread 0xae1ffb40 (LWP 4612)]
[New Thread 0xad8bfb40 (LWP 4615)]
WARNING: gnome-keyring:: couldn't connect to: /run/user/reimer/keyring-2wER2c/pkcs11: No such file or directory
[Thread 0xad8bfb40 (LWP 4615) exited]
[Thread 0xaebc2b40 (LWP 4611) exited]
[New Thread 0xaebc2b40 (LWP 4616)]
[Thread 0xaebc2b40 (LWP 4616) exited]
[New Thread 0xaebc2b40 (LWP 4617)]
[New Thread 0xad8bfb40 (LWP 4618)]

Breakpoint 1, 0xb5b711b0 in g_logv () from /lib/i386-linux-gnu/libglib-2.0.so.0
(gdb) backtrace
#0  0xb5b711b0 in g_logv () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb5b71583 in g_log () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb29266e3 in theme_pixbuf_compute_hints (
    theme_pb=<error reading variable: Cannot access memory at address 0xbfffd1e8>, 
    theme_pb@entry=<error reading variable: Cannot access memory at address 0xbfffd22c>)
    at /build/buildd/gtk+2.0-2.24.13/modules/engines/pixbuf/pixbuf-render.c:624
(gdb) 
[/code]

Hope this helps.....
Comment 25 Michael Meeks 2013-06-13 08:39:01 UTC
Can you install the glib debuginfo package as well.
Also - you need to do:

'continue'

(or just 'c') after hitting a g_logv breakpoint.

Clearly this was for some other random console warning - wow gtk+ is dirty / noisy on your system - this looks like some unrelated theme issue.
Comment 26 David 2013-06-13 08:53:37 UTC
Having added glib dbg info (can you tell you're dealing with a rank amateur here? Hopefully having a numpty user is helpful for debugging, though - thanks for your patience):

[code]
> gdb ./soffice.bin
GNU gdb (GDB) 7.5-ubuntu
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/soffice.bin...(no debugging symbols found)...done.
(gdb) break g_logv
Function "g_logv" not defined.
Make breakpoint pending on future shared library load? (y or [n]) c

Please answer y or [n].
Make breakpoint pending on future shared library load? (y or [n]) y

Breakpoint 1 (g_logv) pending.
(gdb) run
Starting program: /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/soffice.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[New Thread 0xb3c61b40 (LWP 5937)]
[New Thread 0xb2193b40 (LWP 5938)]
[New Thread 0xb17ffb40 (LWP 5939)]
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
[Thread 0xb2193b40 (LWP 5938) exited]
[New Thread 0xb2193b40 (LWP 5940)]
[New Thread 0xafab9b40 (LWP 5941)]
[New Thread 0xaef83b40 (LWP 5942)]
[Thread 0xaef83b40 (LWP 5942) exited]
warning: File "/home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libpython3.3m.so-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
[New Thread 0xaef83b40 (LWP 5943)]
[Thread 0xaef83b40 (LWP 5943) exited]
[New Thread 0xaef83b40 (LWP 5944)]
[Thread 0xaef83b40 (LWP 5944) exited]
[New Thread 0xaef83b40 (LWP 5945)]
[Thread 0xaef83b40 (LWP 5945) exited]
[New Thread 0xaef83b40 (LWP 5946)]
[New Thread 0xadf1fb40 (LWP 5947)]
[New Thread 0xad65ab40 (LWP 5950)]
WARNING: gnome-keyring:: couldn't connect to: /run/user/reimer/keyring-2wER2c/pkcs11: No such file or directory
[Thread 0xad65ab40 (LWP 5950) exited]
[Thread 0xaef83b40 (LWP 5946) exited]
[New Thread 0xaef83b40 (LWP 5951)]

Breakpoint 1, g_logv (log_domain=log_domain@entry=0x0, 
    log_level=log_level@entry=G_LOG_LEVEL_WARNING, 
    format=format@entry=0xb292861c "Invalid borders specified for theme pixmap:\n        %s,\nborders don't fit within the image", 
    args=args@entry=0xbfffd1bc "\260J\t\b\220\375\214\b\005")
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
853	/build/buildd/glib2.0-2.34.1/./glib/gmessages.c: No such file or directory.
(gdb) c
Continuing.
g_logv (
    log_domain=<error reading variable: Cannot access memory at address 0xbfffd190>, 
    log_domain@entry=<error reading variable: Cannot access memory at address 0xbfffd1b0>, 
    log_level=<error reading variable: Cannot access memory at address 0xbfffd194>, 
    log_level@entry=<error reading variable: Cannot access memory at address 0xbfffd1b4>, 
    format=<error reading variable: Cannot access memory at address 0xbfffd198>, 
    format@entry=<error reading variable: Cannot access memory at address 0xbfffd1b8>, ) at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
853	in /build/buildd/glib2.0-2.34.1/./glib/gmessages.c
Couldn't get registers: No such process.
(gdb) backtrace
#0  g_logv (
    log_domain=<error reading variable: Cannot access memory at address 0xbfffd190>, 
    log_domain@entry=<error reading variable: Cannot access memory at address 0xbfffd1b0>, 
    log_level=<error reading variable: Cannot access memory at address 0xbfffd194>, 
    log_level@entry=<error reading variable: Cannot access memory at address 0xbfffd1b4>, 
    format=<error reading variable: Cannot access memory at address 0xbfffd198>, 
    format@entry=<error reading variable: Cannot access memory at address 0xbfffd1b8>, ) at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
#1  0xb5b71583 in g_log (
    log_domain=<error reading variable: Cannot access memory at address 0xbfffd1b0>, 
    log_domain@entry=<error reading variable: Cannot access memory at address 0xbfffd1ac>, 
    log_level=<error reading variable: Cannot access memory at address 0xbfffd1b4>, 
    format=<error reading variable: Cannot access memory at address 0xbfffd1b8>)
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:1003
(gdb) 
[/code]
Comment 27 Michael Meeks 2013-06-13 11:17:39 UTC
Sure - so you still fell at the first post ;-)
please do:

gdb ./soffice.bin
b g_logv
r
bt
c
bt
c
bt
c
bt
c
bt
c
...

And attach the output here if you can :-) the 'c' continues after the first irrelevant breakpoint. Continue the 'c' 'bt' pairs until we get the message that you think was related :-)

And hey - we're all gdb neophytes to start with :-)

Thanks !
Comment 28 David 2013-06-13 13:12:19 UTC
I hope we're getting somewhere! Here's a prose account of what is happening: after I hit "r[un], I get the "welcome" LibO screen. I either click the "Writer" icon thing, or from the toolbar do File > New > Text Document. At that point, the toolbar for Writer is built, but *that's all*. The application is now totally frozen, in this state: http://i.imgur.com/VcIbpzx.png 

If I then try to move it, or do anything else, the new "screens" will simply overwrite that "frame", except for the titlebar. I can do nothing more.

This time, I did the "bt" at this point, and did your "c" thing, etc. Then I killed LibO, and did bt ... c ... once more for good measure. And this is dump I'm now appending. As I say, I hope we're making progress. If I've got it wrong again ... well, hopefully you'll be able to get me the next step!

Ouput follows:


> gdb ./soffice.bin
GNU gdb (GDB) 7.5-ubuntu
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/soffice.bin...(no debugging symbols found)...done.
(gdb) b g_logv
Function "g_logv" not defined.
Make breakpoint pending on future shared library load? (y or [n]) y

Breakpoint 1 (g_logv) pending.
(gdb) r
Starting program: /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/soffice.bin 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[New Thread 0xb3c61b40 (LWP 7449)]
[New Thread 0xb2193b40 (LWP 7450)]
[New Thread 0xb17ffb40 (LWP 7451)]
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
[Thread 0xb2193b40 (LWP 7450) exited]
[New Thread 0xb2193b40 (LWP 7452)]
[New Thread 0xafab9b40 (LWP 7453)]
[New Thread 0xaef83b40 (LWP 7454)]
[New Thread 0xae782b40 (LWP 7457)]
WARNING: gnome-keyring:: couldn't connect to: /run/user/reimer/keyring-2wER2c/pkcs11: No such file or directory
[Thread 0xae782b40 (LWP 7457) exited]
warning: File "/home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libpython3.3m.so-gdb.py" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
[Thread 0xaef83b40 (LWP 7454) exited]
[New Thread 0xaef83b40 (LWP 7458)]
[Thread 0xaef83b40 (LWP 7458) exited]
[New Thread 0xaef83b40 (LWP 7459)]
[Thread 0xaef83b40 (LWP 7459) exited]
[New Thread 0xaef83b40 (LWP 7460)]
[Thread 0xaef83b40 (LWP 7460) exited]
[New Thread 0xaef83b40 (LWP 7461)]
[New Thread 0xae782b40 (LWP 7462)]
[Thread 0xaef83b40 (LWP 7461) exited]
[New Thread 0xaef83b40 (LWP 7463)]

Breakpoint 1, g_logv (log_domain=log_domain@entry=0x0, 
    log_level=log_level@entry=G_LOG_LEVEL_WARNING, 
    format=format@entry=0xb292861c "Invalid borders specified for theme pixmap:\n        %s,\nborders don't fit within the image", 
    args=args@entry=0xbfffd1bc "\260J\t\b\220\377\214\b\001")
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
853	/build/buildd/glib2.0-2.34.1/./glib/gmessages.c: No such file or directory.
(gdb) bt
#0  g_logv (log_domain=log_domain@entry=0x0, 
    log_level=log_level@entry=G_LOG_LEVEL_WARNING, 
    format=format@entry=0xb292861c "Invalid borders specified for theme pixmap:\n        %s,\nborders don't fit within the image", 
    args=args@entry=0xbfffd1bc "\260J\t\b\220\377\214\b\001")
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
#1  0xb5b71583 in g_log (log_domain=log_domain@entry=0x0, 
    log_level=log_level@entry=G_LOG_LEVEL_WARNING, 
    format=format@entry=0xb292861c "Invalid borders specified for theme pixmap:\n        %s,\nborders don't fit within the image")
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:1003
#2  0xb29266e3 in theme_pixbuf_compute_hints (
    theme_pb=theme_pb@entry=0x8094a20)
    at /build/buildd/gtk+2.0-2.24.13/modules/engines/pixbuf/pixbuf-render.c:624
#3  0xb2926b19 in theme_pixbuf_get_pixbuf (theme_pb=theme_pb@entry=0x8094a20)
    at /build/buildd/gtk+2.0-2.24.13/modules/engines/pixbuf/pixbuf-render.c:742
#4  0xb2926ba1 in theme_pixbuf_render (theme_pb=0x8094a20, 
    window=window@entry=0x87bf280, mask=mask@entry=0x0, 
    clip_rect=clip_rect@entry=0x0, component_mask=component_mask@entry=512, 
    center=center@entry=0, x=x@entry=0, y=y@entry=0, width=10, height=810)
    at /build/buildd/gtk+2.0-2.24.13/modules/engines/pixbuf/pixbuf-render.c:760
#5  0xb2923061 in draw_simple_image (style=style@entry=0x808d060, 
    window=window@entry=0x87bf280, area=area@entry=0x0, 
---Type <return> to continue, or q <return> to quit---
    widget=widget@entry=0x86c3140, match_data=match_data@entry=0xbfffd374, 
    draw_center=draw_center@entry=1, x=x@entry=0, y=y@entry=0, 
    width=width@entry=10, height=height@entry=810, allow_setbg=1)
    at /build/buildd/gtk+2.0-2.24.13/modules/engines/pixbuf/pixbuf-draw.c:145
#6  0xb292432f in draw_box (style=0x808d060, window=0x87bf280, 
    state=GTK_STATE_ACTIVE, shadow=GTK_SHADOW_IN, area=0x0, widget=0x86c3140, 
    detail=<optimised out>, x=0, y=0, width=10, height=810)
    at /build/buildd/gtk+2.0-2.24.13/modules/engines/pixbuf/pixbuf-draw.c:668
#7  0xb2ec522c in IA__gtk_paint_box (style=0x808d060, window=0x87bf280, 
    state_type=GTK_STATE_ACTIVE, shadow_type=GTK_SHADOW_IN, area=0x0, 
    widget=0x86c3140, detail=0xb31d48ee "trough", x=0, y=0, width=10, 
    height=810) at /build/buildd/gtk+2.0-2.24.13/gtk/gtkstyle.c:6207
#8  0xb31acc7f in GtkSalGraphics::NWPaintGTKScrollbar(unsigned long, unsigned long, Rectangle const&, std::list<Rectangle, std::allocator<Rectangle> > const&, unsigned long, ImplControlValue const&, rtl::OUString const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvclplug_gtklo.so
#9  0xb31b12a4 in GtkSalGraphics::drawNativeControl(unsigned long, unsigned long, Rectangle const&, unsigned long, ImplControlValue const&, rtl::OUString const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvclplug_gtklo.so
#10 0xb693521d in SalGraphics::DrawNativeControl(unsigned long, unsigned long, R---Type <return> to continue, or q <return> to quit---
ectangle const&, unsigned long, ImplControlValue const&, rtl::OUString const&, OutputDevice const*) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#11 0xb68a3e91 in OutputDevice::DrawNativeControl(unsigned long, unsigned long, Rectangle const&, unsigned long, ImplControlValue const&, rtl::OUString) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#12 0xb67823c1 in ScrollBar::ImplDrawNative(unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#13 0xb678399e in ScrollBar::ImplDraw(unsigned short, OutputDevice*) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#14 0xb6783a12 in ScrollBar::Paint(Rectangle const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#15 0xb69ecb40 in Window::ImplCallPaint(Region const*, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#16 0xb69ecc13 in Window::ImplCallPaint(Region const*, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
---Type <return> to continue, or q <return> to quit---
#17 0xb69ecc13 in Window::ImplCallPaint(Region const*, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#18 0xb69ecc13 in Window::ImplCallPaint(Region const*, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#19 0xb69ecc13 in Window::ImplCallPaint(Region const*, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#20 0xb69ecc13 in Window::ImplCallPaint(Region const*, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#21 0xb69ece64 in Window::Update() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#22 0xacf1521e in SwView::SetVisArea(Rectangle const&, unsigned char) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libswlo.so
#23 0xacf1358e in SwView::CalcVisArea(Size const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libswlo.so
#24 0xacf15704 in SwView::OuterResizePixel(Point const&, Size const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86---Type <return> to continue, or q <return> to quit---
_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libswlo.so
#25 0xb7857b51 in SfxViewFrame::DoAdjustPosSizePixel(SfxViewShell*, Point const&, Size const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#26 0xb7858cef in SfxViewFrame::Resize(unsigned char) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#27 0xb785b212 in SfxFrameViewWindow_Impl::Resize() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#28 0xb69e822d in Window::ImplCallResize() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#29 0xb69e88de in Window::ImplPosSizeWindow(long, long, long, long, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#30 0xb69eaab4 in Window::setPosSizePixel(long, long, long, long, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#31 0xb69da1a9 in Window::SetPosSizePixel(Point const&, Size const&) ()
---Type <return> to continue, or q <return> to quit---
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#32 0xb7839817 in SfxFrame::SetToolSpaceBorderPixel_Impl(SvBorder const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#33 0xb768280c in SfxFrameWorkWin_Impl::ArrangeChildren_Impl(unsigned char) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#34 0xb783bd0e in SfxFrame::Resize() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#35 0xb783cbf3 in SfxFrameWindow_Impl::DoResize() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#36 0xb783cc3e in SfxFrameWindow_Impl::Resize() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#37 0xb69e822d in Window::ImplCallResize() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#38 0xb69e88de in Window::ImplPosSizeWindow(long, long, long, long, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86---Type <return> to continue, or q <return> to quit---
_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#39 0xb69e8827 in Window::ImplPosSizeWindow(long, long, long, long, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#40 0xb69eaab4 in Window::setPosSizePixel(long, long, long, long, unsigned short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#41 0xb6f3bedb in VCLXWindow::setPosSize(long, long, long, long, short) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libtklo.so
#42 0xb0795bb0 in framework::DockingAreaDefaultAcceptor::setDockingAreaSpace(com::sun::star::awt::Rectangle const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#43 0xb07bc04c in framework::LayoutManager::implts_doLayout(unsigned char, unsigned char) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#44 0xb07bc2a8 in framework::LayoutManager::implts_doLayout_notify(unsigned char) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86---Type <return> to continue, or q <return> to quit---
_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#45 0xb07bc3de in framework::LayoutManager::unlock() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#46 0xb7869ab7 in SfxDispatcher::Update_Impl(unsigned char) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#47 0xb7848699 in SfxBaseController::ConnectSfxFrame_Impl(SfxBaseController::ConnectSfxFrame) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#48 0xb784a77e in SfxBaseController::attachFrame(com::sun::star::uno::Reference<com::sun::star::frame::XFrame> const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#49 0xb783e466 in SfxFrameLoader_Impl::impl_createDocumentView(com::sun::star::uno::Reference<com::sun::star::frame::XModel2> const&, com::sun::star::uno::Reference<com::sun::star::frame::XFrame> const&, comphelper::NamedValueCollection const&, rtl::OUString const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#50 0xb78409dd in SfxFrameLoader_Impl::load(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, com::sun::star::uno::Reference<com::sun:---Type <return> to continue, or q <return> to quit---
:star::frame::XFrame> const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsfxlo.so
#51 0xb07df9bf in framework::LoadEnv::impl_loadContent() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#52 0xb07e060d in framework::LoadEnv::startLoading() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#53 0xb0791322 in framework::LoadDispatcher::impl_dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, com::sun::star::uno::Reference<com::sun::star::frame::XDispatchResultListener> const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#54 0xb0791af1 in framework::LoadDispatcher::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwklo.so
#55 0xad273c92 in framework::NewMenuController::ExecuteHdl_Impl(framework::NewMenuController*, framework::NewDocument*) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86---Type <return> to continue, or q <return> to quit---
_deb/DEBS/install/opt/libreofficedev4.1/program/../program/libfwllo.so
#56 0xb7f4133d in Link::Call(void*) const ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsofficeapp.so
#57 0xb69f9e58 in ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#58 0xb6a0210f in SalFrame::CallCallback(unsigned short, void const*) const ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#59 0xb6a01fc4 in SalGenericDisplay::DispatchInternalEvent() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#60 0xb31a0cc8 in GtkData::userEventFn(void*) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvclplug_gtklo.so
#61 0xb31a0d1f in call_userEventFn ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvclplug_gtklo.so
#62 0xb5b66c30 in g_idle_dispatch (source=source@entry=0x88ee9c8, 
    callback=0xb31a0cfa <call_userEventFn>, user_data=0x8053780)
    at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:4806
---Type <return> to continue, or q <return> to quit---
#63 0xb5b699e3 in g_main_dispatch (context=0x807b3f8)
    at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:2715
#64 g_main_context_dispatch (context=context@entry=0x807b3f8)
    at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3219
#65 0xb5b69d80 in g_main_context_iterate (context=context@entry=0x807b3f8, 
    block=block@entry=0, dispatch=dispatch@entry=1, self=<optimised out>)
    at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3290
#66 0xb5b69e61 in g_main_context_iteration (context=0x807b3f8, may_block=0)
    at /build/buildd/glib2.0-2.34.1/./glib/gmain.c:3351
#67 0xb31a110b in GtkData::Yield(bool, bool) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvclplug_gtklo.so
#68 0xb31a3155 in GtkInstance::Yield(bool, bool) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvclplug_gtklo.so
#69 0xb672d4e6 in ImplYield(bool, bool) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#70 0xb672aa66 in Application::Yield(bool) ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#71 0xb672c371 in Application::Execute() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86---Type <return> to continue, or q <return> to quit---
_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#72 0xb7f4105f in desktop::Desktop::Main() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsofficeapp.so
#73 0xb6732481 in ImplSVMain() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#74 0xb6732536 in SVMain() ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libvcllo.so
#75 0xb7f64a2a in soffice_main ()
   from /home/reimer/Downloads/LibO41Beta/LibreOfficeDev_4.1.0.0.beta2_Linux_x86_deb/DEBS/install/opt/libreofficedev4.1/program/libsofficeapp.so
#76 0x08048681 in main ()
(gdb) c
Continuing.

** (soffice:7445): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Lubuntu-default/gtk-2.0/images/null.png,
borders don't fit within the image

Breakpoint 1, g_logv (log_domain=log_domain@entry=0x0, 
    log_level=log_level@entry=G_LOG_LEVEL_WARNING, 
    format=format@entry=0xb292861c "Invalid borders specified for theme pixmap:\n        %s,\nborders don't fit within the image", 
    args=args@entry=0xbfffd1bc "\bN\t\b(\001\215\b\005")
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
853	in /build/buildd/glib2.0-2.34.1/./glib/gmessages.c
(gdb) bt
#0  g_logv (log_domain=0x0, 
    log_domain@entry=<error reading variable: Cannot access memory at address 0xbfffd1b0>, log_level=G_LOG_LEVEL_WARNING, 
    log_level@entry=<error reading variable: Cannot access memory at address 0xbfffd1b4>, format=0xb292861c <Address 0xb292861c out of bounds>, 
    format@entry=<error reading variable: Cannot access memory at address 0xbfffd1b8>, args=args@entry=0xbfffd1bc <Address 0xbfffd1bc out of bounds>)
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
#1  0xb5b71583 in g_log (log_domain=log_domain@entry=0x0, 
    log_level=log_level@entry=G_LOG_LEVEL_WARNING, 
    format=format@entry=0xb292861c <Address 0xb292861c out of bounds>)
    at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:1003
#2  0xb29266e3 in theme_pixbuf_compute_hints (
    theme_pb=<error reading variable: Cannot access memory at address 0xbfffd1e8>, 
    theme_pb@entry=<error reading variable: Cannot access memory at address 0xbfffd22c>)
    at /build/buildd/gtk+2.0-2.24.13/modules/engines/pixbuf/pixbuf-render.c:624
(gdb) c
Continuing.
g_logv (
    log_domain=<error reading variable: Cannot access memory at address 0xbfffd190>, 
    log_domain@entry=<error reading variable: Cannot access memory at address 0xbfffd1b0>, 
    log_level=<error reading variable: Cannot access memory at address 0xbfffd194>, 
    log_level@entry=<error reading variable: Cannot access memory at address 0xbfffd1b4>, 
    format=<error reading variable: Cannot access memory at address 0xbfffd198>, 
    format@entry=<error reading variable: Cannot access memory at address 0xbfffd1b8>, ) at /build/buildd/glib2.0-2.34.1/./glib/gmessages.c:853
853	in /build/buildd/glib2.0-2.34.1/./glib/gmessages.c
Couldn't get registers: No such process.
(gdb) quit
A debugging session is active.

	Inferior 1 [process 7445] will be killed.

Quit anyway? (y or n) y
Quitting: Couldn't get registers: No such process.
>
Comment 29 Michael Meeks 2013-06-13 13:38:10 UTC
> I hope we're getting somewhere! Here's a prose account of what is happening: 
> after I hit "r[un], I get the "welcome" LibO screen. I either click the 
> "Writer" icon thing, or from the toolbar do File > New > Text Document. At 
> that point, the toolbar for Writer is built, but *that's all*. The 
> application is now totally frozen

Of course it is - it's trapped into the debugger - which has stopped the app :-) until you type 'continue' in gdb - nothing will be re-rendered; that is completely normal and expected.

> If I then try to move it, or do anything else, the new "screens" will simply 
> overwrite that "frame", except for the titlebar. I can do nothing more.

Type 'continue' in gdb, and see what happens ;-> We need a stack-trace of the message that happens whe you use gvfs; not this random dirt at startup.

So - you need to type 'c' by which I mean: c<enter> in gdb, and repeat the c / bt loop until you get to the exception which you mentioned.

Please can you add your traces as file attachments rather than these huge pastes.

Thanks.
Comment 30 David 2013-06-13 14:00:29 UTC
Created attachment 80777 [details]
backtrace output
Comment 31 David 2013-06-13 14:02:32 UTC
Sorry - I should have known better (re: pastes!). 

So, this time: now I get the bt/c thing. ;) I got my new document created, typed in a bit of text, and tried to save to the Windows share drive. I could navigate to it just fine, typed in a filename at the prompt, clicked "save" -- and then the thing hung. (Spinner, spinning....) Unfortunately, though I had a (gdb) prompt in the terminal, it was the "empty rectangle" cursor, and it would not accept input. I waited ... then killed it.

The attachment in comment #30 is (I think, I hope), the last two backtraces before killing it.

It seems we're at the crucial point: felt very stymied that I couldn't get past that hang. Hope the dump has something useful.
Comment 32 Michael Meeks 2013-06-13 15:15:35 UTC
Assuming this is the warning is the one mentioned:

static void
gtk_folder_constructed (GObject *object)
{
  GtkFolderPrivate *priv;
  GError *error = NULL;

  priv = GTK_FOLDER_GET_PRIVATE (object);
  priv->directory_monitor = g_file_monitor_directory (priv->folder_file, G_FILE_MONITOR_NONE, NULL, &error);

  if (error)
    {
      g_warning ("%s", error->message);

it is benign - it just means we can't monitor the directory, so we don't ǒnnect to "changed" for it, which is fine, we continue with the file enumeration.

So - no idea. Thanks for the help David - sorry it didn't result in a solution.

I assume the distro provided / PPA packages work out for you :-)
Comment 33 David 2013-06-13 18:56:32 UTC
In comment #32 Michael Meeks wrote:

> So - no idea. Thanks for the help David - sorry it didn't result in a solution.

Hey ho! Thanks for persevering and for your help in teaching me a bit about gdb. :)

The slightly frustrating thing from my end is that at home, on an ancient laptop running Linux Mint 13, I can use a VPN and LibO 4.0.3.3 and this works to that same Windows network drive no problem. It seems, then, that this is more to do with something in Lubuntu (which I'm running at work) ... or something I'm doing that's squiffy.

Strange, still, that AbiWord, Inkscape ... well, *every* other app works just fine in that environment, except LibO, which I need far more than those others.

Like you say, will hope that the issue is dealt with at some other point in the scenario.
Comment 34 Michael Meeks 2013-06-13 20:17:22 UTC
David - AbiWord / Inkscape etc. are using a different toolkit version, and almost certainly gio not gvfs - and you are getting them not from a random download from a long-suffering ISV (Linux is a -total- rats nest of a platform to build for), but from your Distro vendor. If you get LibreOffice from the PPA / your distro vendor - you should not have this problem.

HTH.
Comment 35 Norbert X 2015-03-07 07:52:50 UTC
Dear Michael Meeks!
I have some problems with Samba-shared folder ( see https://bugs.documentfoundation.org/show_bug.cgi?id=89632 ).

The SMB/CIFS server is Ubuntu 12.04.5, shared folder is created with nautilus-share.
I can connect to this share with full read-write access from my local network.
I placed OpenDocument file ('test.odt') on it.
If I connect to this share from client computer (GNU/Linux or Windows) I get error 'Document in Use' message from LibreOffice. 

I tested several versions of LibO with various access methods.
In GNU/Linux I used:
1. 'libreoffice smb://server/public/test.odt'
2. Nautilus or Caja, set path to 'smb://server/public', click on 'test.odt' file
3. Navigate in terminal to '~/.gvfs/public on server/', launch 'libreoffice test.odt'
4. Mount share with 'mount.cifs'

In Windows I used:
1. Windows File Explorer, '\\server\public', click on 'test.odt'
2. 'net use \\server\public S:', open S: disk in Explorer, click on 'test.odt'

My results are summarized in Google Docs table ( http://goo.gl/jY9Ubj ).


If SMB/CIFS server is Windows I get no errors or warnings.

Could you please consult me about how to debug this Samba-LibO communication?