Bug Hunting Session
Bug 63763 - keyboard shortcuts for cut and paste (ctrl+c, ...) are broken in not English layout
Summary: keyboard shortcuts for cut and paste (ctrl+c, ...) are broken in not English ...
Status: RESOLVED DUPLICATE of bug 41169
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-21 05:48 UTC by Peter
Modified: 2013-08-12 17:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
emerge --info libreoffice output (6.21 KB, text/plain)
2013-04-21 05:48 UTC, Peter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2013-04-21 05:48:44 UTC
Created attachment 78286 [details]
emerge --info libreoffice output

After I change layout from English to Russian Cut and Paste shortcuts (Ctrl+C and Ctrl+V, Ctrl+S) are not working in libreoffice writer. At the same time acceleration combinations, like Alt+Ф and etc are working fine.

I've reproduced this in Gentoo, but same issue afects people in ubuntu:
http://en.libreofficeforum.org/node/1586
http://ubuntuforums.org/showthread.php?t=1986133

This is libreoffice in gnome 3.4 environment without any specific customisations.
Comment 1 m.a.riosv 2013-07-13 15:31:44 UTC
Hi Peter,
Have you seen in Menu/Tools/Customize/Keyboard what are the assigned shortcuts?.

Have you tried resetting the user profile?, sometimes solve strange issues.
https://wiki.documentfoundation.org/UserProfile
Comment 2 Peter 2013-07-23 09:02:41 UTC
Yes, I've tried to reset profile (closed all OO instanses and moved .config/libreoffice/4 directory to the temp directory) and this did not helped.

Also I've looked and assigned shortcuts. As I see Ctrl+C is assigned there and it works in English layout. After I switch to Russian layout keyboard shortcuts do not work.
Comment 3 Sina Momken 2013-08-12 16:58:23 UTC
I have the same problem. When my keyboard layout is in a non-English language (in my case Fa) most shortcuts don't work (e.g. Ctrl+C, Ctrl+S, customized LO‌ shortcuts).

My system: Linux Mint Debian Edition Update Pack 6, XFCE 4.8, LibreOffice 3.5.4.2, both libreoffice-gnome and libreoffice-gtk packages installed.
I've not tried resetting my user profile yet.
Comment 4 Sina Momken 2013-08-12 17:03:58 UTC

*** This bug has been marked as a duplicate of bug 41169 ***