Bug 63767 - CRASH when opening a file
Summary: CRASH when opening a file
Status: RESOLVED DUPLICATE of bug 63680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All Windows (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-21 07:36 UTC by Florian Reisinger
Modified: 2013-04-28 15:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2013-04-21 07:36:37 UTC
For testing I used this file: https://bugs.freedesktop.org/attachment.cgi?id=58474 I tried with some other bug documents, from time to tome a crah, but most reproducable with this file.....

1) Try to open with master
2) crash (after a second)
Comment 1 Florian Reisinger 2013-04-21 10:19:32 UTC
Also crashes with Version: 4.1.0.0.alpha0+
Build ID: fa72fc3eddbfabb82193452a4ba993b11d1584d
TinderBox: Win-x86@6, Branch:master, Time: 2013-04-18_23:11:53

https://bugs.freedesktop.org/attachment.cgi?id=68822
Comment 2 Florian Reisinger 2013-04-21 10:27:47 UTC
Okay far better way to crash: Open Writer and press any button you want :)
If recovery has recovered the document one single character lets LibreOffice crash
Comment 3 Florian Reisinger 2013-04-21 10:34:35 UTC
https://bugs.freedesktop.org/attachment.cgi?id=68822 is also a crasher on Ubuntu ( after 10 seconds marking and unmarking text) --> This document contains makros (not activated) --> Confirmed 2 independent systems 

Linux: Self-built Version: 4.1.0.0.alpha0+
Build ID: 75c87c417b6fbb82d956a803f065c9c49d0d62f
Comment 4 Florian Reisinger 2013-04-21 10:35:32 UTC
Linux master does not crash when holding down a key...
Comment 5 Florian Reisinger 2013-04-21 10:43:00 UTC
https://bugs.freedesktop.org/attachment.cgi?id=69600 CRASH on Windows (not on Linux)
Comment 6 Florian Reisinger 2013-04-23 13:44:35 UTC
Valid with Version: 4.1.0.0.alpha0+
Build ID: 6536d0eb4f56e64c9b74b358642e3ee1e39353e
TinderBox: Win-x86@6, Branch:master, Time: 2013-04-23_04:48:50
---
With Version: 4.1.0.0.alpha0+
Build ID: c8da8f48415c058c70698a7b4a6716bd41cfeeb @ Ubuntu 13.04
Crash with 2011.10.20.doc WORKING with OpenOfficew 3.2.0, crash with LibreOffice 3.3.4 OOO330m19 (Build:401)
Comment 7 Urmas 2013-04-24 17:19:07 UTC
In Windows, the master build crashes with every document trying to dereference NULL pointer:

sal3.dll!rtl_uString_assign()
????	
swlo.dll!SwTable::SetTabCols()
swlo.dll!cppu::WeakImplHelper2<com::sun::star::linguistic2::XLinguServiceEventListener,com::sun::star::frame::XTerminateListener>::getImplementationId()
swlo.dll!SwTxtNode::GetMinMaxSize()
swlo.dll!SwTxtNode::GetMinMaxSize()
swlo.dll!SwTxtNode::GetMinMaxSize()
swlo.dll!SwTable::SetTabCols()	
swlo.dll!SwTxtNode::IsAutoCompleteWordDirty()
swlo.dll!SwTxtNode::TransliterateText()
swlo.dll!SwPosFlyFrm::~SwPosFlyFrm()
swlo.dll!SwPosFlyFrm::~SwPosFlyFrm()
swlo.dll!SwPosFlyFrm::~SwPosFlyFrm()
swlo.dll!ViewShell::LayoutIdle()
....
Comment 8 V Stuart Foote 2013-04-26 13:39:41 UTC
@urmus,

(In reply to comment #7)

Would you add additional comment to bug 63680

Thanks!
Comment 9 V Stuart Foote 2013-04-28 14:54:49 UTC
Closing as resolved duplicate of bug 63680 which has been resolved fixed by

Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1fd3167695aaebb050df53acd91f2e1625e8305a

fdo#63680 SwTxtCursor::GetCrsrOfst: don't pass reference to a temporary


@Urmas, would be great if you also can confirm on your build of master.

*** This bug has been marked as a duplicate of bug 63680 ***
Comment 10 V Stuart Foote 2013-04-28 15:04:13 UTC
Sorry, should have included profs to the patch author Arnaud V.