Bug 63770 - UI: German key names in menu 'Tools - Customize' despite US language settings
Summary: UI: German key names in menu 'Tools - Customize' despite US language settings
Status: RESOLVED DUPLICATE of bug 54165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-21 08:30 UTC by A (Andy)
Modified: 2013-04-22 05:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2013-04-21 08:30:12 UTC
Problem Description: 
I had installed the German LO release and had changed all settings in TOOLS -> OPTIONS -> LANGUAGE SETTINGS -> LANGUAGES to US English settings.  But in the CUSTOMIZE dialog box I get still German entries.
 
Steps to Reproduce:
1. Open any LO component (WRITER, IMPRESS, CALC, DRAW, BASE)
2. Go to the menu TOOLS -> CUSTOMIZE
3. Go to the tab KEYBOARD

Current Behavior:
In the section SHORTKEY KEYS and KEYS under FUNCTIONS I have German entries.  
Note: For the second part KEYS: I could find them under the CATEGORIES Format and Navigate.

Expected Behavior:
Everything should be in English without German entries.
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Rainer Bielefeld Retired 2013-04-21 09:20:35 UTC
@A:
I have no item "Functions" available there. May be you have installed an extension? Can you please attach a screenshot?
Comment 2 A (Andy) 2013-04-21 09:27:15 UTC
FUNCTIONS is the title of the bottom half in the tab KEYBOARD.  There you can find the selection fields CATEGORY, FUNCTION and KEYS.
Comment 3 A (Andy) 2013-04-21 09:30:34 UTC
@Rainer: Here is also the corresponding LO help entry:
https://help.libreoffice.org/scalc/CUI_HID_ACCELCONFIG_LISTBOX?Language=en-US&System=WIN&Version=4.0#bm_id3150355
Therefore, I suppose you should also have it?
Comment 4 Rainer Bielefeld Retired 2013-04-21 10:24:20 UTC
Hm, seems to by my misinterpretation. But I still haven't a clue what we are talking about. Of course (?) key names stay in German. I checked entries for Functions-Category "Format" in pane "Function" and found no German item.

I tested with server installation of "LibO  4.0.2.2    -  English UI / Locale  [Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)]"  {tinderbox: @6, pull time  2013-03-26 12:00(?)} on German WIN7 Home Premium (64bit) with newly created own user profile
Comment 5 A (Andy) 2013-04-21 19:14:11 UTC
@Rainer:
Why should "Of course (?) key names stay in German"?  If I switch in the language settings to US English for the menu, that I would expect that there are now no German menu and dialog box entries?

If I now take a look at the SHORTCUT KEYS section in the upper half of the KEYBOARD tab in the CUSTOMIZE dialog box, then I have there if (I scroll down) for instance entries like "Nach-Unten" = "To Line Below" or "Umschalt+F4" = "To Next Frame", etc.  I would expect that these entries are all in English.

If I switch to the CATEGORY = FORMAT (in FUNCTIONS pane) in the bottom half of the KEYBOARD tab in the dialog box CUSTOMIZE, then I have there as KEYS for the FUNCTION "Align Left" = "Strg+L" instead of "Ctrl+L" and in the CATEGORY = NAVIGATE as KEYS for the FUNCTION "Edit Footnoote/Endnote" = "Strg+Umschalt+Bild-Nach-Unten".
Comment 6 Rainer Bielefeld Retired 2013-04-22 05:17:32 UTC
This is a feature, not a bug. The language of the key names is related to the OS WIN keyboard setting. If you change in WIN settings "Systemsteuerung -> Region und Sprache -> Tastaturen und Sprachen -> Tastaturen ändern - Standardeingabesprache' from "German" to "English" you will see the key names in English (even with German LibO UI) after next Launch of LibO. That seems plausible to me, because so the dialog shows the real key names visible on the keyboard. On a German keyboard the <Control> key still will show <Strg> on the key even after you changed LibO UI to "English". 

So with scope of original report NOTABUG.

But if you can contribute good reasons, of course we can think about en Enhancement for an option "Use language xyz for keys different from OS settings", I think that would more or less be a be a DUP of "Bug 54165 - Unable to localize key names"? Unfortunately I can't find Help for the fix for that Bug. ("Bug 63793 - LOCALHELP missing for 'Tools - Options - Language Settings - Languages - Enhanced Language Support' "?)

*** This bug has been marked as a duplicate of bug 54165 ***