Bug Hunting Session
Bug 63805 - EDITING: 'Autofill - Date - Months' wrong if day of month exceeds max. days of month
Summary: EDITING: 'Autofill - Date - Months' wrong if day of month exceeds max. days o...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: BSA target:4.1.0 target:3.6.7 target:...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-04-22 14:32 UTC by Kranthi Katikala
Modified: 2018-05-09 04:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kranthi Katikala 2013-04-22 14:32:48 UTC
Problem description: 
The autofill command for series type:month malfunctions
Steps to reproduce:
1.  set up shortcut for category:edit>function>fill series
1.1 type in continuous cells : 1, 2, 3
2.  use shortcut
3.  select Direction:down ; series type:Date ; Time unit:month ;
4.  Select ok

Current behavior:
1
32
63
121
152
183

Expected behavior:
1
32
63
94
125
156
187
and so on.
              
Operating System: Fedora
Version: 3.5.7.2 release
Comment 1 Rainer Bielefeld Retired 2013-04-22 15:34:44 UTC
[Reproducible] with  "LibreOffice 3.6.6.2 release " German UI/ German Locale [Build-ID: f969faf] {pull date 2013-04-03} on German WIN7 Home Premium (64bit)

Steps how to reproduce:
0. Open new Calc document from LibO Start Center
1. Select all cells
2. Menu 'Format -> Cells -> Date -> 1999-12-31'
3. A1: 2012-10-31
4. Select A1:A20, menu 'Edit -> fill -> Series -> Down - Date-Month-Increment=1
   <ok>
   Expected: All Cells show last day of month
   Actual: some months skipped

If I start a series with 2012-10-12 I expect to get a series always showing the 12th day of the next month in the next cell. 
That always will work until Day number exceeds 28, what will give wrong results in February, and if exceeds 30, wrong results for all other Months with less than 31 days. It should be expected that if day number of cell before exceeds number of days for next month, the cell should show the last day of the month. But in case of mistake it seems that LibO simply adds 31 days instead of calculating the appropriate day of month.

Already reproducible with Server Installation of "LibreOffice 3.5.1.2 English UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit) 

Still worked fine with 
* Server Installation (own profile) of "LibreOffice 3.4.5 RC1  - WIN7 Home Premium (64bit) German UI [Build ID: OOO340m1 (Build:501)]", so Regression!
Comment 2 Rainer Bielefeld Retired 2013-04-22 15:39:23 UTC
@Kranthi Katikala:
good shot, thank you for your attention! May be you are interested in testing some of our UNCONFIRMED Bugs?

@Eike:
Is this also your area? Please change Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 3 Eike Rathke 2013-04-22 17:40:31 UTC
(In reply to comment #2)
> Is this also your area? Please change Status to ASSIGNED and add yourself to
> "Assigned To" if you accept this Bug or forward the Bug if it's not your
> turf.

I don't like this concept of "assigned to", it doesn't work. Bugs just pile up at a developer until s/he eventually will find some time to work on it, maybe or maybe not, and others looking for bugs think when seeing "assigned" that someone else is already working on it.
Comment 4 Commit Notification 2013-05-17 12:21:40 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cd9d1bdf5e3351c929d5b651c009ee17b4d962c4

resolved fdo#63805 max day of month of the intended month



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Eike Rathke 2013-05-17 12:34:57 UTC
Pending review
for 4-0 as https://gerrit.libreoffice.org/3938
for 3-6 as https://gerrit.libreoffice.org/3939
Comment 6 Commit Notification 2013-05-17 14:37:30 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e159b9834731a0282e45d8e5f5bbaedb624dc6b&h=libreoffice-3-6

resolved fdo#63805 max day of month of the intended month


It will be available in LibreOffice 3.6.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-05-17 14:38:05 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b183466bcdf56c9221ab28be9c52ed8787fe4ea&h=libreoffice-4-0

resolved fdo#63805 max day of month of the intended month


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-05-17 15:29:49 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=59d6bde4045e928b5d68fb23e3340fa0e48f3e33

obtain days in month from non-normalized date, fdo#63805 related



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-05-17 15:45:01 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=145d46663e2d9872b42cd7d4b8f6f76d672a883f&h=libreoffice-3-6

obtain days in month from non-normalized date, fdo#63805 related


It will be available in LibreOffice 3.6.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-05-17 15:45:18 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c7f6b004cd04f427529968d004405b1a95f74bb&h=libreoffice-4-0

obtain days in month from non-normalized date, fdo#63805 related


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-05-09 04:30:42 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c242335331b7095b17db43a78b91904b507a0a7f

uitest for bug tdf#63805

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.