Bug Hunting Session
Bug 63817 - Base crashes quite frequently, often when re-opening an ODB, with a JRE error
Summary: Base crashes quite frequently, often when re-opening an ODB, with a JRE error
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-22 21:42 UTC by tim
Modified: 2013-08-07 14:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
JRE crash report (129.23 KB, text/plain)
2013-04-22 21:42 UTC, tim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2013-04-22 21:42:28 UTC
Created attachment 78348 [details]
JRE crash report

I have had this problem for many months, on several versions of Base, and of JRE.  I am no closer to determining exactly when it happens or why.  The summary of the fault is:

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f5b371e16db, pid=7128, tid=140029768993024
#
# JRE version: 7.0_21-b11
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.21-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libuno_cppu.so.3+0x2b6db]  uno_type_sequence_reference2One+0x2ab
#
I have attached a sample crash report.  Base quite frequently crashes when I am using the Basic IDE.  I have got used to that, and it doesn'r happen often when using the ODB normally.  However I also find that Base will not open my ODB, even when nothing remiss appears to have happened.  I often have to make 2, 3 or even 4 attempts to open my ODB before it succeeds with recovering, even though I was unaware that there had been a problem.

I am aware this is too unspecific to be of much help, but am raising it in case others are having similar problems not yet reported.

I am on Ubuntu 12.04, LO 3.6.5.2. My ODB currently links to MySQL using the Native connector (it also crashes when I use JDBC). I can't move to LO 4 because of other faults (some events are not working).

I haven't had any JRE crashes with other software.
Comment 1 Julien Nabet 2013-05-04 21:02:39 UTC
Tim: do you have similar problem with hsqldb files?
Is it only with 1 Mysql base or all Mysql bases you have?
What's the Mysql server version?
Is Mysql server on local? (to know if it could be network problem)
Did you run maintenance on Mysql base? (see http://stackoverflow.com/questions/7478849/general-mysql-database-maintenance-advice)
Do you encounter any problem with another Mysql client (eg: phpmyadmin)?

Could it be possible you retrieve a full bt by following this? (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux)
Comment 2 tim 2013-05-05 07:15:19 UTC
Thanks for responding - that's very helpful.

I haven't got any hsqldb files, so I don't know if it happens with them.

I have 2 local mysql databases and it happens with both of them, using jdbc or mysql connector.  I'm now on mysql 5.5.31, but it happened with earlier versions as well.  I will the maintenance as you suggest.

phpmyadmin seems OK.

I can't reproduce the fault, it just happens sometimes.  Base quite often fails to start cleanly, and sometimes crashes when running, but only occasionally does it produce a dump like the one I reported.  I'm unlikely to be able to get a backtrace, but will see what I can do.
Comment 3 Julien Nabet 2013-05-05 07:35:18 UTC
Tim: thank you for your feedback. Did you run maintenance on Mysql Base?

Also, you may give a try to 4.0.2 (4.0.3 will be released in very few days).
Comment 4 tim 2013-05-05 08:05:36 UTC
I will run maintenance later today (I need a little time to make sure I have the right backups).

I can't move to LO 4 at all because of #63398, which is rather a nuisance.
Comment 5 Fred Toussi 2013-05-05 19:22:19 UTC
This is clearly a JRE internal error and unrelated to MySQL. It could be a bug in the JRE or a hardware issue, such as faulty memory.
Comment 6 tim 2013-05-05 19:30:47 UTC
I've had this problem with Base, and only Base, for months, with many (far too many!) versions of JRE.

I've run hardware checks and all seems well.  

I don't have any way of interpreting the crash report.
Comment 7 Julien Nabet 2013-05-05 20:31:38 UTC
Tim: Base is the LO part which uses a lot of Java.
Reading Fred's comment, I wonder about these possibilities:
- other jre than java Hotspot
- a 1.6 version instead of 1.7
- 32 bits instead of 64
But perhaps you've already tried all of them.
Comment 8 tim 2013-05-06 09:03:33 UTC
I started with a 1.6 Jre and then changed to move along with Oracle's releases through many versions of 1.7 to the latest version 21. 

I have to admit I've never deliberately tried a 32 bit version.  As seems to be the way once one tries to analyse a transient fault it hasn't shown itself with crashes for a week or so.  

I'm still plagued by databases randomly refusing to open several times, but have no idea where to start looking for a cause.  I have recreated my user profile from scratch, to no effect.

Since I can't reliably reproduce or demonstrate these problems (I wish I could) I guess I should close this report off.
Comment 9 Julien Nabet 2013-05-06 09:24:21 UTC
Robert: I'm no DB expert, would you have some time to take a look?
Comment 10 Robert Großkopf 2013-05-07 19:27:54 UTC
There are many problems between java and LO since LO 3.5.0 rc2.:
https://bugs.freedesktop.org/show_bug.cgi?id=52170
See also open bugs for other connections to external databases via JDBC:
https://bugs.freedesktop.org/show_bug.cgi?id=63713
https://bugs.freedesktop.org/show_bug.cgi?id=57872
https://bugs.freedesktop.org/show_bug.cgi?id=54730

Seems to be a little tricky to confirm a bug, which could not be reproduced by 
step 1
step 2
...

I have tested a database with many tables and forms. Have tested with LO 3.6.0.4 and LO 3.3.4 (my version for working with databases ...). LO 3.6.0.4 could open and close all tables, couldn't open one form and crashes immediately. This crash I couldn't reproduce with 3.6.6.2, also not with 3.3.4.

I don't know if we should set this bug to unconfirmed, or let the bug in needinfo-status.
Comment 11 Julien Nabet 2013-05-08 07:07:44 UTC
Thank you Robert for your feedback.

Lionel: an opinion about all this?
Comment 12 tim 2013-07-03 13:14:14 UTC
Just to say that I still get theses crashes, on every LO version I have ever tried.

I don't know what other information I can supply, or how to do so.
Comment 13 Julien Nabet 2013-07-03 18:48:14 UTC
Just copy paste from Tim's comment https://bugs.freedesktop.org/show_bug.cgi?id=66239#c8 which is more appropriate here:
"
Using 4.1.0.1, Debian, 32 bit, if I try to open or edit an existing report, built using  3.5/3.6 Report Builder extension, Base just crashes.  

If I try to create a new report using the wizard it says 'No valid report template was found'.

If I open a new one in design mode it appears to work (although I have not pursued this).

I can't easily submit a sample since this application is on mysql.  I am even unable now to run the report on 3.5/6 since the 4.1 report builder has supplanted the compatible extension and I can't download it any more from the extension library (why is that - isn't 3.6.n a valid version any more?). 

All in all I have had to give up entirely on LO reports on Base and create them another way (using the ancient DataVision).  The Report Builder always rather flaky.
"
Comment 14 tim 2013-07-03 19:10:37 UTC
I see my comments of report builder causing crashes has been copied to here.  I'm not sure it's appropriate, since this last comment is very specifically about report builder in 4.1.0.1, not about not being able to even open an ODB at all sometimes in most versions of LO.

Would be be OK to open a brand new bug?
Comment 15 Julien Nabet 2013-07-03 19:15:44 UTC
Just re reading all this and notice I didn't ask you the basics:
- did you install any LO specific extensions?
- could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile) and test again?
Indeed, it seems you had different LO versions (which is ok of course! :-)) but perhaps there might be buggy remnants of older versions.
I don't expect it solves your bug but at least, we'll be sure it's no extensions, buggy remnants.

What's the version of:
- libreoffice-mysql-connector
- libmysqlcppconn7
- libmysql-java
- unixodbc

mine, on pc Debian x86-64 testing, are:
- 1.0.1+LibO4.0.3-3
- 1.1.3-3
- 5.1.16-2
- 2.2.14p2-5
I'm not an expert but these information may help.

Also, still by re reading, I notice you used Oracle jre, did you try openJdk 6 (mine is 6b27-1.12.5-2)?

Finally, if you have some time, would you have another machine where you could install a newer Ubuntu version or just "boot-cd/dvd" on your current machine? (Ubuntu 12.10 or ideally 13.04).
Comment 16 Julien Nabet 2013-07-03 19:16:46 UTC
tim: why not for a brand new bugtracker, no problem for me. Could you give a try first to my previous comment?
Comment 17 Lionel Elie Mamane 2013-07-03 19:51:43 UTC
(In reply to comment #5)
> This is clearly a JRE internal error

I disagree. To me it looks like a crash in C(++) code called from Java code. See the Stack:

 uno_type_sequence_reference

But the information there is rather sparse...
Comment 18 tim 2013-07-03 20:00:45 UTC
This has all got too confused.

I'm not going to raise a fault report about the report builder until I can show that I have a report that will run on 3.n and won't on 4.n.  Currently I can't do that.

LO has basically got into a situation where I cannot run any old reports.  I don't know why.

I have my main ubuntu 12.04 64 bit desktop on which I have reverted to LO 3.5 to get some stability back into my systems and be able to use them reliably. These have reports created using report builder.  These now don't run at all because the report builder extension is not present.  The extension was replaced by the in-built version when I upgraded to 4.1.0.1.  4.1.0.1 crashed as I reported whenever I tried to open an old report.  I now can't get the 3.5 report builder extension from the LO website so I cannot check if the reports work or not on this system.

I have a debian mint 32 bit laptop on which I have tried to maintain an LO 3.6 and a recent 4.1.0.1 version as well.  I can't get the reports to work on that either, probably because of the incompatible report builder extension.

I can't reproduce the problem since that would mean creating a new report, which has it's own problems that Lionel says are now fixed in 4.1.0.2.  I can't ship the complete old version because I can't now even see how the report was built and which queries it employed.  There's quite a few non-trivial mysql tables involved and I'm not terribly inclined to ship them out with data since they hold personal financial information.

Meanwhile, for all I know the reports have been corrupted by multiple incompatible version of LO, as were my dialogs (which I have take a day to reconstruct) and this part of the fault report may therefore be irrelevant.

If I can yet find a copy of a report that used to work, and get a 3.n system running on my ubuntu system with report builder, then I might be able to make progress on the debian laptop with 4.1.01.  Until then I can't see how I can help further.  I'll keep trying for a while.
Comment 19 Lionel Elie Mamane 2013-07-03 20:04:31 UTC
So, for stuff that is not reproducible but "happens sometimes, don't know when", there is not really much I/we can do to investigate.

If you can get your hands on a debug version, or at least a version with symbols, then suddenly your crash reports become much more useful. 't would have to be in a "recent" version, though. Something 4.x is reasonable. For Ubuntu-provided packages, install the package "libreoffice-dbg" and "uno-libs3-dbg" and "ure-dbg". Then in a shell, run "ulimit -c unlimited", and run LibreOffice from this shell with "--norestore" option. This disables the restore mechanism, wich gets in the way of debugging. When it crashes, it will create a file named "core", which you can then use in gdb to get a meaningful backtrace.

I'm sure Julien will be glad to help you get through gdb, and we have some documentation on our wiki. Oh, from looking at the wiki, it looks like it is a bit easier than what I thought:

https://wiki.documentfoundation.org/QA/BugReport#How_to_get_a_backtrace_on_Linux

> Base quite frequently crashes when I am using the Basic IDE.

I use the Basic IDE quite a lot, in all versions from 3.4 to 4.0, no significant crash for me.

> However I also find that Base will not open my ODB, (...)
> I often have to make 2, 3 or even 4 attempts to open
> my ODB before it succeeds with recovering

That sounds familiar to me. My users (on Windows) have that sometimes. What they observe is a freeze of LibreOffice when clicking "OK" or "cancel" on the recovery screen. I have found that the following always gets them through without fail:

Launch LibreOffice *without* opening any file.
Go through the recovery dialog (either OK or cancel).
*Then*, after all recovery is done, open the file you want.
Comment 20 Lionel Elie Mamane 2013-07-03 20:13:27 UTC
(In reply to comment #18)
> I have my main ubuntu 12.04 64 bit desktop on which I have reverted to LO
> 3.5 to get some stability back into my systems and be able to use them
> reliably. These have reports created using report builder.  These now don't
> run at all because the report builder extension is not present.  The
> extension was replaced by the in-built version when I upgraded to 4.1.0.1. 
> I now can't get the 3.5 report builder extension from the LO website

It is *bundled* with LibreOffice. If you installed LibreOffice from Ubuntu packages, it should be in an Ubuntu package.

Where did you get the report builder extension for 3.5 before you upgraded to LibreOffice 4.x?
Comment 21 Lionel Elie Mamane 2013-07-03 20:22:06 UTC
I looked at http://packages.ubuntu.com/ and https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232. It seems Ubuntu disabled the bundled report builder and "fixed" this only in their package of 4.0 version... What a mess...

My question stands:

Where did you get the report builder extension for 3.5 before you upgraded to LibreOffice 4.x?

I'm terribly sorry Ubuntu is serving you so incompletely. You could try the libreoffice.org deb packages from http://www.libreoffice.org/download; or if you want an older version, such as e.g. 3.5, from http://downloadarchive.documentfoundation.org/libreoffice/old/

That's what https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/992232/comments/57 suggests. <shrug>
Comment 22 Lionel Elie Mamane 2013-07-03 20:32:46 UTC
(In reply to comment #18)

> I have a debian mint 32 bit laptop on which I have tried to maintain an LO
> 3.6 and a recent 4.1.0.1 version as well.  I can't get the reports to work
> on that either, probably because of the incompatible report builder
> extension.

Assuming "Debian mint" uses the Debian packages rather than the Ubuntu ones, these contain report builder since the times of 3.5.4, so installing the report builder from packages "should work" in as far as it installs a "compatible report builder extension".
Comment 23 tim 2013-07-03 21:11:44 UTC
(In reply to comment #19)
> So, for stuff that is not reproducible but "happens sometimes, don't know
> when", there is not really much I/we can do to investigate.
> 
> If you can get your hands on a debug version, or at least a version with
> symbols, then suddenly your crash reports become much more useful. 't would
> have to be in a "recent" version, though. Something 4.x is reasonable. For
> Ubuntu-provided packages, install the package "libreoffice-dbg" and
> "uno-libs3-dbg" and "ure-dbg". Then in a shell, run "ulimit -c unlimited",
> and run LibreOffice from this shell with "--norestore" option. This disables
> the restore mechanism, wich gets in the way of debugging. When it crashes,
> it will create a file named "core", which you can then use in gdb to get a
> meaningful backtrace.
> 
> I'm sure Julien will be glad to help you get through gdb, and we have some
> documentation on our wiki. Oh, from looking at the wiki, it looks like it is
> a bit easier than what I thought:
> 
> https://wiki.documentfoundation.org/QA/
> BugReport#How_to_get_a_backtrace_on_Linux
> 
> > Base quite frequently crashes when I am using the Basic IDE.
> 
> I use the Basic IDE quite a lot, in all versions from 3.4 to 4.0, no
> significant crash for me.
> 
> > However I also find that Base will not open my ODB, (...)
> > I often have to make 2, 3 or even 4 attempts to open
> > my ODB before it succeeds with recovering
> 
> That sounds familiar to me. My users (on Windows) have that sometimes. What
> they observe is a freeze of LibreOffice when clicking "OK" or "cancel" on
> the recovery screen. I have found that the following always gets them
> through without fail:
> 
> Launch LibreOffice *without* opening any file.
> Go through the recovery dialog (either OK or cancel).
> *Then*, after all recovery is done, open the file you want.

But why does it freeze so often, even when the odb is closed normally?  It's really quite irritating.

I'm really not able to hack around with version 4.anything on my main system.  I need a working system, and 4 isn't there yet - sorry. I'm sure it will be, but not for me yet.  My attempts to have a 3.n and 4.n on my laptop at the same time produces ambiguous results, with problems possibly due to having both systems installed.
Comment 24 tim 2013-07-03 21:13:49 UTC
(In reply to comment #20)
> (In reply to comment #18)
> > I have my main ubuntu 12.04 64 bit desktop on which I have reverted to LO
> > 3.5 to get some stability back into my systems and be able to use them
> > reliably. These have reports created using report builder.  These now don't
> > run at all because the report builder extension is not present.  The
> > extension was replaced by the in-built version when I upgraded to 4.1.0.1. 
> > I now can't get the 3.5 report builder extension from the LO website
> 
> It is *bundled* with LibreOffice. If you installed LibreOffice from Ubuntu
> packages, it should be in an Ubuntu package.
> 
> Where did you get the report builder extension for 3.5 before you upgraded
> to LibreOffice 4.x?
I don't seem to have any version installed now, and cannot find one anywhere. 

I'm pretty sure I downloaded the extension from the LO website for 3.5, but nothing is there now.  I normally keeps copies, but I can't find it.
Comment 25 tim 2013-07-03 21:59:56 UTC
To try and move this forward I have moved my ubuntu 12.04 64-bit desktop system to 3.6.6.2, (first purging any sight of any other version).  Report builder is included and my old Base report-builder reports worked 1st time.  As I said before I'm not going to try 4.n again on this system for a while.


Tomorrow I will try to run these odbs on 4.1.0.1 on my debian 32-bit laptop.  If they fail I'll try to emulate with HSQL.  I'll then raise a new report, and leave this fault report to the 'fail to open ODB' issues (closing off any report-builder issues which didn't really belong here).
Comment 26 tim 2013-07-04 12:14:04 UTC
I have managed to replicate the Base report builder crash in a predictable fashion.  See #66582.

I propose to close this report, having got rather off track and not having enough information to pin anything down. 

If I manage to get any more information that looks reproducible enough, I'll open another report.  Is that OK?
Comment 27 tim 2013-08-07 14:51:26 UTC
I am now using LO 4.1  I am not now getting this error with any frequency, so have set it to Resolved.  

I trust that's OK.