Bug 63834 - PDFIMPORT bullets disappear
Summary: PDFIMPORT bullets disappear
Status: RESOLVED DUPLICATE of bug 61393
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Import-Draw
  Show dependency treegraph
 
Reported: 2013-04-23 09:57 UTC by Lionel Elie Mamane
Modified: 2016-06-26 10:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
reproduction case (11.67 KB, application/pdf)
2013-04-23 09:57 UTC, Lionel Elie Mamane
Details
screenshot: how it looks in Draw (5.07 KB, image/png)
2013-04-23 10:02 UTC, Lionel Elie Mamane
Details
screenshot: how it looks in a PDF viewer (3.72 KB, image/png)
2013-04-23 10:03 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2013-04-23 09:57:37 UTC
Created attachment 78362 [details]
reproduction case

Open the attached PDF in LibreOffice (with the bundled PDFImport). It opens in Draw.

1) The underlined text is crossed instead (the underlining line is *over*
   the text instead of *under* the text).

2) The triangular bullets have disappeared.


Bug reproduced with:

1) LibreOffice 3.5.7 under MS Windows
2) LibreOffice 3.6.3.2 (Build ID: 58f22d5) on Debian GNU/Linux,
   TDF official x86-64 build deb packages
3) LibreOffice 4.0 my own development tree on Debian GNU/Linux
4) LibreOffice 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) on Debian GNU/Linux,
   TDF official x86-64 build deb packages
5) LibreOffice-pdfimport 1.0.5+LibO3.5.4+dfsg-4
   Debian package slated for wheezy (the next release in a few weeks)
Comment 1 Lionel Elie Mamane 2013-04-23 10:02:59 UTC
Created attachment 78363 [details]
screenshot: how it looks in Draw
Comment 2 Lionel Elie Mamane 2013-04-23 10:03:27 UTC
Created attachment 78364 [details]
screenshot: how it looks in a PDF viewer
Comment 3 m.a.riosv 2013-04-23 18:33:44 UTC
Reproducible:
Win7x64 Ultimate
LibreOffice Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39)
Comment 4 vvort 2014-05-20 06:11:43 UTC
Underlined text problem will be fixed within Bug 78689
Comment 5 vvort 2014-05-26 06:48:21 UTC
Bullet problem is related to symbol fonts.
In PDF this bullets are recorded as character 001 in embedded font #N.
There is no translation to Unicode or even to char code within system font.

We need either - to implement font embedding or to import this characters as polygons.
Comment 6 QA Administrators 2015-06-08 14:42:47 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.3 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results;
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-06-08
Comment 7 Buovjaga 2015-08-02 10:37:05 UTC
Confirmed bullets disappear.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 902255645328efde34ddf62227c8278e8dd61ff0
TinderBox: Win-x86@39, Branch:master, Time: 2015-07-30_03:52:07
Locale: en-US (fi_FI)
Comment 8 vvort 2016-06-26 10:46:27 UTC

*** This bug has been marked as a duplicate of bug 61393 ***