Bug Hunting Session
Bug 63901 - Not pasting number after copy from numbered paragraph
Summary: Not pasting number after copy from numbered paragraph
Status: RESOLVED DUPLICATE of bug 49076
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-25 03:37 UTC by Charles
Modified: 2016-02-16 20:52 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles 2013-04-25 03:37:59 UTC
It would be nice to be able to configure whether the paragraph number is put in the general paste buffer after copying text from a numbered paragraph.

An example may make that clearer.  Suppose there's a numbered list:

1. item one 
2. item two 
3. item three 

The user selects the word "one" and copies it using Ctrl+c.  The user goes to a non LibreOffice program's window, say a terminal emulator or a simple text editor and uses Ctrl+v to paste.  The pasted text is "1. one".  

This enhancement request is to make LibreOffice configurable so, in the above example, it would paste not "1. one" but "one".

Two use cases:

* A software procedure has been written in Writer with steps in a numbered list.  The text includes commands to be executed at the command prompt.  The existing LibreOffice behaviour means the user cannot copy commands from the Writer document for execution in the terminal emulator without having to manually delete the paragraph numbers after pasting.

* A Writer user wants to copy a few words from within a numbered paragraph, strip applied formatting, paste and edit it.  When they use "Paste Unformatted", the applied formatting is stripped but the unwanted paragraph numbers remain and have to be manually deleted.  The "1. one" example above is of this type.

* As above except the user wants to copy text including numbered paragraphs (say lists and headings), strip applied formatting and edit it.  When they use "Paste Unformatted", the applied formatting is stripped but the unwanted paragraph numbers remain and have to be manually deleted.
Comment 1 Brenda Granados 2013-04-27 12:10:02 UTC
Hi, thank you for submitting your ideas about LibreOffice functionality. I have seen this issue mentioned a couple of times before. I am marking this as a duplicate of Bug 49076.

Version: 4.0.3.1
Platform: Ubuntu 13.04 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39)

- Brenda

-------------------------------
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link: https://wiki.documentfoundation.org/QA/BugTriage
There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists

*** This bug has been marked as a duplicate of bug 49076 ***